Upstream information

CVE-2019-6133 at MITRE

Description

In PolicyKit (aka polkit) 0.115, the "start time" protection mechanism can be bypassed because fork() is not atomic, and therefore authorization decisions are improperly cached. This is related to lack of uid checking in polkitbackend/polkitbackendinteractiveauthority.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.7 6.7
Vector AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity High High
Privileges Required Low Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entries: 1070943 [IN_PROGRESS], 1121826 [NEW], 1121872 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2035
SUSE Enterprise Storage 4
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-Storage-4-2019-2035
SUSE Enterprise Storage 5
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-Storage-5-2019-2035
SUSE Linux Enterprise Desktop 12 SP4
  • libpolkit0 >= 0.113-5.18.1
  • libpolkit0-32bit >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2035
SUSE Linux Enterprise Module for Basesystem 15
  • libpolkit0 >= 0.114-3.9.1
  • polkit >= 0.114-3.9.1
  • polkit-devel >= 0.114-3.9.1
  • typelib-1_0-Polkit-1_0 >= 0.114-3.9.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2018
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libpolkit0 >= 0.114-3.9.1
  • polkit >= 0.114-3.9.1
  • polkit-devel >= 0.114-3.9.1
  • typelib-1_0-Polkit-1_0 >= 0.114-3.9.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2018
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • polkit >= 0.114-3.9.1
  • polkit-doc >= 0.114-3.9.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2018
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libpolkit0-32bit >= 0.114-3.9.1
  • polkit >= 0.114-3.9.1
  • polkit-doc >= 0.114-3.9.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2018
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2035
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2035
SUSE Linux Enterprise Server 12 SP2-BCL
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2035
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2035
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2035
SUSE Linux Enterprise Server 12 SP3-BCL
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2035
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2035
SUSE Linux Enterprise Server 12 SP3-LTSS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2035
SUSE Linux Enterprise Server 12 SP4
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2035
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2035
SUSE Linux Enterprise Software Development Kit 12 SP4
  • polkit >= 0.113-5.18.1
  • polkit-devel >= 0.113-5.18.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2035
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libpolkit0-32bit >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
Patchnames:
SUSE-SLE-WE-12-SP4-2019-2035
SUSE OpenStack Cloud 7
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2035
SUSE OpenStack Cloud 8
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2035
SUSE OpenStack Cloud Crowbar 8
  • libpolkit0 >= 0.113-5.18.1
  • polkit >= 0.113-5.18.1
  • typelib-1_0-Polkit-1_0 >= 0.113-5.18.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2035
openSUSE Leap 15.0
  • libpolkit0 >= 0.114-lp150.2.10.1
  • libpolkit0-32bit >= 0.114-lp150.2.10.1
  • libpolkit0-32bit-debuginfo >= 0.114-lp150.2.10.1
  • libpolkit0-debuginfo >= 0.114-lp150.2.10.1
  • polkit >= 0.114-lp150.2.10.1
  • polkit-debuginfo >= 0.114-lp150.2.10.1
  • polkit-debugsource >= 0.114-lp150.2.10.1
  • polkit-devel >= 0.114-lp150.2.10.1
  • polkit-devel-debuginfo >= 0.114-lp150.2.10.1
  • polkit-doc >= 0.114-lp150.2.10.1
  • typelib-1_0-Polkit-1_0 >= 0.114-lp150.2.10.1
Patchnames:
openSUSE-2019-1914
openSUSE Leap 15.1
  • libpolkit0 >= 0.114-lp151.5.3.1
  • libpolkit0-32bit >= 0.114-lp151.5.3.1
  • libpolkit0-32bit-debuginfo >= 0.114-lp151.5.3.1
  • libpolkit0-debuginfo >= 0.114-lp151.5.3.1
  • polkit >= 0.114-lp151.5.3.1
  • polkit-debuginfo >= 0.114-lp151.5.3.1
  • polkit-debugsource >= 0.114-lp151.5.3.1
  • polkit-devel >= 0.114-lp151.5.3.1
  • polkit-devel-debuginfo >= 0.114-lp151.5.3.1
  • polkit-doc >= 0.114-lp151.5.3.1
  • typelib-1_0-Polkit-1_0 >= 0.114-lp151.5.3.1
Patchnames:
openSUSE-2019-1914


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 polkit Affected
SUSE Linux Enterprise Desktop 12 SP4 polkit Released
SUSE Linux Enterprise High Performance Computing 12 polkit Released
SUSE Linux Enterprise Module for Basesystem 15 GA polkit Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 polkit Released
SUSE Linux Enterprise SDK 11 SP4 PolicyKit Not affected
SUSE Linux Enterprise SDK 12 SP3 polkit Affected
SUSE Linux Enterprise SDK 12 SP4 polkit Released
SUSE Linux Enterprise Server 11 SP3 LTSS PolicyKit Not affected
SUSE Linux Enterprise Server 11 SP4 PolicyKit Not affected
SUSE Linux Enterprise Server 12 GA LTSS polkit Affected
SUSE Linux Enterprise Server 12 SP1 LTSS polkit Released
SUSE Linux Enterprise Server 12 SP2 LTSS polkit Released
SUSE Linux Enterprise Server 12 SP3 polkit Affected
SUSE Linux Enterprise Server 12 SP4 polkit Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 PolicyKit Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA polkit Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 polkit Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 polkit Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 polkit Released
SUSE Linux Enterprise Workstation Extension 12 SP3 polkit Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 polkit Released