Upstream information

CVE-2019-6110 at MITRE

Description

In OpenSSH 7.9, due to accepting and displaying arbitrary stderr output from the server, a malicious server (or Man-in-The-Middle attacker) can manipulate the client output, for example to use ANSI control codes to hide additional files being transferred.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:H/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.8 4.6
Vector AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L
Access Vector Network Network
Access Complexity High Low
Privileges Required None Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High Low
Availability Impact None Low
SUSE Bugzilla entries: 1121571 [IN_PROGRESS], 1121816 [NEW], 1121818 [NEW], 1121821 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • openssh >= 7.2p2-74.35.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-132
SUSE CaaS Platform 3.0
  • openssh >= 7.2p2-74.35.1
Patchnames:
SUSE-CAASP-3.0-2019-132
SUSE CaaS Platform ALL
  • openssh >= 7.2p2-74.35.1
Patchnames:
SUSE-CAASP-ALL-2019-132
SUSE Enterprise Storage 4
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-Storage-4-2019-132
SUSE Linux Enterprise Desktop 12 SP3
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-132
SUSE Linux Enterprise Desktop 12 SP4
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-132
SUSE Linux Enterprise Module for Basesystem 15
  • openssh >= 7.6p1-9.13.1
  • openssh-helpers >= 7.6p1-9.13.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-126
SUSE Linux Enterprise Module for Desktop Applications 15
  • openssh-askpass-gnome >= 7.6p1-9.13.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-126
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • openssh >= 7.6p1-9.13.1
  • openssh-cavs >= 7.6p1-9.13.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-126
SUSE Linux Enterprise Module for Server Applications 15
  • openssh >= 7.6p1-9.13.1
  • openssh-fips >= 7.6p1-9.13.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-126
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-132
SUSE Linux Enterprise Server 11 SP4
  • openssh >= 6.6p1-36.12.1
  • openssh-askpass-gnome >= 6.6p1-36.12.1
  • openssh-fips >= 6.6p1-36.12.1
  • openssh-helpers >= 6.6p1-36.12.1
Patchnames:
slessp4-openssh-13931
SUSE Linux Enterprise Server 12 SP1-LTSS
  • openssh >= 6.6p1-54.26.1
  • openssh-askpass-gnome >= 6.6p1-54.26.1
  • openssh-fips >= 6.6p1-54.26.1
  • openssh-helpers >= 6.6p1-54.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-125
SUSE Linux Enterprise Server 12 SP2-BCL
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-132
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-132
SUSE Linux Enterprise Server 12 SP2-LTSS
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-132
SUSE Linux Enterprise Server 12 SP3
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-132
SUSE Linux Enterprise Server 12 SP4
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-132
SUSE Linux Enterprise Server 12-LTSS
  • openssh >= 6.6p1-54.26.1
  • openssh-askpass-gnome >= 6.6p1-54.26.1
  • openssh-fips >= 6.6p1-54.26.1
  • openssh-helpers >= 6.6p1-54.26.1
Patchnames:
SUSE-SLE-SERVER-12-2019-125
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • openssh >= 6.6p1-36.12.1
  • openssh-askpass-gnome >= 6.6p1-36.12.1
  • openssh-fips >= 6.6p1-36.12.1
  • openssh-helpers >= 6.6p1-36.12.1
Patchnames:
slessp4-openssh-13931
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • openssh >= 6.6p1-54.26.1
  • openssh-askpass-gnome >= 6.6p1-54.26.1
  • openssh-fips >= 6.6p1-54.26.1
  • openssh-helpers >= 6.6p1-54.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-125
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-132
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-132
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-132
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-132
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-132
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-132
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • openssh >= 6.6p1-54.26.1
  • openssh-askpass-gnome >= 6.6p1-54.26.1
  • openssh-fips >= 6.6p1-54.26.1
  • openssh-helpers >= 6.6p1-54.26.1
Patchnames:
SUSE-SLE-SERVER-12-2019-125
SUSE OpenStack Cloud 7
  • openssh >= 7.2p2-74.35.1
  • openssh-askpass-gnome >= 7.2p2-74.35.1
  • openssh-fips >= 7.2p2-74.35.1
  • openssh-helpers >= 7.2p2-74.35.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-132
openSUSE Leap 15.0
  • openssh >= 7.6p1-lp150.8.9.1
  • openssh-askpass-gnome >= 7.6p1-lp150.8.9.1
  • openssh-askpass-gnome-debuginfo >= 7.6p1-lp150.8.9.1
  • openssh-cavs >= 7.6p1-lp150.8.9.1
  • openssh-cavs-debuginfo >= 7.6p1-lp150.8.9.1
  • openssh-debuginfo >= 7.6p1-lp150.8.9.1
  • openssh-debugsource >= 7.6p1-lp150.8.9.1
  • openssh-fips >= 7.6p1-lp150.8.9.1
  • openssh-helpers >= 7.6p1-lp150.8.9.1
  • openssh-helpers-debuginfo >= 7.6p1-lp150.8.9.1
Patchnames:
openSUSE-2019-91
openSUSE Leap 42.3
  • openssh >= 7.2p2-29.1
  • openssh-askpass-gnome >= 7.2p2-29.1
  • openssh-askpass-gnome-debuginfo >= 7.2p2-29.1
  • openssh-cavs >= 7.2p2-29.1
  • openssh-cavs-debuginfo >= 7.2p2-29.1
  • openssh-debuginfo >= 7.2p2-29.1
  • openssh-debugsource >= 7.2p2-29.1
  • openssh-fips >= 7.2p2-29.1
  • openssh-helpers >= 7.2p2-29.1
  • openssh-helpers-debuginfo >= 7.2p2-29.1
Patchnames:
openSUSE-2019-93


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 openssh Affected
CaaS Platform 3.0 openssh Affected
OpenStack Cloud Magnum Orchestration 7.0 openssh Affected
SUSE Linux Enterprise Desktop 12 SP3 openssh Affected
SUSE Linux Enterprise Desktop 12 SP4 openssh Affected
SUSE Linux Enterprise High Performance Computing 12 openssh Affected
SUSE Linux Enterprise Module for Basesystem 15 GA openssh Affected
SUSE Linux Enterprise Module for Server Applications 15 GA openssh Affected
SUSE Linux Enterprise Security Module 11.3 GA openssh-openssl1 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssh Affected
SUSE Linux Enterprise Server 11 SP4 openssh Affected
SUSE Linux Enterprise Server 12 GA LTSS openssh Affected
SUSE Linux Enterprise Server 12 SP1 LTSS openssh Affected
SUSE Linux Enterprise Server 12 SP2 LTSS openssh Affected
SUSE Linux Enterprise Server 12 SP3 openssh Affected
SUSE Linux Enterprise Server 12 SP4 openssh Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA openssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssh Affected