Upstream information

CVE-2019-5419 at MITRE

Description

There is a possible denial of service vulnerability in Action View (Rails)

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1129271 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.9-7.6.1
  • rubygem-actionpack-4_2 >= 4.2.9-7.6.1
Patchnames:
SUSE-Storage-4-2019-915
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-3.3.1
  • rubygem-actionpack-5_1 >= 5.1.4-3.3.1
Patchnames:
SUSE-SLE-Product-HA-15-2019-1090
SUSE Linux Enterprise High Availability 15 SP1
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-3.3.1
Patchnames:
SUSE Linux Enterprise High Availability 15 SP1 GA ruby2.5-rubygem-actionpack-5_1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • ruby2.5-rubygem-actionpack-doc-5_1 >= 5.1.4-3.3.1
  • rubygem-actionpack-5_1 >= 5.1.4-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1090
SUSE Linux Enterprise Module for Public Cloud 15 SP1
  • rmt-server >= 2.3.1-3.3.3
  • rmt-server-pubcloud >= 2.3.1-3.3.3
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP1-2019-1973
SUSE Linux Enterprise Module for Server Applications 15
  • rmt-server >= 2.1.4-3.17.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-1381
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • rmt-server >= 2.3.1-3.3.3
  • rmt-server-config >= 2.3.1-3.3.3
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2019-1973
SUSE OpenStack Cloud 7
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.9-7.6.1
  • rubygem-actionpack-4_2 >= 4.2.9-7.6.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-915
SUSE OpenStack Cloud Crowbar 8
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.9-7.6.1
  • rubygem-actionpack-4_2 >= 4.2.9-7.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-915
openSUSE Leap 15.0
  • rmt-server >= 2.1.4-lp150.2.16.1
  • rmt-server-debuginfo >= 2.1.4-lp150.2.16.1
  • rmt-server-pubcloud >= 2.1.4-lp150.2.16.1
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-lp150.2.3.1
  • ruby2.5-rubygem-actionpack-doc-5_1 >= 5.1.4-lp150.2.3.1
  • rubygem-actionpack-5_1 >= 5.1.4-lp150.2.3.1
Patchnames:
openSUSE-2019-1344
openSUSE-2019-1527
openSUSE Leap 15.1
  • rmt-server >= 2.3.1-lp151.2.3.1
  • rmt-server-config >= 2.3.1-lp151.2.3.1
  • rmt-server-debuginfo >= 2.3.1-lp151.2.3.1
  • rmt-server-debugsource >= 2.3.1-lp151.2.3.1
  • rmt-server-pubcloud >= 2.3.1-lp151.2.3.1
Patchnames:
openSUSE-2019-1824


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability 15 GA rubygem-actionpack-5_1 Released
SUSE Openstack Cloud 6 rubygem-actionpack-4_2 Affected
SUSE Openstack Cloud 7 rubygem-actionpack-4_2 Released
SUSE Openstack Cloud 8 rubygem-actionpack-4_2 Released
SUSE Storage 4 rubygem-actionpack-4_2 Released