Upstream information

CVE-2019-5052 at MITRE

Description

An exploitable integer overflow vulnerability exists when loading a PCX file in SDL2_image 2.0.4. A specially crafted file can cause an integer overflow, resulting in too little memory being allocated, which can lead to a buffer overflow and potential code execution. An attacker can provide a specially crafted image file to trigger this vulnerability.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1140421 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • SDL2_image >= 2.0.5-lp150.9.1
  • SDL2_image-debugsource >= 2.0.5-lp150.9.1
  • SDL_image >= 1.2.12+hg695-lp150.2.3.1
  • SDL_image-debugsource >= 1.2.12+hg695-lp150.2.3.1
  • libSDL2_image-2_0-0 >= 2.0.5-lp150.9.1
  • libSDL2_image-2_0-0-32bit >= 2.0.5-lp150.9.1
  • libSDL2_image-2_0-0-32bit-debuginfo >= 2.0.5-lp150.9.1
  • libSDL2_image-2_0-0-debuginfo >= 2.0.5-lp150.9.1
  • libSDL2_image-devel >= 2.0.5-lp150.9.1
  • libSDL2_image-devel-32bit >= 2.0.5-lp150.9.1
  • libSDL_image-1_2-0 >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-1_2-0-32bit >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-1_2-0-32bit-debuginfo >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-1_2-0-debuginfo >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-devel >= 1.2.12+hg695-lp150.2.3.1
  • libSDL_image-devel-32bit >= 1.2.12+hg695-lp150.2.3.1
Patchnames:
openSUSE-2019-2070
openSUSE-2019-2071
openSUSE Leap 15.1
  • SDL2_image >= 2.0.5-lp151.2.5.1
  • SDL2_image-debugsource >= 2.0.5-lp151.2.5.1
  • SDL_image >= 1.2.12+hg695-lp151.3.3.1
  • SDL_image-debugsource >= 1.2.12+hg695-lp151.3.3.1
  • libSDL2_image-2_0-0 >= 2.0.5-lp151.2.5.1
  • libSDL2_image-2_0-0-32bit >= 2.0.5-lp151.2.5.1
  • libSDL2_image-2_0-0-32bit-debuginfo >= 2.0.5-lp151.2.5.1
  • libSDL2_image-2_0-0-debuginfo >= 2.0.5-lp151.2.5.1
  • libSDL2_image-devel >= 2.0.5-lp151.2.5.1
  • libSDL2_image-devel-32bit >= 2.0.5-lp151.2.5.1
  • libSDL_image-1_2-0 >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-1_2-0-32bit >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-1_2-0-32bit-debuginfo >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-1_2-0-debuginfo >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-devel >= 1.2.12+hg695-lp151.3.3.1
  • libSDL_image-devel-32bit >= 1.2.12+hg695-lp151.3.3.1
Patchnames:
openSUSE-2019-2070
openSUSE-2019-2071