Upstream information

CVE-2019-4732 at MITRE

Description

IBM SDK, Java Technology Edition Version 7.0.0.0 through 7.0.10.55, 7.1.0.0 through 7.1.4.55, and 8.0.0.0 through 8.0.6.0 could allow a local authenticated attacker to execute arbitrary code on the system, caused by DLL search order hijacking vulnerability in Microsoft Windows client. By placing a specially-crafted file in a compromised folder, an attacker could exploit this vulnerability to execute arbitrary code on the system. IBM X-Force ID: 172618.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required High
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1162972 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
HPE-Helion-OpenStack-8-2020-528
SUSE Enterprise Storage 5
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-Storage-5-2020-528
SUSE Linux Enterprise Module for Legacy 15 SP1
  • java-1_8_0-ibm >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-3.33.2
Patchnames:
SUSE-SLE-Module-Legacy-15-SP1-2020-466
SUSE Linux Enterprise Module for Legacy 15 SP2
  • java-1_8_0-ibm >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-3.33.2
SUSE Linux Enterprise Module for Legacy 15
  • java-1_8_0-ibm >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-3.33.2
Patchnames:
SUSE-SLE-Module-Legacy-15-2020-466
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • java-1_8_0-ibm >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-32bit >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-demo >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-devel-32bit >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-src >= 1.8.0_sr6.5-3.33.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-466
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-528
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2020-528
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-528
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-528
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-528
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-528
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-528
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-528
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-528
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-528
SUSE Linux Enterprise Server 15-LTSS
  • java-1_8_0-ibm >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-3.33.2
Patchnames:
SUSE-SLE-Product-SLES-15-2020-466
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2020-528
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-528
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-528
SUSE Linux Enterprise Server for SAP Applications 15
  • java-1_8_0-ibm >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-3.33.2
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-3.33.2
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-466
SUSE Linux Enterprise Software Development Kit 12 SP4
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-528
SUSE Linux Enterprise Software Development Kit 12 SP5
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-528
SUSE OpenStack Cloud 7
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-528
SUSE OpenStack Cloud 8
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-528
SUSE OpenStack Cloud Crowbar 8
  • java-1_8_0-ibm >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr6.5-30.63.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr6.5-30.63.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-528


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 SP4 java-1_8_0-ibm Released
SUSE Linux Enterprise High Performance Computing 12 SP5 java-1_8_0-ibm Released
SUSE Linux Enterprise Module for Legacy 15 java-1_8_0-ibm Released
SUSE Linux Enterprise Module for Legacy 15 SP1 java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12 SP1 LTSS java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12 SP2 BCL java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12 SP2 LTSS java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12 SP3 BCL java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12 SP3 LTSS java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12 SP4 java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12 SP5 java-1_8_0-ibm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 java-1_8_0-ibm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 java-1_8_0-ibm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 java-1_8_0-ibm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 java-1_8_0-ibm Released
SUSE Linux Enterprise Software Development Kit 12 SP4 java-1_8_0-ibm Released
SUSE Linux Enterprise Software Development Kit 12 SP5 java-1_8_0-ibm Released