Upstream information

CVE-2019-3881 at MITRE

Description

Bundler prior to 2.1.0 uses a predictable path in /tmp/, created with insecure permissions as a storage location for gems, if locations under the user's home directory are not available. If Bundler is used in a scenario where the user does not have a writable home directory, an attacker could place malicious code in this directory that would be later loaded and executed.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7 6.7
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity High High
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1143436 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • ruby2.5-rubygem-bundler >= 1.16.1-3.3.1
  • rubygem-bundler >= 1.16.1-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-1582
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • ruby2.5-rubygem-bundler >= 1.16.1-3.3.1
  • rubygem-bundler >= 1.16.1-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2020-1582
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ruby2.5-rubygem-bundler-doc >= 1.16.1-3.3.1
  • rubygem-bundler >= 1.16.1-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1582
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • ruby2.5-rubygem-bundler-doc >= 1.16.1-3.3.1
  • rubygem-bundler >= 1.16.1-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-1582
openSUSE Leap 15.1
  • ruby2.5-rubygem-bundler >= 1.16.1-lp151.3.3.1
  • ruby2.5-rubygem-bundler-doc >= 1.16.1-lp151.3.3.1
  • rubygem-bundler >= 1.16.1-lp151.3.3.1
Patchnames:
openSUSE-2020-803
openSUSE Leap 15.2
  • ruby2.5-rubygem-bundler >= 1.16.1-lp152.4.3.1
  • ruby2.5-rubygem-bundler-doc >= 1.16.1-lp152.4.3.1
  • rubygem-bundler >= 1.16.1-lp152.4.3.1
Patchnames:
openSUSE-2020-861


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications rubygem-bundler Not affected
SUSE Enterprise Storage 4 rubygem-bundler Not affected
SUSE Lifecycle Management Server 1.3 rubygem-bundler Not affected
SUSE Linux Enterprise 15 Module for Basesystem rubygem-bundler Affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem rubygem-bundler Released
SUSE Linux Enterprise 15-SP2 Module for Basesystem rubygem-bundler Released
SUSE Linux Enterprise High Availability Extension 11 SP4 rubygem-bundler Not affected
SUSE Linux Enterprise High Availability Extension 12 rubygem-bundler Not affected
SUSE Linux Enterprise High Availability Extension 12 SP1 rubygem-bundler Not affected
SUSE Linux Enterprise High Availability Extension 12 SP2 rubygem-bundler Not affected
SUSE Linux Enterprise High Availability Extension 12 SP3 rubygem-bundler Not affected
SUSE Linux Enterprise High Availability Extension 12 SP4 rubygem-bundler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 rubygem-bundler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 rubygem-bundler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 rubygem-bundler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 rubygem-bundler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 rubygem-bundler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 rubygem-bundler Not affected
SUSE OpenStack Cloud 6 LTSS rubygem-bundler Not affected
SUSE OpenStack Cloud 7 rubygem-bundler Not affected
SUSE OpenStack Cloud Crowbar 8 rubygem-bundler Not affected
SUSE OpenStack Cloud Crowbar 9 rubygem-bundler Not affected