Upstream information

CVE-2019-3820 at MITRE

Description

It was discovered that the gnome-shell lock screen since version 3.15.91 did not properly restrict all contextual actions. An attacker with physical access to a locked workstation could invoke certain keyboard shortcuts, and potentially other actions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.3 5.1
Vector AV:P/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L AV:P/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
Access Vector Physical Physical
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact Low Low
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entry: 1124493 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-browser-plugin >= 3.20.4-77.23.1
  • gnome-shell-calendar >= 3.20.4-77.23.1
  • gnome-shell-lang >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-1390
SUSE Linux Enterprise Desktop 12 SP4
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-browser-plugin >= 3.20.4-77.23.1
  • gnome-shell-calendar >= 3.20.4-77.23.1
  • gnome-shell-lang >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1390
SUSE Linux Enterprise Module for Desktop Applications 15
  • gnome-shell >= 3.26.2+20180130.0d9c74212-4.19.2
  • gnome-shell-devel >= 3.26.2+20180130.0d9c74212-4.19.2
  • gnome-shell-lang >= 3.26.2+20180130.0d9c74212-4.19.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-1459
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • gnome-shell >= 3.26.2+20180130.0d9c74212-4.19.2
  • gnome-shell-devel >= 3.26.2+20180130.0d9c74212-4.19.2
  • gnome-shell-lang >= 3.26.2+20180130.0d9c74212-4.19.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-1459
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • gnome-shell >= 3.26.2+20180130.0d9c74212-4.19.2
  • gnome-shell-browser-plugin >= 3.26.2+20180130.0d9c74212-4.19.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1459
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • gnome-shell >= 3.26.2+20180130.0d9c74212-4.19.2
  • gnome-shell-browser-plugin >= 3.26.2+20180130.0d9c74212-4.19.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1459
SUSE Linux Enterprise Server 12 SP3
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-browser-plugin >= 3.20.4-77.23.1
  • gnome-shell-lang >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1390
SUSE Linux Enterprise Server 12 SP4
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-browser-plugin >= 3.20.4-77.23.1
  • gnome-shell-lang >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1390
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-browser-plugin >= 3.20.4-77.23.1
  • gnome-shell-lang >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1390
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-browser-plugin >= 3.20.4-77.23.1
  • gnome-shell-lang >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1390
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-devel >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1390
SUSE Linux Enterprise Software Development Kit 12 SP4
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-devel >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1390
SUSE Linux Enterprise Workstation Extension 12 SP3
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-calendar >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-WE-12-SP3-2019-1390
SUSE Linux Enterprise Workstation Extension 12 SP4
  • gnome-shell >= 3.20.4-77.23.1
  • gnome-shell-calendar >= 3.20.4-77.23.1
Patchnames:
SUSE-SLE-WE-12-SP4-2019-1390
SUSE Linux Enterprise Workstation Extension 15
  • gnome-shell >= 3.26.2+20180130.0d9c74212-4.19.2
  • gnome-shell-calendar >= 3.26.2+20180130.0d9c74212-4.19.2
Patchnames:
SUSE-SLE-Product-WE-15-2019-1459
SUSE Linux Enterprise Workstation Extension 15 SP1
  • gnome-shell >= 3.26.2+20180130.0d9c74212-4.19.2
  • gnome-shell-calendar >= 3.26.2+20180130.0d9c74212-4.19.2
Patchnames:
SUSE-SLE-Product-WE-15-SP1-2019-1459
openSUSE Leap 15.0
  • gnome-shell >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
  • gnome-shell-browser-plugin >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
  • gnome-shell-browser-plugin-debuginfo >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
  • gnome-shell-calendar >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
  • gnome-shell-calendar-debuginfo >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
  • gnome-shell-debuginfo >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
  • gnome-shell-debugsource >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
  • gnome-shell-devel >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
  • gnome-shell-lang >= 3.26.2+20180130.0d9c74212-lp150.3.16.1
Patchnames:
openSUSE-2019-1582
openSUSE Leap 15.1
  • gnome-shell >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
  • gnome-shell-browser-plugin >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
  • gnome-shell-browser-plugin-debuginfo >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
  • gnome-shell-calendar >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
  • gnome-shell-calendar-debuginfo >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
  • gnome-shell-debuginfo >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
  • gnome-shell-debugsource >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
  • gnome-shell-devel >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
  • gnome-shell-lang >= 3.26.2+20180130.0d9c74212-lp151.7.3.1
Patchnames:
openSUSE-2019-1582
openSUSE Leap 42.3
  • gnome-shell >= 3.20.4-22.1
  • gnome-shell-browser-plugin >= 3.20.4-22.1
  • gnome-shell-browser-plugin-debuginfo >= 3.20.4-22.1
  • gnome-shell-calendar >= 3.20.4-22.1
  • gnome-shell-calendar-debuginfo >= 3.20.4-22.1
  • gnome-shell-debuginfo >= 3.20.4-22.1
  • gnome-shell-debugsource >= 3.20.4-22.1
  • gnome-shell-devel >= 3.20.4-22.1
  • gnome-shell-lang >= 3.20.4-22.1
Patchnames:
openSUSE-2019-1529


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 gnome-shell Released
SUSE Linux Enterprise Desktop 12 SP4 gnome-shell Released
SUSE Linux Enterprise High Performance Computing 12 gnome-shell Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA gnome-shell Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 gnome-shell Released
SUSE Linux Enterprise SDK 12 SP3 gnome-shell Released
SUSE Linux Enterprise SDK 12 SP4 gnome-shell Released
SUSE Linux Enterprise Server 12 GA LTSS gnome-shell Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS gnome-shell Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS gnome-shell Affected
SUSE Linux Enterprise Server 12 SP3 gnome-shell Released
SUSE Linux Enterprise Server 12 SP4 gnome-shell Released
SUSE Linux Enterprise Server for SAP Applications 12 GA gnome-shell Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gnome-shell Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gnome-shell Released
SUSE Linux Enterprise Workstation Extension 12 SP3 gnome-shell Released
SUSE Linux Enterprise Workstation Extension 12 SP4 gnome-shell Released
SUSE Linux Enterprise Workstation Extension 15 GA gnome-shell Released
SUSE Linux Enterprise Workstation Extension 15 SP1 gnome-shell Released