Upstream information

CVE-2019-3816 at MITRE

Description

Openwsman, versions up to and including 2.6.9, are vulnerable to arbitrary file disclosure because the working directory of openwsmand daemon was set to root directory. A remote, unauthenticated attacker can exploit this vulnerability by sending a specially crafted HTTP request to openwsman server.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entry: 1122623 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libwsman1 >= 2.4.11-21.8.1
  • libwsman_clientpp1 >= 2.4.11-21.8.1
  • openwsman >= 2.4.11-21.8.1
  • openwsman-server >= 2.4.11-21.8.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-656
SUSE Linux Enterprise Desktop 12 SP4
  • libwsman1 >= 2.4.11-21.8.1
  • libwsman_clientpp1 >= 2.4.11-21.8.1
  • openwsman >= 2.4.11-21.8.1
  • openwsman-server >= 2.4.11-21.8.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-656
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libwsman_clientpp-devel >= 2.6.7-3.3.1
  • libwsman_clientpp1 >= 2.6.7-3.3.1
  • openwsman >= 2.6.7-3.3.1
  • openwsman-java >= 2.6.7-3.3.1
  • openwsman-perl >= 2.6.7-3.3.1
  • openwsman-ruby >= 2.6.7-3.3.1
  • openwsman-ruby-docs >= 2.6.7-3.3.1
  • openwsman-server-plugin-ruby >= 2.6.7-3.3.1
  • python3-openwsman >= 2.6.7-3.3.1
  • winrs >= 2.6.7-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-654
SUSE Linux Enterprise Module for Server Applications 15
  • libwsman-devel >= 2.6.7-3.3.1
  • libwsman3 >= 2.6.7-3.3.1
  • openwsman >= 2.6.7-3.3.1
  • openwsman-server >= 2.6.7-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-654
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • libwsman-devel >= 2.6.7-3.3.1
  • libwsman3 >= 2.6.7-3.3.1
  • openwsman-server >= 2.6.7-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA libwsman-devel
SUSE Linux Enterprise Server 11 SP4
  • libwsman1 >= 2.2.3-0.16.8.1
  • openwsman >= 2.2.3-0.16.8.1
  • openwsman-client >= 2.2.3-0.16.8.1
  • openwsman-server >= 2.2.3-0.16.8.1
Patchnames:
slessp4-openwsman-13981
SUSE Linux Enterprise Server 12 SP3
  • libwsman1 >= 2.4.11-21.8.1
  • libwsman_clientpp1 >= 2.4.11-21.8.1
  • openwsman >= 2.4.11-21.8.1
  • openwsman-server >= 2.4.11-21.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-656
SUSE Linux Enterprise Server 12 SP4
  • libwsman1 >= 2.4.11-21.8.1
  • libwsman_clientpp1 >= 2.4.11-21.8.1
  • openwsman >= 2.4.11-21.8.1
  • openwsman-server >= 2.4.11-21.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-656
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libwsman1 >= 2.2.3-0.16.8.1
  • openwsman >= 2.2.3-0.16.8.1
  • openwsman-client >= 2.2.3-0.16.8.1
  • openwsman-server >= 2.2.3-0.16.8.1
Patchnames:
slessp4-openwsman-13981
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libwsman1 >= 2.4.11-21.8.1
  • libwsman_clientpp1 >= 2.4.11-21.8.1
  • openwsman >= 2.4.11-21.8.1
  • openwsman-server >= 2.4.11-21.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-656
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libwsman1 >= 2.4.11-21.8.1
  • libwsman_clientpp1 >= 2.4.11-21.8.1
  • openwsman >= 2.4.11-21.8.1
  • openwsman-server >= 2.4.11-21.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-656
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libwsman-devel >= 2.2.3-0.16.8.1
  • openwsman >= 2.2.3-0.16.8.1
  • openwsman-python >= 2.2.3-0.16.8.1
Patchnames:
sdksp4-openwsman-13981
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libwsman-devel >= 2.4.11-21.8.1
  • libwsman_clientpp-devel >= 2.4.11-21.8.1
  • openwsman >= 2.4.11-21.8.1
  • openwsman-python >= 2.4.11-21.8.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-656
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libwsman-devel >= 2.4.11-21.8.1
  • libwsman_clientpp-devel >= 2.4.11-21.8.1
  • openwsman >= 2.4.11-21.8.1
  • openwsman-python >= 2.4.11-21.8.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-656
openSUSE Leap 15.0
  • libwsman-devel >= 2.6.7-lp150.2.3.1
  • libwsman3 >= 2.6.7-lp150.2.3.1
  • libwsman3-debuginfo >= 2.6.7-lp150.2.3.1
  • libwsman_clientpp-devel >= 2.6.7-lp150.2.3.1
  • libwsman_clientpp1 >= 2.6.7-lp150.2.3.1
  • libwsman_clientpp1-debuginfo >= 2.6.7-lp150.2.3.1
  • openwsman >= 2.6.7-lp150.2.3.1
  • openwsman-debuginfo >= 2.6.7-lp150.2.3.1
  • openwsman-debugsource >= 2.6.7-lp150.2.3.1
  • openwsman-java >= 2.6.7-lp150.2.3.1
  • openwsman-perl >= 2.6.7-lp150.2.3.1
  • openwsman-perl-debuginfo >= 2.6.7-lp150.2.3.1
  • openwsman-ruby >= 2.6.7-lp150.2.3.1
  • openwsman-ruby-debuginfo >= 2.6.7-lp150.2.3.1
  • openwsman-ruby-docs >= 2.6.7-lp150.2.3.1
  • openwsman-server >= 2.6.7-lp150.2.3.1
  • openwsman-server-debuginfo >= 2.6.7-lp150.2.3.1
  • openwsman-server-plugin-ruby >= 2.6.7-lp150.2.3.1
  • openwsman-server-plugin-ruby-debuginfo >= 2.6.7-lp150.2.3.1
  • python3-openwsman >= 2.6.7-lp150.2.3.1
  • python3-openwsman-debuginfo >= 2.6.7-lp150.2.3.1
  • winrs >= 2.6.7-lp150.2.3.1
Patchnames:
openSUSE-2019-1111
openSUSE Leap 42.3
  • libwsman-devel >= 2.6.7-4.3.1
  • libwsman3 >= 2.6.7-4.3.1
  • libwsman3-debuginfo >= 2.6.7-4.3.1
  • libwsman_clientpp-devel >= 2.6.7-4.3.1
  • libwsman_clientpp1 >= 2.6.7-4.3.1
  • libwsman_clientpp1-debuginfo >= 2.6.7-4.3.1
  • openwsman >= 2.6.7-4.3.1
  • openwsman-debugsource >= 2.6.7-4.3.1
  • openwsman-java >= 2.6.7-4.3.1
  • openwsman-perl >= 2.6.7-4.3.1
  • openwsman-perl-debuginfo >= 2.6.7-4.3.1
  • openwsman-python >= 2.6.7-4.3.1
  • openwsman-python-debuginfo >= 2.6.7-4.3.1
  • openwsman-ruby >= 2.6.7-4.3.1
  • openwsman-ruby-debuginfo >= 2.6.7-4.3.1
  • openwsman-ruby-docs >= 2.6.7-4.3.1
  • openwsman-server >= 2.6.7-4.3.1
  • openwsman-server-debuginfo >= 2.6.7-4.3.1
  • openwsman-server-plugin-ruby >= 2.6.7-4.3.1
  • openwsman-server-plugin-ruby-debuginfo >= 2.6.7-4.3.1
  • winrs >= 2.6.7-4.3.1
Patchnames:
openSUSE-2019-1217


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 openwsman Released
SUSE Linux Enterprise Desktop 12 SP4 openwsman Released
SUSE Linux Enterprise High Performance Computing 12 openwsman Released
SUSE Linux Enterprise Module for Server Applications 15 GA openwsman Released
SUSE Linux Enterprise SDK 11 SP4 openwsman Released
SUSE Linux Enterprise SDK 12 SP3 openwsman Released
SUSE Linux Enterprise SDK 12 SP4 openwsman Released
SUSE Linux Enterprise Server 11 SP3 LTSS openwsman Affected
SUSE Linux Enterprise Server 11 SP4 openwsman Released
SUSE Linux Enterprise Server 12 GA LTSS openwsman Affected
SUSE Linux Enterprise Server 12 SP1 LTSS openwsman Affected
SUSE Linux Enterprise Server 12 SP2 LTSS openwsman Affected
SUSE Linux Enterprise Server 12 SP3 openwsman Released
SUSE Linux Enterprise Server 12 SP4 openwsman Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openwsman Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA openwsman Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openwsman Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openwsman Released