Upstream information

CVE-2019-3681 at MITRE

Description

A External Control of File Name or Path vulnerability in osc of SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Software Development Kit 12-SP5, SUSE Linux Enterprise Software Development Kit 12-SP4; openSUSE Leap 15.1, openSUSE Factory allowed remote attackers that can change downloaded packages to overwrite arbitrary files. This issue affects: SUSE Linux Enterprise Module for Development Tools 15 osc versions prior to 0.169.1-3.20.1. SUSE Linux Enterprise Software Development Kit 12-SP5 osc versions prior to 0.162.1-15.9.1. SUSE Linux Enterprise Software Development Kit 12-SP4 osc versions prior to 0.162.1-15.9.1. openSUSE Leap 15.1 osc versions prior to 0.169.1-lp151.2.15.1. openSUSE Factory osc versions prior to 0.169.0 .

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 4.2
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:L
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact Low
Availability Impact Low
CVSSv3 Version 3
SUSE Bugzilla entry: 1122675 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • osc >= 0.169.1-3.20.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2020-1695
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • osc >= 0.169.1-3.20.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2020-1695
SUSE Linux Enterprise Software Development Kit 12 SP4
  • osc >= 0.162.1-15.9.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-1528
SUSE Linux Enterprise Software Development Kit 12 SP5
  • osc >= 0.162.1-15.9.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1528
openSUSE Leap 15.1
  • osc >= 0.169.1-lp151.2.15.1
Patchnames:
openSUSE-2020-852


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Legacy osc Affected
SUSE Linux Enterprise 15-SP1 Module for Development Tools osc Released
SUSE Linux Enterprise 15-SP2 Module for Development Tools osc Released
SUSE Linux Enterprise Software Development Kit 11 SP4 osc Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 osc Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 osc Released
SUSE Linux Enterprise Software Development Kit 12 SP5 osc Released