Upstream information

CVE-2019-2821 at MITRE

Description

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: JSSE). Supported versions that are affected are Java SE: 11.0.3 and 12.0.1. Difficult to exploit vulnerability allows unauthenticated attacker with network access via TLS to compromise Java SE. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all Java SE accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.0 Base Score 5.3 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 5.3
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1141781 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
  • java-11-openjdk >= 11.0.4.0-1.26
  • java-11-openjdk-demo >= 11.0.4.0-1.26
  • java-11-openjdk-devel >= 11.0.4.0-1.26
  • java-11-openjdk-headless >= 11.0.4.0-1.26
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA java-11-openjdk
SUSE Linux Enterprise Module for Basesystem 15
  • java-11-openjdk >= 11.0.4.0-3.33.1
  • java-11-openjdk-demo >= 11.0.4.0-3.33.1
  • java-11-openjdk-devel >= 11.0.4.0-3.33.1
  • java-11-openjdk-headless >= 11.0.4.0-3.33.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2002
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • java-11-openjdk >= 11.0.4.0-3.33.1
  • java-11-openjdk-demo >= 11.0.4.0-3.33.1
  • java-11-openjdk-devel >= 11.0.4.0-3.33.1
  • java-11-openjdk-headless >= 11.0.4.0-3.33.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2002
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • java-11-openjdk >= 11.0.4.0-3.33.1
  • java-11-openjdk-accessibility >= 11.0.4.0-3.33.1
  • java-11-openjdk-demo >= 11.0.4.0-3.33.1
  • java-11-openjdk-devel >= 11.0.4.0-3.33.1
  • java-11-openjdk-headless >= 11.0.4.0-3.33.1
  • java-11-openjdk-javadoc >= 11.0.4.0-3.33.1
  • java-11-openjdk-jmods >= 11.0.4.0-3.33.1
  • java-11-openjdk-src >= 11.0.4.0-3.33.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2002
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • java-11-openjdk >= 11.0.4.0-3.33.1
  • java-11-openjdk-accessibility >= 11.0.4.0-3.33.1
  • java-11-openjdk-javadoc >= 11.0.4.0-3.33.1
  • java-11-openjdk-jmods >= 11.0.4.0-3.33.1
  • java-11-openjdk-src >= 11.0.4.0-3.33.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2002
SUSE Linux Enterprise Server 12 SP5
  • java-11-openjdk >= 11.0.4.0-1.26
  • java-11-openjdk-demo >= 11.0.4.0-1.26
  • java-11-openjdk-devel >= 11.0.4.0-1.26
  • java-11-openjdk-headless >= 11.0.4.0-1.26
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA java-11-openjdk
openSUSE Leap 15.0
  • java-11-openjdk >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-accessibility >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-accessibility-debuginfo >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-debuginfo >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-debugsource >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-demo >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-devel >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-headless >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-javadoc >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-jmods >= 11.0.4.0-lp150.2.25.1
  • java-11-openjdk-src >= 11.0.4.0-lp150.2.25.1
Patchnames:
openSUSE-2019-1916
openSUSE Leap 15.1
  • java-11-openjdk >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-accessibility >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-accessibility-debuginfo >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-debuginfo >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-debugsource >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-demo >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-devel >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-headless >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-javadoc >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-jmods >= 11.0.4.0-lp151.3.6.1
  • java-11-openjdk-src >= 11.0.4.0-lp151.3.6.1
Patchnames:
openSUSE-2019-1916


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Basesystem 15 GA java-11-openjdk Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 java-11-openjdk Released