Upstream information

CVE-2019-2503 at MITRE

Description

Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Connection Handling). Supported versions that are affected are 5.6.42 and prior, 5.7.24 and prior and 8.0.13 and prior. Difficult to exploit vulnerability allows low privileged attacker with access to the physical communication segment attached to the hardware where the MySQL Server executes to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all MySQL Server accessible data and unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 6.4 (Confidentiality and Availability impacts). CVSS Vector: (CVSS:3.0/AV:A/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:H).

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.8
Vector AV:A/AC:M/Au:S/C:P/I:N/A:P
Access Vector Adjacent Network
Access Complexity Medium
Authentication Single
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.4 6.4
Vector AV:A/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:H AV:A/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:H
Access Vector Adjacent Network Adjacent Network
Access Complexity High High
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entry: 1122198 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.3
  • libmysql56client18 >= 5.6.43-45.1
  • libmysql56client18-32bit >= 5.6.43-45.1
  • libmysql56client18-debuginfo >= 5.6.43-45.1
  • libmysql56client18-debuginfo-32bit >= 5.6.43-45.1
  • libmysql56client_r18 >= 5.6.43-45.1
  • libmysql56client_r18-32bit >= 5.6.43-45.1
  • mysql-community-server >= 5.6.43-45.1
  • mysql-community-server-bench >= 5.6.43-45.1
  • mysql-community-server-bench-debuginfo >= 5.6.43-45.1
  • mysql-community-server-client >= 5.6.43-45.1
  • mysql-community-server-client-debuginfo >= 5.6.43-45.1
  • mysql-community-server-debuginfo >= 5.6.43-45.1
  • mysql-community-server-debugsource >= 5.6.43-45.1
  • mysql-community-server-errormessages >= 5.6.43-45.1
  • mysql-community-server-test >= 5.6.43-45.1
  • mysql-community-server-test-debuginfo >= 5.6.43-45.1
  • mysql-community-server-tools >= 5.6.43-45.1
  • mysql-community-server-tools-debuginfo >= 5.6.43-45.1
Patchnames:
openSUSE-2019-138


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP4 mysql Affected
SUSE Linux Enterprise Server 11 SP3 LTSS mysql Affected
SUSE Linux Enterprise Server 11 SP4 mysql Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 mysql Affected