Upstream information

CVE-2019-19451 at MITRE

Description

When GNOME Dia before 2019-11-27 is launched with a filename argument that is not a valid codepoint in the current encoding, it enters an endless loop, thus endlessly writing text to stdout. If this launch is from a thumbnailer service, this output will usually be written to disk via the system's logging facility (potentially with elevated privileges), thus filling up the disk and eventually rendering the system unusable. (The filename can be for a nonexistent file.) NOTE: this does not affect an upstream release, but affects certain Linux distribution packages with version numbers such as 0.97.3.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v3 Scores
  SUSE
Base Score 3.3
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1158194 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • dia >= 0.97.3-17.4.1
  • dia-lang >= 0.97.3-17.4.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-3390
SUSE Linux Enterprise Software Development Kit 12 SP4
  • dia >= 0.97.3-17.4.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-3390
SUSE Linux Enterprise Software Development Kit 12 SP5
  • dia >= 0.97.3-17.4.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-3390
SUSE Linux Enterprise Workstation Extension 12 SP4
  • dia >= 0.97.3-17.4.1
  • dia-lang >= 0.97.3-17.4.1
Patchnames:
SUSE-SLE-WE-12-SP4-2019-3390
SUSE Linux Enterprise Workstation Extension 12 SP5
  • dia >= 0.97.3-17.4.1
  • dia-lang >= 0.97.3-17.4.1
Patchnames:
SUSE-SLE-WE-12-SP5-2019-3390
SUSE Linux Enterprise Workstation Extension 15 SP1
  • dia >= 0.97.3-4.3.3
  • dia-lang >= 0.97.3-4.3.3
Patchnames:
SUSE-SLE-Product-WE-15-SP1-2019-3391
SUSE Linux Enterprise Workstation Extension 15
  • dia >= 0.97.3-4.3.3
  • dia-lang >= 0.97.3-4.3.3
Patchnames:
SUSE-SLE-Product-WE-15-2019-3391
openSUSE Leap 15.1
  • dia >= 0.97.3-lp151.4.3.1
  • dia-debuginfo >= 0.97.3-lp151.4.3.1
  • dia-debugsource >= 0.97.3-lp151.4.3.1
  • dia-lang >= 0.97.3-lp151.4.3.1
Patchnames:
openSUSE-2020-21


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP4 dia Released
SUSE Linux Enterprise Software Development Kit 12 SP4 dia Released
SUSE Linux Enterprise Software Development Kit 12 SP5 dia Released
SUSE Linux Enterprise Workstation Extension 12 dia Released
SUSE Linux Enterprise Workstation Extension 15 dia Released
SUSE Linux Enterprise Workstation Extension 15 SP1 dia Released