Upstream information

CVE-2019-19221 at MITRE

Description

In Libarchive 3.4.0, archive_wstring_append_from_mbs in archive_string.c has an out-of-bounds read because of an incorrect mbrtowc or mbtowc call. For example, bsdtar crashes via a crafted archive.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1157569 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP4 libarchive Affected
SUSE Linux Enterprise High Performance Computing 12 libarchive Affected
SUSE Linux Enterprise Module for Basesystem 15 GA libarchive Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libarchive Affected
SUSE Linux Enterprise Module for Development Tools 15 GA libarchive Affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 libarchive Affected
SUSE Linux Enterprise SDK 12 SP4 libarchive Affected
SUSE Linux Enterprise SDK 12 SP5 libarchive Affected
SUSE Linux Enterprise Server 11 SP4 LTSS bsdtar Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS libarchive Affected
SUSE Linux Enterprise Server 12 SP2 LTSS libarchive Affected
SUSE Linux Enterprise Server 12 SP3 LTSS libarchive Affected
SUSE Linux Enterprise Server 12 SP4 libarchive Affected
SUSE Linux Enterprise Server 12 SP5 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libarchive Affected