Upstream information

CVE-2019-19191 at MITRE

Description

Shibboleth Service Provider (SP) 3.x before 3.1.0 shipped a spec file that calls chown on files in a directory controlled by the service user (the shibd account) after installation. This allows the user to escalate to root by pointing symlinks to files such as /etc/shadow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 8.4
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1157471 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
HPE-Helion-OpenStack-8-2020-115
SUSE Enterprise Storage 5
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-Storage-5-2020-115
SUSE Linux Enterprise Module for Server Applications 15
  • libshibsp-lite7 >= 2.6.1-3.3.1
  • libshibsp7 >= 2.6.1-3.3.1
  • shibboleth-sp >= 2.6.1-3.3.1
  • shibboleth-sp-devel >= 2.6.1-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-3386
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • libshibsp-lite7 >= 2.6.1-3.3.1
  • libshibsp7 >= 2.6.1-3.3.1
  • shibboleth-sp >= 2.6.1-3.3.1
  • shibboleth-sp-devel >= 2.6.1-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2019-3386
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-115
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2020-115
SUSE Linux Enterprise Server 12 SP2-BCL
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-115
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-115
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-115
SUSE Linux Enterprise Server 12 SP3-BCL
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-115
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-115
SUSE Linux Enterprise Server 12 SP3-LTSS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-115
SUSE Linux Enterprise Server 12 SP4
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-115
SUSE Linux Enterprise Server 12 SP5
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-115
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-115
SUSE Linux Enterprise Software Development Kit 12 SP4
  • shibboleth-sp >= 2.5.5-6.6.1
  • shibboleth-sp-devel >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-115
SUSE Linux Enterprise Software Development Kit 12 SP5
  • shibboleth-sp >= 2.5.5-6.6.1
  • shibboleth-sp-devel >= 2.5.5-6.6.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-115
SUSE OpenStack Cloud 7
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-115
SUSE OpenStack Cloud 8
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-115
SUSE OpenStack Cloud Crowbar 8
  • libshibsp-lite6 >= 2.5.5-6.6.1
  • libshibsp6 >= 2.5.5-6.6.1
  • shibboleth-sp >= 2.5.5-6.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-115
openSUSE Leap 15.1
  • libshibsp-lite7 >= 2.6.1-lp151.3.3.1
  • libshibsp-lite7-debuginfo >= 2.6.1-lp151.3.3.1
  • libshibsp7 >= 2.6.1-lp151.3.3.1
  • libshibsp7-debuginfo >= 2.6.1-lp151.3.3.1
  • shibboleth-sp >= 2.6.1-lp151.3.3.1
  • shibboleth-sp-debuginfo >= 2.6.1-lp151.3.3.1
  • shibboleth-sp-debugsource >= 2.6.1-lp151.3.3.1
  • shibboleth-sp-devel >= 2.6.1-lp151.3.3.1
Patchnames:
openSUSE-2020-20


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 shibboleth-sp Released
SUSE Linux Enterprise Module for Server Applications 15 GA shibboleth-sp Released
SUSE Linux Enterprise Module for Server Applications 15 SP1 shibboleth-sp Released
SUSE Linux Enterprise SDK 12 SP4 shibboleth-sp Released
SUSE Linux Enterprise SDK 12 SP5 shibboleth-sp Released
SUSE Linux Enterprise Server 12 SP1 LTSS shibboleth-sp Released
SUSE Linux Enterprise Server 12 SP2 LTSS shibboleth-sp Released
SUSE Linux Enterprise Server 12 SP3 LTSS shibboleth-sp Released
SUSE Linux Enterprise Server 12 SP4 shibboleth-sp Released
SUSE Linux Enterprise Server 12 SP5 shibboleth-sp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 shibboleth-sp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 shibboleth-sp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 shibboleth-sp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 shibboleth-sp Released