Upstream information

CVE-2019-19126 at MITRE

Description

On the x86-64 architecture, the GNU C Library (aka glibc) before 2.31 fails to ignore the LD_PREFER_MAP_32BIT_EXEC environment variable during program execution after a security transition, allowing local attackers to restrict the possible mapping addresses for loaded libraries and thus bypass ASLR for a setuid program.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

SUSE Bugzilla entry: 1157292 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • glibc >= 2.26-13.36.1
  • glibc-32bit >= 2.26-13.36.1
  • glibc-devel >= 2.26-13.36.1
  • glibc-extra >= 2.26-13.36.1
  • glibc-i18ndata >= 2.26-13.36.1
  • glibc-info >= 2.26-13.36.1
  • glibc-locale >= 2.26-13.36.1
  • glibc-locale-base >= 2.26-13.36.1
  • glibc-locale-base-32bit >= 2.26-13.36.1
  • glibc-profile >= 2.26-13.36.1
  • nscd >= 2.26-13.36.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2020-262
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • glibc >= 2.26-13.36.1
  • glibc-32bit >= 2.26-13.36.1
  • glibc-devel >= 2.26-13.36.1
  • glibc-extra >= 2.26-13.36.1
  • glibc-i18ndata >= 2.26-13.36.1
  • glibc-info >= 2.26-13.36.1
  • glibc-locale >= 2.26-13.36.1
  • glibc-locale-base >= 2.26-13.36.1
  • glibc-locale-base-32bit >= 2.26-13.36.1
  • glibc-profile >= 2.26-13.36.1
  • nscd >= 2.26-13.36.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-262
SUSE Linux Enterprise Module for Development Tools 15
  • glibc >= 2.26-13.36.1
  • glibc-devel-32bit >= 2.26-13.36.1
  • glibc-devel-static >= 2.26-13.36.1
  • glibc-utils >= 2.26-13.36.1
  • glibc-utils-src >= 2.26-13.36.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2020-262
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • glibc >= 2.26-13.36.1
  • glibc-devel-32bit >= 2.26-13.36.1
  • glibc-devel-static >= 2.26-13.36.1
  • glibc-utils >= 2.26-13.36.1
  • glibc-utils-src >= 2.26-13.36.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2020-262
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • glibc >= 2.26-13.36.1
  • glibc-html >= 2.26-13.36.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2020-262
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • glibc >= 2.26-13.36.1
  • glibc-devel-static-32bit >= 2.26-13.36.1
  • glibc-html >= 2.26-13.36.1
  • glibc-locale-base-32bit >= 2.26-13.36.1
  • glibc-profile-32bit >= 2.26-13.36.1
  • glibc-utils-32bit >= 2.26-13.36.1
  • glibc-utils-src >= 2.26-13.36.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-262


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 glibc Not affected
CaaS Platform 2.0 glibc Not affected
CaaS Platform 3.0 glibc Not affected
SUSE Business Critical Linux 12 SP3 glibc Affected
SUSE Linux Enterprise Desktop 12 SP4 glibc Not affected
SUSE Linux Enterprise High Performance Computing 12 glibc Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA glibc Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 glibc Released
SUSE Linux Enterprise Module for Development Tools 15 GA glibc Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 glibc Released
SUSE Linux Enterprise SDK 12 SP4 glibc Not affected
SUSE Linux Enterprise SDK 12 SP5 glibc Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP4 glibc Not affected
SUSE Linux Enterprise Server 12 SP5 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 glibc Not affected