Upstream information

CVE-2019-18801 at MITRE

Description

An issue was discovered in Envoy 1.12.0. An untrusted remote client may send HTTP/2 requests that write to the heap outside of the request buffers when the upstream is HTTP/1. This may be used to corrupt nearby heap contents (leading to a query-of-death scenario) or may be used to bypass Envoy's access control mechanisms such as path based routing. An attacker can also modify requests from other users that happen to be proximal temporally and spatially.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1159002 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/cert-exporter:2.3.0
Image caasp4/caasp-cert-exporter-image
  • cert-exporter >= 2.3.0-1.3.4
Container caasp/v4/cilium-operator:1.6.6
Image caasp4/caasp-cilium-operator-image
  • cilium-operator >= 1.6.6-3.3.8
Container caasp/v4/cilium:1.6.6
Image caasp4/caasp-cilium-image
  • bpftool >= 4.12.14-1.3.8.3
  • cilium >= 1.6.6-3.3.8
  • cilium-cni >= 1.6.6-3.3.8
  • cilium-proxy >= 20200109-3.3.11.1
  • iproute2 >= 5.3-3.3.5
  • libdd_opentracing0 >= 1.0.1-3.7.3
  • libfmt6 >= 6.1.2-3.3.5
  • libsqlparser1 >= 1.5+git20181206-1.6.6
  • libxxhash0 >= 0.7.1-3.3.4
Container caasp/v4/hyperkube:v1.17.13
Image caasp4/caasp-hyperkube-image
  • iproute2 >= 5.3-3.3.5
Container caasp/v4/kured:1.3.0
Image caasp4/caasp-kured-image
  • kured >= 1.3.0-4.17.5
Container caasp/v4/metrics-server:0.3.6
Image caasp4/caasp-metrics-server-image
  • metrics-server >= 0.3.6-1.3.4
SUSE CaaS Platform 4.0
  • caasp-release >= 4.2.1-24.23.4
  • skuba >= 1.3.5-3.39.1
  • skuba-update >= 1.3.5-3.39.1
  • terraform-provider-vsphere >= 1.17.3-3.3.4
Patchnames:
SUSE-SUSE-CAASP-4.0-2020-1573


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 caasp-release Released
SUSE CaaS Platform 4.0 skuba Released
SUSE CaaS Platform 4.0 terraform-provider-vsphere Released