Upstream information

CVE-2019-18678 at MITRE

Description

An issue was discovered in Squid 3.x and 4.x through 4.8. It allows attackers to smuggle HTTP requests through frontend software to a Squid instance that splits the HTTP Request pipeline differently. The resulting Response messages corrupt caches (between a client and Squid) with attacker-controlled content at arbitrary URLs. Effects are isolated to software between the attacker client and Squid. There are no effects on Squid itself, nor on any upstream servers. The issue is related to a request header containing whitespace between a header name and a colon.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1156323 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • squid >= 3.5.21-26.20.1
Patchnames:
HPE-Helion-OpenStack-8-2020-661
SUSE Enterprise Storage 5
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-Storage-5-2020-661
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • squid >= 4.9-5.11.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2019-2975
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • squid >= 4.11-5.17.2
SUSE Linux Enterprise Module for Server Applications 15
  • squid >= 4.9-5.11.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-2975
SUSE Linux Enterprise Point of Sale 11 SP3
  • squid3 >= 3.1.23-8.16.37.12.1
Patchnames:
sleposp3-squid3-14460
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-661
SUSE Linux Enterprise Server 11 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • squid3 >= 3.1.23-8.16.37.12.1
Patchnames:
slessp4-squid3-14460
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-661
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-661
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-661
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-661
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-661
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-661
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-661
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • squid >= 4.9-4.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-3067
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-661
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-661
SUSE OpenStack Cloud 7
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-661
SUSE OpenStack Cloud 8
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-661
SUSE OpenStack Cloud Crowbar 8
  • squid >= 3.5.21-26.20.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-661
openSUSE Leap 15.0
  • squid >= 4.9-lp150.13.1
  • squid-debuginfo >= 4.9-lp150.13.1
  • squid-debugsource >= 4.9-lp150.13.1
Patchnames:
openSUSE-2019-2540
openSUSE Leap 15.1
  • squid >= 4.9-lp151.2.7.1
  • squid-debuginfo >= 4.9-lp151.2.7.1
  • squid-debugsource >= 4.9-lp151.2.7.1
Patchnames:
openSUSE-2019-2541


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Server Applications squid Released
SUSE Linux Enterprise 15-SP1 Module for Server Applications squid Released
SUSE Linux Enterprise High Performance Computing 12 SP4 squid Released
SUSE Linux Enterprise High Performance Computing 12 SP5 squid Released
SUSE Linux Enterprise Server 11 SP4 LTSS squid Analysis
SUSE Linux Enterprise Server 11 SP4 LTSS squid3 Released
SUSE Linux Enterprise Server 12 SP1 LTSS squid Analysis
SUSE Linux Enterprise Server 12 SP2 BCL squid Released
SUSE Linux Enterprise Server 12 SP2 LTSS squid Released
SUSE Linux Enterprise Server 12 SP3 BCL squid Released
SUSE Linux Enterprise Server 12 SP3 LTSS squid Released
SUSE Linux Enterprise Server 12 SP4 squid Released
SUSE Linux Enterprise Server 12 SP5 squid Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 squid Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 squid Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 squid Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 squid Released