Upstream information

CVE-2019-17594 at MITRE

Description

There is a heap-based buffer over-read in the _nc_find_entry function in tinfo/comp_hash.c in the terminfo library in ncurses before 6.1-20191012.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 4
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low None
Integrity Impact Low None
Availability Impact Low Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1154036 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 3.0
  • libncurses5 >= 5.9-69.1
  • libncurses6 >= 5.9-69.1
  • ncurses >= 5.9-69.1
  • ncurses-utils >= 5.9-69.1
  • terminfo >= 5.9-69.1
  • terminfo-base >= 5.9-69.1
Patchnames:
SUSE-CAASP-3.0-2019-3094
SUSE Linux Enterprise Desktop 12 SP4
  • libncurses5 >= 5.9-69.1
  • libncurses5-32bit >= 5.9-69.1
  • libncurses6 >= 5.9-69.1
  • libncurses6-32bit >= 5.9-69.1
  • ncurses >= 5.9-69.1
  • ncurses-devel >= 5.9-69.1
  • ncurses-utils >= 5.9-69.1
  • tack >= 5.9-69.1
  • terminfo >= 5.9-69.1
  • terminfo-base >= 5.9-69.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-3094
SUSE Linux Enterprise Module for Basesystem 15
  • libncurses6 >= 6.1-5.6.2
  • libncurses6-32bit >= 6.1-5.6.2
  • ncurses >= 6.1-5.6.2
  • ncurses-devel >= 6.1-5.6.2
  • ncurses-utils >= 6.1-5.6.2
  • tack >= 6.1-5.6.2
  • terminfo >= 6.1-5.6.2
  • terminfo-base >= 6.1-5.6.2
  • terminfo-iterm >= 6.1-5.6.2
  • terminfo-screen >= 6.1-5.6.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2997
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libncurses6 >= 6.1-5.6.2
  • libncurses6-32bit >= 6.1-5.6.2
  • ncurses >= 6.1-5.6.2
  • ncurses-devel >= 6.1-5.6.2
  • ncurses-utils >= 6.1-5.6.2
  • tack >= 6.1-5.6.2
  • terminfo >= 6.1-5.6.2
  • terminfo-base >= 6.1-5.6.2
  • terminfo-iterm >= 6.1-5.6.2
  • terminfo-screen >= 6.1-5.6.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2997
SUSE Linux Enterprise Module for Development Tools 15
  • ncurses >= 6.1-5.6.2
  • ncurses-devel-32bit >= 6.1-5.6.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2019-2997
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • ncurses >= 6.1-5.6.2
  • ncurses-devel-32bit >= 6.1-5.6.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2019-2997
SUSE Linux Enterprise Module for Legacy Software 15
  • libncurses5 >= 6.1-5.6.2
  • libncurses5-32bit >= 6.1-5.6.2
  • ncurses >= 6.1-5.6.2
  • ncurses5-devel >= 6.1-5.6.2
Patchnames:
SUSE-SLE-Module-Legacy-15-2019-2997
SUSE Linux Enterprise Module for Legacy Software 15 SP1
  • libncurses5 >= 6.1-5.6.2
  • libncurses5-32bit >= 6.1-5.6.2
  • ncurses >= 6.1-5.6.2
  • ncurses5-devel >= 6.1-5.6.2
Patchnames:
SUSE-SLE-Module-Legacy-15-SP1-2019-2997
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ncurses >= 6.1-5.6.2
  • ncurses5-devel-32bit >= 6.1-5.6.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2997
SUSE Linux Enterprise Server 12 SP4
  • libncurses5 >= 5.9-69.1
  • libncurses5-32bit >= 5.9-69.1
  • libncurses6 >= 5.9-69.1
  • libncurses6-32bit >= 5.9-69.1
  • ncurses >= 5.9-69.1
  • ncurses-devel >= 5.9-69.1
  • ncurses-devel-32bit >= 5.9-69.1
  • ncurses-utils >= 5.9-69.1
  • tack >= 5.9-69.1
  • terminfo >= 5.9-69.1
  • terminfo-base >= 5.9-69.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-3094
SUSE Linux Enterprise Server 12 SP5
  • libncurses5 >= 5.9-69.1
  • libncurses5-32bit >= 5.9-69.1
  • libncurses6 >= 5.9-69.1
  • libncurses6-32bit >= 5.9-69.1
  • ncurses >= 5.9-69.1
  • ncurses-devel >= 5.9-69.1
  • ncurses-devel-32bit >= 5.9-69.1
  • ncurses-utils >= 5.9-69.1
  • tack >= 5.9-69.1
  • terminfo >= 5.9-69.1
  • terminfo-base >= 5.9-69.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-3094
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libncurses5 >= 5.9-69.1
  • libncurses5-32bit >= 5.9-69.1
  • libncurses6 >= 5.9-69.1
  • libncurses6-32bit >= 5.9-69.1
  • ncurses >= 5.9-69.1
  • ncurses-devel >= 5.9-69.1
  • ncurses-devel-32bit >= 5.9-69.1
  • ncurses-utils >= 5.9-69.1
  • tack >= 5.9-69.1
  • terminfo >= 5.9-69.1
  • terminfo-base >= 5.9-69.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-3094
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libncurses5 >= 5.9-69.1
  • libncurses5-32bit >= 5.9-69.1
  • libncurses6 >= 5.9-69.1
  • libncurses6-32bit >= 5.9-69.1
  • ncurses >= 5.9-69.1
  • ncurses-devel >= 5.9-69.1
  • ncurses-devel-32bit >= 5.9-69.1
  • ncurses-utils >= 5.9-69.1
  • tack >= 5.9-69.1
  • terminfo >= 5.9-69.1
  • terminfo-base >= 5.9-69.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-3094
SUSE Linux Enterprise Software Development Kit 12 SP4
  • ncurses >= 5.9-69.1
  • ncurses-devel >= 5.9-69.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-3094
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ncurses >= 5.9-69.1
  • ncurses-devel >= 5.9-69.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-3094
openSUSE Leap 15.0
  • libncurses5 >= 6.1-lp150.9.1
  • libncurses5-32bit >= 6.1-lp150.9.1
  • libncurses5-32bit-debuginfo >= 6.1-lp150.9.1
  • libncurses5-debuginfo >= 6.1-lp150.9.1
  • libncurses6 >= 6.1-lp150.9.1
  • libncurses6-32bit >= 6.1-lp150.9.1
  • libncurses6-32bit-debuginfo >= 6.1-lp150.9.1
  • libncurses6-debuginfo >= 6.1-lp150.9.1
  • ncurses >= 6.1-lp150.9.1
  • ncurses-debugsource >= 6.1-lp150.9.1
  • ncurses-devel >= 6.1-lp150.9.1
  • ncurses-devel-32bit >= 6.1-lp150.9.1
  • ncurses-devel-32bit-debuginfo >= 6.1-lp150.9.1
  • ncurses-devel-debuginfo >= 6.1-lp150.9.1
  • ncurses-utils >= 6.1-lp150.9.1
  • ncurses-utils-debuginfo >= 6.1-lp150.9.1
  • ncurses5-devel >= 6.1-lp150.9.1
  • ncurses5-devel-32bit >= 6.1-lp150.9.1
  • tack >= 6.1-lp150.9.1
  • tack-debuginfo >= 6.1-lp150.9.1
  • terminfo >= 6.1-lp150.9.1
  • terminfo-base >= 6.1-lp150.9.1
  • terminfo-iterm >= 6.1-lp150.9.1
  • terminfo-screen >= 6.1-lp150.9.1
Patchnames:
openSUSE-2019-2550
openSUSE Leap 15.1
  • libncurses5 >= 6.1-lp151.6.3.1
  • libncurses5-32bit >= 6.1-lp151.6.3.1
  • libncurses5-32bit-debuginfo >= 6.1-lp151.6.3.1
  • libncurses5-debuginfo >= 6.1-lp151.6.3.1
  • libncurses6 >= 6.1-lp151.6.3.1
  • libncurses6-32bit >= 6.1-lp151.6.3.1
  • libncurses6-32bit-debuginfo >= 6.1-lp151.6.3.1
  • libncurses6-debuginfo >= 6.1-lp151.6.3.1
  • ncurses >= 6.1-lp151.6.3.1
  • ncurses-debugsource >= 6.1-lp151.6.3.1
  • ncurses-devel >= 6.1-lp151.6.3.1
  • ncurses-devel-32bit >= 6.1-lp151.6.3.1
  • ncurses-devel-32bit-debuginfo >= 6.1-lp151.6.3.1
  • ncurses-devel-debuginfo >= 6.1-lp151.6.3.1
  • ncurses-utils >= 6.1-lp151.6.3.1
  • ncurses-utils-debuginfo >= 6.1-lp151.6.3.1
  • ncurses5-devel >= 6.1-lp151.6.3.1
  • ncurses5-devel-32bit >= 6.1-lp151.6.3.1
  • tack >= 6.1-lp151.6.3.1
  • tack-debuginfo >= 6.1-lp151.6.3.1
  • terminfo >= 6.1-lp151.6.3.1
  • terminfo-base >= 6.1-lp151.6.3.1
  • terminfo-iterm >= 6.1-lp151.6.3.1
  • terminfo-screen >= 6.1-lp151.6.3.1
Patchnames:
openSUSE-2019-2551


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 ncurses Affected
CaaS Platform 2.0 ncurses Affected
CaaS Platform 3.0 ncurses Affected
SUSE Linux Enterprise Desktop 12 SP4 ncurses Affected
SUSE Linux Enterprise High Performance Computing 12 ncurses Affected
SUSE Linux Enterprise Module for Basesystem 15 GA ncurses Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 ncurses Released
SUSE Linux Enterprise Module for Development Tools 15 GA ncurses Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 ncurses Released
SUSE Linux Enterprise Module for Legacy Software 15 ncurses Released
SUSE Linux Enterprise SDK 12 SP4 ncurses Affected
SUSE Linux Enterprise SDK 12 SP5 ncurses Affected
SUSE Linux Enterprise Server 11 SP4 LTSS ncurses Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS ncurses Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ncurses Affected
SUSE Linux Enterprise Server 12 SP3 LTSS ncurses Affected
SUSE Linux Enterprise Server 12 SP4 ncurses Affected
SUSE Linux Enterprise Server 12 SP5 ncurses Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ncurses Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ncurses Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ncurses Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ncurses Affected