Upstream information

CVE-2019-17563 at MITRE

Description

When using FORM authentication with Apache Tomcat 9.0.0.M1 to 9.0.29, 8.5.0 to 8.5.49 and 7.0.0 to 7.0.98 there was a narrow window where an attacker could perform a session fixation attack. The window was considered too narrow for an exploit to be practical but, erring on the side of caution, this issue has been treated as a security vulnerability.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 3.4
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:A/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
Access Vector Network Adjacent Network
Access Complexity High High
Privileges Required None Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1159729 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • tomcat >= 9.0.30-3.34.1
  • tomcat-docs-webapp >= 9.0.30-3.34.1
  • tomcat-embed >= 9.0.30-3.34.1
  • tomcat-javadoc >= 9.0.30-3.34.1
  • tomcat-jsvc >= 9.0.30-3.34.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2020-226
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • tomcat >= 9.0.30-4.10.1
  • tomcat-docs-webapp >= 9.0.30-4.10.1
  • tomcat-embed >= 9.0.30-4.10.1
  • tomcat-javadoc >= 9.0.30-4.10.1
  • tomcat-jsvc >= 9.0.30-4.10.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-29
SUSE Linux Enterprise Module for Web Scripting 15
  • tomcat >= 9.0.30-3.34.1
  • tomcat-admin-webapps >= 9.0.30-3.34.1
  • tomcat-el-3_0-api >= 9.0.30-3.34.1
  • tomcat-jsp-2_3-api >= 9.0.30-3.34.1
  • tomcat-lib >= 9.0.30-3.34.1
  • tomcat-servlet-4_0-api >= 9.0.30-3.34.1
  • tomcat-webapps >= 9.0.30-3.34.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-2020-226
SUSE Linux Enterprise Module for Web Scripting 15 SP1
  • tomcat >= 9.0.30-4.10.1
  • tomcat-admin-webapps >= 9.0.30-4.10.1
  • tomcat-el-3_0-api >= 9.0.30-4.10.1
  • tomcat-jsp-2_3-api >= 9.0.30-4.10.1
  • tomcat-lib >= 9.0.30-4.10.1
  • tomcat-servlet-4_0-api >= 9.0.30-4.10.1
  • tomcat-webapps >= 9.0.30-4.10.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP1-2020-29
openSUSE Leap 15.1
  • tomcat >= 9.0.30-lp151.3.6.1
  • tomcat-admin-webapps >= 9.0.30-lp151.3.6.1
  • tomcat-docs-webapp >= 9.0.30-lp151.3.6.1
  • tomcat-el-3_0-api >= 9.0.30-lp151.3.6.1
  • tomcat-embed >= 9.0.30-lp151.3.6.1
  • tomcat-javadoc >= 9.0.30-lp151.3.6.1
  • tomcat-jsp-2_3-api >= 9.0.30-lp151.3.6.1
  • tomcat-jsvc >= 9.0.30-lp151.3.6.1
  • tomcat-lib >= 9.0.30-lp151.3.6.1
  • tomcat-servlet-4_0-api >= 9.0.30-lp151.3.6.1
  • tomcat-webapps >= 9.0.30-lp151.3.6.1
Patchnames:
openSUSE-2020-38

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Server 12 SP4
  • tomcat >= 9.0.31-3.23.1
  • tomcat-admin-webapps >= 9.0.31-3.23.1
  • tomcat-docs-webapp >= 9.0.31-3.23.1
  • tomcat-el-3_0-api >= 9.0.31-3.23.1
  • tomcat-javadoc >= 9.0.31-3.23.1
  • tomcat-jsp-2_3-api >= 9.0.31-3.23.1
  • tomcat-lib >= 9.0.31-3.23.1
  • tomcat-servlet-4_0-api >= 9.0.31-3.23.1
  • tomcat-webapps >= 9.0.31-3.23.1
SUSE Linux Enterprise Server 12 SP5
  • tomcat >= 9.0.31-3.23.1
  • tomcat-admin-webapps >= 9.0.31-3.23.1
  • tomcat-docs-webapp >= 9.0.31-3.23.1
  • tomcat-el-3_0-api >= 9.0.31-3.23.1
  • tomcat-javadoc >= 9.0.31-3.23.1
  • tomcat-jsp-2_3-api >= 9.0.31-3.23.1
  • tomcat-lib >= 9.0.31-3.23.1
  • tomcat-servlet-4_0-api >= 9.0.31-3.23.1
  • tomcat-webapps >= 9.0.31-3.23.1
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • tomcat >= 9.0.31-3.23.1
  • tomcat-admin-webapps >= 9.0.31-3.23.1
  • tomcat-docs-webapp >= 9.0.31-3.23.1
  • tomcat-el-3_0-api >= 9.0.31-3.23.1
  • tomcat-javadoc >= 9.0.31-3.23.1
  • tomcat-jsp-2_3-api >= 9.0.31-3.23.1
  • tomcat-lib >= 9.0.31-3.23.1
  • tomcat-servlet-4_0-api >= 9.0.31-3.23.1
  • tomcat-webapps >= 9.0.31-3.23.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • tomcat >= 9.0.31-3.23.1
  • tomcat-admin-webapps >= 9.0.31-3.23.1
  • tomcat-docs-webapp >= 9.0.31-3.23.1
  • tomcat-el-3_0-api >= 9.0.31-3.23.1
  • tomcat-javadoc >= 9.0.31-3.23.1
  • tomcat-jsp-2_3-api >= 9.0.31-3.23.1
  • tomcat-lib >= 9.0.31-3.23.1
  • tomcat-servlet-4_0-api >= 9.0.31-3.23.1
  • tomcat-webapps >= 9.0.31-3.23.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 tomcat In progress
SUSE Linux Enterprise Module for Web and Scripting 15 tomcat Released
SUSE Linux Enterprise Server 12 SP1 LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP2 LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP3 LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP4 tomcat In progress
SUSE Linux Enterprise Server 12 SP5 tomcat In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 tomcat In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 tomcat In progress