Upstream information

CVE-2019-17069 at MITRE

Description

PuTTY before 0.73 might allow remote SSH-1 servers to cause a denial of service by accessing freed memory locations via an SSH1_MSG_DISCONNECT message.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 1152753 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • putty >= 0.73-lp150.18.1
  • putty-debuginfo >= 0.73-lp150.18.1
  • putty-debugsource >= 0.73-lp150.18.1
Patchnames:
openSUSE-2019-2276
openSUSE Leap 15.1
  • putty >= 0.73-lp151.3.6.1
  • putty-debuginfo >= 0.73-lp151.3.6.1
  • putty-debugsource >= 0.73-lp151.3.6.1
Patchnames:
openSUSE-2019-2277