Upstream information

CVE-2019-16319 at MITRE

Description

In Wireshark 3.0.0 to 3.0.3 and 2.6.0 to 2.6.10, the Gryphon dissector could go into an infinite loop. This was addressed in plugins/epan/gryphon/packet-gryphon.c by checking for a message length of zero.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1150690 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libmaxminddb >= 1.4.2-1.3.1
  • libmaxminddb-devel >= 1.4.2-1.3.1
  • libmaxminddb0 >= 1.4.2-1.3.1
  • libmaxminddb0-32bit >= 1.4.2-1.3.1
  • libspandsp2 >= 0.0.6-3.2.1
  • libwireshark13 >= 3.2.2-3.35.2
  • libwiretap10 >= 3.2.2-3.35.2
  • libwsutil11 >= 3.2.2-3.35.2
  • mmdblookup >= 1.4.2-1.3.1
  • spandsp >= 0.0.6-3.2.1
  • wireshark >= 3.2.2-3.35.2
Patchnames:
SUSE-SLE-Product-HPC-15-2020-693
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libmaxminddb >= 1.4.2-1.3.1
  • libmaxminddb-devel >= 1.4.2-1.3.1
  • libmaxminddb0 >= 1.4.2-1.3.1
  • libmaxminddb0-32bit >= 1.4.2-1.3.1
  • libspandsp2 >= 0.0.6-3.2.1
  • libwireshark13 >= 3.2.2-3.35.2
  • libwiretap10 >= 3.2.2-3.35.2
  • libwsutil11 >= 3.2.2-3.35.2
  • mmdblookup >= 1.4.2-1.3.1
  • spandsp >= 0.0.6-3.2.1
  • wireshark >= 3.2.2-3.35.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-693
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libspandsp2 >= 0.0.6-3.2.1
  • spandsp >= 0.0.6-3.2.1
  • spandsp-devel >= 0.0.6-3.2.1
  • wireshark >= 3.2.2-3.35.2
  • wireshark-devel >= 3.2.2-3.35.2
  • wireshark-ui-qt >= 3.2.2-3.35.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-693
SUSE Linux Enterprise Module for Desktop Applications 15
  • libspandsp2 >= 0.0.6-3.2.1
  • spandsp >= 0.0.6-3.2.1
  • spandsp-devel >= 0.0.6-3.2.1
  • wireshark >= 3.2.2-3.35.2
  • wireshark-devel >= 3.2.2-3.35.2
  • wireshark-ui-qt >= 3.2.2-3.35.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2020-693
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libspandsp2-32bit >= 0.0.6-3.2.1
  • spandsp >= 0.0.6-3.2.1
  • spandsp-doc >= 0.0.6-3.2.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-693
SUSE Linux Enterprise Server 15-LTSS
  • libmaxminddb >= 1.4.2-1.3.1
  • libmaxminddb-devel >= 1.4.2-1.3.1
  • libmaxminddb0 >= 1.4.2-1.3.1
  • libmaxminddb0-32bit >= 1.4.2-1.3.1
  • libspandsp2 >= 0.0.6-3.2.1
  • libwireshark13 >= 3.2.2-3.35.2
  • libwiretap10 >= 3.2.2-3.35.2
  • libwsutil11 >= 3.2.2-3.35.2
  • mmdblookup >= 1.4.2-1.3.1
  • spandsp >= 0.0.6-3.2.1
  • wireshark >= 3.2.2-3.35.2
Patchnames:
SUSE-SLE-Product-SLES-15-2020-693
SUSE Linux Enterprise Server for SAP Applications 15
  • libmaxminddb >= 1.4.2-1.3.1
  • libmaxminddb-devel >= 1.4.2-1.3.1
  • libmaxminddb0 >= 1.4.2-1.3.1
  • libmaxminddb0-32bit >= 1.4.2-1.3.1
  • libspandsp2 >= 0.0.6-3.2.1
  • libwireshark13 >= 3.2.2-3.35.2
  • libwiretap10 >= 3.2.2-3.35.2
  • libwsutil11 >= 3.2.2-3.35.2
  • mmdblookup >= 1.4.2-1.3.1
  • spandsp >= 0.0.6-3.2.1
  • wireshark >= 3.2.2-3.35.2
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-693
openSUSE Leap 15.1
  • libmaxminddb >= 1.4.2-lp151.3.3.1
  • libmaxminddb-debugsource >= 1.4.2-lp151.3.3.1
  • libmaxminddb-devel >= 1.4.2-lp151.3.3.1
  • libmaxminddb0 >= 1.4.2-lp151.3.3.1
  • libmaxminddb0-32bit >= 1.4.2-lp151.3.3.1
  • libmaxminddb0-32bit-debuginfo >= 1.4.2-lp151.3.3.1
  • libmaxminddb0-debuginfo >= 1.4.2-lp151.3.3.1
  • libspandsp2 >= 0.0.6-lp151.3.3.1
  • libspandsp2-32bit >= 0.0.6-lp151.3.3.1
  • libspandsp2-32bit-debuginfo >= 0.0.6-lp151.3.3.1
  • libspandsp2-debuginfo >= 0.0.6-lp151.3.3.1
  • libwireshark13 >= 3.2.2-lp151.2.9.1
  • libwireshark13-debuginfo >= 3.2.2-lp151.2.9.1
  • libwiretap10 >= 3.2.2-lp151.2.9.1
  • libwiretap10-debuginfo >= 3.2.2-lp151.2.9.1
  • libwsutil11 >= 3.2.2-lp151.2.9.1
  • libwsutil11-debuginfo >= 3.2.2-lp151.2.9.1
  • mmdblookup >= 1.4.2-lp151.3.3.1
  • mmdblookup-debuginfo >= 1.4.2-lp151.3.3.1
  • spandsp >= 0.0.6-lp151.3.3.1
  • spandsp-debugsource >= 0.0.6-lp151.3.3.1
  • spandsp-devel >= 0.0.6-lp151.3.3.1
  • spandsp-doc >= 0.0.6-lp151.3.3.1
  • wireshark >= 3.2.2-lp151.2.9.1
  • wireshark-debuginfo >= 3.2.2-lp151.2.9.1
  • wireshark-debugsource >= 3.2.2-lp151.2.9.1
  • wireshark-devel >= 3.2.2-lp151.2.9.1
  • wireshark-ui-qt >= 3.2.2-lp151.2.9.1
  • wireshark-ui-qt-debuginfo >= 3.2.2-lp151.2.9.1
Patchnames:
openSUSE-2020-362


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP4 wireshark Not affected
SUSE Linux Enterprise High Performance Computing 12 wireshark Not affected
SUSE Linux Enterprise High Performance Computing ESPOS 15 GA wireshark Released
SUSE Linux Enterprise High Performance Computing LTSS 15 GA wireshark Released
SUSE Linux Enterprise Module for Basesystem 15 GA wireshark Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 wireshark Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA wireshark Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 wireshark Released
SUSE Linux Enterprise SDK 12 SP4 wireshark Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP4 wireshark Not affected
SUSE Linux Enterprise Server 15 GA LTSS wireshark Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wireshark Not affected