Upstream information

CVE-2019-15892 at MITRE

Description

An issue was discovered in Varnish Cache before 6.0.4 LTS, and 6.1.x and 6.2.x before 6.2.1. An HTTP/1 parsing failure allows a remote attacker to trigger an assert by sending crafted HTTP/1 requests. The assert will cause an automatic restart with a clean cache, which makes it a Denial of Service attack.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1149382 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 15 SP1
  • libvarnishapi2 >= 6.2.1-bp151.4.3.1
  • libvarnishapi2-debuginfo >= 6.2.1-bp151.4.3.1
  • varnish >= 6.2.1-bp151.4.3.1
  • varnish-debuginfo >= 6.2.1-bp151.4.3.1
  • varnish-debugsource >= 6.2.1-bp151.4.3.1
  • varnish-devel >= 6.2.1-bp151.4.3.1
Patchnames:
openSUSE-2019-2221
SUSE Package Hub for SUSE Linux Enterprise 15
  • libvarnishapi2 >= 6.2.1-bp150.3.3.1
  • varnish >= 6.2.1-bp150.3.3.1
  • varnish-devel >= 6.2.1-bp150.3.3.1
Patchnames:
openSUSE-2019-2221
openSUSE Leap 15.0
  • libvarnishapi2 >= 6.2.1-lp150.2.3.1
  • libvarnishapi2-debuginfo >= 6.2.1-lp150.2.3.1
  • varnish >= 6.2.1-lp150.2.3.1
  • varnish-debuginfo >= 6.2.1-lp150.2.3.1
  • varnish-debugsource >= 6.2.1-lp150.2.3.1
  • varnish-devel >= 6.2.1-lp150.2.3.1
Patchnames:
openSUSE-2019-2184
openSUSE Leap 15.1
  • libvarnishapi2 >= 6.2.1-lp151.3.3.1
  • libvarnishapi2-debuginfo >= 6.2.1-lp151.3.3.1
  • varnish >= 6.2.1-lp151.3.3.1
  • varnish-debuginfo >= 6.2.1-lp151.3.3.1
  • varnish-debugsource >= 6.2.1-lp151.3.3.1
  • varnish-devel >= 6.2.1-lp151.3.3.1
Patchnames:
openSUSE-2019-2184