Upstream information

CVE-2019-15807 at MITRE

Description

In the Linux kernel before 5.1.13, there is a memory leak in drivers/scsi/libsas/sas_expander.c when SAS expander discovery fails. This will cause a BUG and denial of service.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3 3.1
SUSE Bugzilla entry: 1148938 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • kernel-default >= 4.4.180-94.107.1
  • kernel-default-base >= 4.4.180-94.107.1
  • kernel-default-devel >= 4.4.180-94.107.1
  • kernel-default-kgraft >= 4.4.180-94.107.1
  • kernel-devel >= 4.4.180-94.107.1
  • kernel-macros >= 4.4.180-94.107.1
  • kernel-source >= 4.4.180-94.107.1
  • kernel-syms >= 4.4.180-94.107.1
  • kgraft-patch-4_4_180-94_107-default >= 1-4.3.1
  • kgraft-patch-SLE12-SP3_Update_29 >= 1-4.3.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2949
SUSE CaaS Platform 3.0
  • kernel-default >= 4.4.180-94.107.1
Patchnames:
SUSE-CAASP-3.0-2019-2949
SUSE Enterprise Storage 5
  • kernel-default >= 4.4.180-94.107.1
  • kernel-default-base >= 4.4.180-94.107.1
  • kernel-default-devel >= 4.4.180-94.107.1
  • kernel-default-kgraft >= 4.4.180-94.107.1
  • kernel-devel >= 4.4.180-94.107.1
  • kernel-macros >= 4.4.180-94.107.1
  • kernel-source >= 4.4.180-94.107.1
  • kernel-syms >= 4.4.180-94.107.1
  • kgraft-patch-4_4_180-94_107-default >= 1-4.3.1
  • kgraft-patch-SLE12-SP3_Update_29 >= 1-4.3.1
Patchnames:
SUSE-Storage-5-2019-2949
SUSE Linux Enterprise High Availability 12 SP2
  • cluster-md-kmp-default >= 4.4.121-92.125.1
  • cluster-network-kmp-default >= 4.4.121-92.125.1
  • dlm-kmp-default >= 4.4.121-92.125.1
  • gfs2-kmp-default >= 4.4.121-92.125.1
  • kernel-default >= 4.4.121-92.125.1
  • ocfs2-kmp-default >= 4.4.121-92.125.1
Patchnames:
SUSE-SLE-HA-12-SP2-2019-2984
SUSE Linux Enterprise High Availability 12 SP3
  • cluster-md-kmp-default >= 4.4.180-94.107.1
  • dlm-kmp-default >= 4.4.180-94.107.1
  • gfs2-kmp-default >= 4.4.180-94.107.1
  • kernel-default >= 4.4.180-94.107.1
  • ocfs2-kmp-default >= 4.4.180-94.107.1
Patchnames:
SUSE-SLE-HA-12-SP3-2019-2949
SUSE Linux Enterprise High Availability Extension 11 SP4
  • ocfs2 >= 1.6-0.28.11.2
  • ocfs2-kmp-bigmem >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-default >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-pae >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-ppc64 >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-trace >= 1.6_3.0.101_108.108-0.28.11.2
  • ocfs2-kmp-xen >= 1.6_3.0.101_108.108-0.28.11.2
Patchnames:
slehasp4-kernel-source-14218
SUSE Linux Enterprise Module for Public Cloud 12
  • kernel-ec2 >= 3.12.74-60.64.124.1
  • kernel-ec2-devel >= 3.12.74-60.64.124.1
  • kernel-ec2-extra >= 3.12.74-60.64.124.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2019-2950
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • kernel-default >= 4.4.121-92.125.1
  • kernel-default-base >= 4.4.121-92.125.1
  • kernel-default-devel >= 4.4.121-92.125.1
  • kernel-devel >= 4.4.121-92.125.1
  • kernel-macros >= 4.4.121-92.125.1
  • kernel-source >= 4.4.121-92.125.1
  • kernel-syms >= 4.4.121-92.125.1
  • kgraft-patch-4_4_121-92_125-default >= 1-3.5.1
  • kgraft-patch-SLE12-SP2_Update_33 >= 1-3.5.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2984
SUSE Linux Enterprise Server 11 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • kernel-bigmem >= 3.0.101-108.108.1
  • kernel-bigmem-base >= 3.0.101-108.108.1
  • kernel-bigmem-devel >= 3.0.101-108.108.1
  • kernel-default >= 3.0.101-108.108.1
  • kernel-default-base >= 3.0.101-108.108.1
  • kernel-default-devel >= 3.0.101-108.108.1
  • kernel-default-man >= 3.0.101-108.108.1
  • kernel-ec2 >= 3.0.101-108.108.1
  • kernel-ec2-base >= 3.0.101-108.108.1
  • kernel-ec2-devel >= 3.0.101-108.108.1
  • kernel-pae >= 3.0.101-108.108.1
  • kernel-pae-base >= 3.0.101-108.108.1
  • kernel-pae-devel >= 3.0.101-108.108.1
  • kernel-ppc64 >= 3.0.101-108.108.1
  • kernel-ppc64-base >= 3.0.101-108.108.1
  • kernel-ppc64-devel >= 3.0.101-108.108.1
  • kernel-source >= 3.0.101-108.108.1
  • kernel-syms >= 3.0.101-108.108.1
  • kernel-trace >= 3.0.101-108.108.1
  • kernel-trace-base >= 3.0.101-108.108.1
  • kernel-trace-devel >= 3.0.101-108.108.1
  • kernel-xen >= 3.0.101-108.108.1
  • kernel-xen-base >= 3.0.101-108.108.1
  • kernel-xen-devel >= 3.0.101-108.108.1
Patchnames:
slessp4-kernel-source-14218
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • kernel-default >= 3.12.74-60.64.124.1
  • kernel-default-base >= 3.12.74-60.64.124.1
  • kernel-default-devel >= 3.12.74-60.64.124.1
  • kernel-default-man >= 3.12.74-60.64.124.1
  • kernel-devel >= 3.12.74-60.64.124.1
  • kernel-macros >= 3.12.74-60.64.124.1
  • kernel-source >= 3.12.74-60.64.124.1
  • kernel-syms >= 3.12.74-60.64.124.1
  • kernel-xen >= 3.12.74-60.64.124.1
  • kernel-xen-base >= 3.12.74-60.64.124.1
  • kernel-xen-devel >= 3.12.74-60.64.124.1
  • kgraft-patch-3_12_74-60_64_124-default >= 1-2.3.1
  • kgraft-patch-3_12_74-60_64_124-xen >= 1-2.3.1
  • kgraft-patch-SLE12-SP1_Update_37 >= 1-2.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2950
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • kernel-default >= 4.4.121-92.125.1
  • kernel-default-base >= 4.4.121-92.125.1
  • kernel-default-devel >= 4.4.121-92.125.1
  • kernel-devel >= 4.4.121-92.125.1
  • kernel-macros >= 4.4.121-92.125.1
  • kernel-source >= 4.4.121-92.125.1
  • kernel-syms >= 4.4.121-92.125.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2984
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • kernel-default >= 4.4.121-92.125.1
  • kernel-default-base >= 4.4.121-92.125.1
  • kernel-default-devel >= 4.4.121-92.125.1
  • kernel-devel >= 4.4.121-92.125.1
  • kernel-macros >= 4.4.121-92.125.1
  • kernel-source >= 4.4.121-92.125.1
  • kernel-syms >= 4.4.121-92.125.1
  • kgraft-patch-4_4_121-92_125-default >= 1-3.5.1
  • kgraft-patch-SLE12-SP2_Update_33 >= 1-3.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2984
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • kernel-default >= 4.4.121-92.125.1
  • kernel-default-base >= 4.4.121-92.125.1
  • kernel-default-devel >= 4.4.121-92.125.1
  • kernel-default-man >= 4.4.121-92.125.1
  • kernel-devel >= 4.4.121-92.125.1
  • kernel-macros >= 4.4.121-92.125.1
  • kernel-source >= 4.4.121-92.125.1
  • kernel-syms >= 4.4.121-92.125.1
  • kgraft-patch-4_4_121-92_125-default >= 1-3.5.1
  • kgraft-patch-SLE12-SP2_Update_33 >= 1-3.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2984
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • kernel-default >= 4.4.180-94.107.1
  • kernel-default-base >= 4.4.180-94.107.1
  • kernel-default-devel >= 4.4.180-94.107.1
  • kernel-devel >= 4.4.180-94.107.1
  • kernel-macros >= 4.4.180-94.107.1
  • kernel-source >= 4.4.180-94.107.1
  • kernel-syms >= 4.4.180-94.107.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2949
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • kernel-default >= 4.4.180-94.107.1
  • kernel-default-base >= 4.4.180-94.107.1
  • kernel-default-devel >= 4.4.180-94.107.1
  • kernel-default-kgraft >= 4.4.180-94.107.1
  • kernel-devel >= 4.4.180-94.107.1
  • kernel-macros >= 4.4.180-94.107.1
  • kernel-source >= 4.4.180-94.107.1
  • kernel-syms >= 4.4.180-94.107.1
  • kgraft-patch-4_4_180-94_107-default >= 1-4.3.1
  • kgraft-patch-SLE12-SP3_Update_29 >= 1-4.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2949
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • kernel-default >= 4.4.180-94.107.1
  • kernel-default-base >= 4.4.180-94.107.1
  • kernel-default-devel >= 4.4.180-94.107.1
  • kernel-default-kgraft >= 4.4.180-94.107.1
  • kernel-default-man >= 4.4.180-94.107.1
  • kernel-devel >= 4.4.180-94.107.1
  • kernel-macros >= 4.4.180-94.107.1
  • kernel-source >= 4.4.180-94.107.1
  • kernel-syms >= 4.4.180-94.107.1
  • kgraft-patch-4_4_180-94_107-default >= 1-4.3.1
  • kgraft-patch-SLE12-SP3_Update_29 >= 1-4.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2949
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • kernel-default >= 3.12.74-60.64.124.1
  • kernel-default-base >= 3.12.74-60.64.124.1
  • kernel-default-devel >= 3.12.74-60.64.124.1
  • kernel-devel >= 3.12.74-60.64.124.1
  • kernel-macros >= 3.12.74-60.64.124.1
  • kernel-source >= 3.12.74-60.64.124.1
  • kernel-syms >= 3.12.74-60.64.124.1
  • kernel-xen >= 3.12.74-60.64.124.1
  • kernel-xen-base >= 3.12.74-60.64.124.1
  • kernel-xen-devel >= 3.12.74-60.64.124.1
  • kgraft-patch-3_12_74-60_64_124-default >= 1-2.3.1
  • kgraft-patch-3_12_74-60_64_124-xen >= 1-2.3.1
  • kgraft-patch-SLE12-SP1_Update_37 >= 1-2.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2950
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • kernel-default >= 4.4.121-92.125.1
  • kernel-default-base >= 4.4.121-92.125.1
  • kernel-default-devel >= 4.4.121-92.125.1
  • kernel-devel >= 4.4.121-92.125.1
  • kernel-macros >= 4.4.121-92.125.1
  • kernel-source >= 4.4.121-92.125.1
  • kernel-syms >= 4.4.121-92.125.1
  • kgraft-patch-4_4_121-92_125-default >= 1-3.5.1
  • kgraft-patch-SLE12-SP2_Update_33 >= 1-3.5.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2984
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • kernel-default >= 4.4.180-94.107.1
  • kernel-default-base >= 4.4.180-94.107.1
  • kernel-default-devel >= 4.4.180-94.107.1
  • kernel-default-kgraft >= 4.4.180-94.107.1
  • kernel-devel >= 4.4.180-94.107.1
  • kernel-macros >= 4.4.180-94.107.1
  • kernel-source >= 4.4.180-94.107.1
  • kernel-syms >= 4.4.180-94.107.1
  • kgraft-patch-4_4_180-94_107-default >= 1-4.3.1
  • kgraft-patch-SLE12-SP3_Update_29 >= 1-4.3.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2949
SUSE OpenStack Cloud 7
  • kernel-default >= 4.4.121-92.125.1
  • kernel-default-base >= 4.4.121-92.125.1
  • kernel-default-devel >= 4.4.121-92.125.1
  • kernel-default-man >= 4.4.121-92.125.1
  • kernel-devel >= 4.4.121-92.125.1
  • kernel-macros >= 4.4.121-92.125.1
  • kernel-source >= 4.4.121-92.125.1
  • kernel-syms >= 4.4.121-92.125.1
  • kgraft-patch-4_4_121-92_125-default >= 1-3.5.1
  • kgraft-patch-SLE12-SP2_Update_33 >= 1-3.5.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2984
SUSE OpenStack Cloud 8
  • kernel-default >= 4.4.180-94.107.1
  • kernel-default-base >= 4.4.180-94.107.1
  • kernel-default-devel >= 4.4.180-94.107.1
  • kernel-default-kgraft >= 4.4.180-94.107.1
  • kernel-devel >= 4.4.180-94.107.1
  • kernel-macros >= 4.4.180-94.107.1
  • kernel-source >= 4.4.180-94.107.1
  • kernel-syms >= 4.4.180-94.107.1
  • kgraft-patch-4_4_180-94_107-default >= 1-4.3.1
  • kgraft-patch-SLE12-SP3_Update_29 >= 1-4.3.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2949
SUSE OpenStack Cloud Crowbar 8
  • kernel-default >= 4.4.180-94.107.1
  • kernel-default-base >= 4.4.180-94.107.1
  • kernel-default-devel >= 4.4.180-94.107.1
  • kernel-default-kgraft >= 4.4.180-94.107.1
  • kernel-devel >= 4.4.180-94.107.1
  • kernel-macros >= 4.4.180-94.107.1
  • kernel-source >= 4.4.180-94.107.1
  • kernel-syms >= 4.4.180-94.107.1
  • kgraft-patch-4_4_180-94_107-default >= 1-4.3.1
  • kgraft-patch-SLE12-SP3_Update_29 >= 1-4.3.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2949


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Business Critical Linux 12 SP2 kernel-source Analysis
SUSE Business Critical Linux 12 SP3 kernel-source Analysis
SUSE Linux Enterprise Desktop 12 SP4 kernel-source Affected
SUSE Linux Enterprise High Performance Computing 12 kernel-source Analysis
SUSE Linux Enterprise High Performance Computing ESPOS 15 GA kernel-source Analysis
SUSE Linux Enterprise High Performance Computing LTSS 15 GA kernel-source Analysis
SUSE Linux Enterprise Module for Basesystem 15 GA kernel-source Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 kernel-source Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 kernel-source Analysis
SUSE Linux Enterprise Module for Development Tools 15 GA kernel-source Affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 kernel-source Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 kernel-source Analysis
SUSE Linux Enterprise Server 11 SP4 LTSS kernel-source Released
SUSE Linux Enterprise Server 12 SP1 LTSS kernel-source Released
SUSE Linux Enterprise Server 12 SP2 LTSS kernel-source Released
SUSE Linux Enterprise Server 12 SP3 LTSS kernel-source Released
SUSE Linux Enterprise Server 12 SP4 kernel-source Affected
SUSE Linux Enterprise Server 12 SP4 LTSS kernel-source Analysis
SUSE Linux Enterprise Server 12 SP5 kernel-source Analysis
SUSE Linux Enterprise Server 15 GA LTSS kernel-source Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP2 kernel-source Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kernel-source Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kernel-source Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 kernel-source Analysis