Upstream information

CVE-2019-15605 at MITRE

Description

HTTP request smuggling in Node.js 10, 12, and 13 causes malicious payload delivery when transfer-encoding is malformed

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1163102 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • nodejs10 >= 10.19.0-1.18.1
  • nodejs10-devel >= 10.19.0-1.18.1
  • nodejs10-docs >= 10.19.0-1.18.1
  • nodejs8 >= 8.17.0-3.28.1
  • nodejs8-devel >= 8.17.0-3.28.1
  • nodejs8-docs >= 8.17.0-3.28.1
  • npm10 >= 10.19.0-1.18.1
  • npm8 >= 8.17.0-3.28.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-454
SUSE-SLE-Product-HPC-15-2020-455
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs10 >= 10.19.0-1.18.1
  • nodejs10-devel >= 10.19.0-1.18.1
  • nodejs10-docs >= 10.19.0-1.18.1
  • nodejs12 >= 12.15.0-1.6.1
  • nodejs12-devel >= 12.15.0-1.6.1
  • nodejs12-docs >= 12.15.0-1.6.1
  • nodejs6 >= 6.17.1-11.33.1
  • nodejs6-devel >= 6.17.1-11.33.1
  • nodejs6-docs >= 6.17.1-11.33.1
  • npm10 >= 10.19.0-1.18.1
  • npm12 >= 12.15.0-1.6.1
  • npm6 >= 6.17.1-11.33.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2020-427
SUSE-SLE-Module-Web-Scripting-12-2020-429
SUSE-SLE-Module-Web-Scripting-12-2020-488
SUSE Linux Enterprise Module for Web Scripting 15 SP1
  • nodejs10 >= 10.19.0-1.18.1
  • nodejs10-devel >= 10.19.0-1.18.1
  • nodejs10-docs >= 10.19.0-1.18.1
  • nodejs8 >= 8.17.0-3.28.1
  • nodejs8-devel >= 8.17.0-3.28.1
  • nodejs8-docs >= 8.17.0-3.28.1
  • npm10 >= 10.19.0-1.18.1
  • npm8 >= 8.17.0-3.28.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP1-2020-454
SUSE-SLE-Module-Web-Scripting-15-SP1-2020-455
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs10 >= 10.19.0-1.18.1
  • nodejs10-devel >= 10.19.0-1.18.1
  • nodejs10-docs >= 10.19.0-1.18.1
  • nodejs8 >= 8.17.0-3.28.1
  • nodejs8-devel >= 8.17.0-3.28.1
  • nodejs8-docs >= 8.17.0-3.28.1
  • npm10 >= 10.19.0-1.18.1
  • npm8 >= 8.17.0-3.28.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-2020-454
SUSE-SLE-Module-Web-Scripting-15-2020-455
SUSE Linux Enterprise Server 15-LTSS
  • nodejs10 >= 10.19.0-1.18.1
  • nodejs10-devel >= 10.19.0-1.18.1
  • nodejs10-docs >= 10.19.0-1.18.1
  • nodejs8 >= 8.17.0-3.28.1
  • nodejs8-devel >= 8.17.0-3.28.1
  • nodejs8-docs >= 8.17.0-3.28.1
  • npm10 >= 10.19.0-1.18.1
  • npm8 >= 8.17.0-3.28.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-454
SUSE-SLE-Product-SLES-15-2020-455
SUSE Linux Enterprise Server for SAP Applications 15
  • nodejs10 >= 10.19.0-1.18.1
  • nodejs10-devel >= 10.19.0-1.18.1
  • nodejs10-docs >= 10.19.0-1.18.1
  • nodejs8 >= 8.17.0-3.28.1
  • nodejs8-devel >= 8.17.0-3.28.1
  • nodejs8-docs >= 8.17.0-3.28.1
  • npm10 >= 10.19.0-1.18.1
  • npm8 >= 8.17.0-3.28.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-454
SUSE-SLE-Product-SLES_SAP-15-2020-455
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.17.1-11.33.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-488
SUSE OpenStack Cloud Crowbar 8
  • nodejs6 >= 6.17.1-11.33.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-488
SUSE OpenStack Cloud Crowbar 9
  • nodejs6 >= 6.17.1-11.33.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2020-488
openSUSE Leap 15.1
  • nodejs8 >= 8.17.0-lp151.2.12.1
  • nodejs8-debuginfo >= 8.17.0-lp151.2.12.1
  • nodejs8-debugsource >= 8.17.0-lp151.2.12.1
  • nodejs8-devel >= 8.17.0-lp151.2.12.1
  • nodejs8-docs >= 8.17.0-lp151.2.12.1
  • npm8 >= 8.17.0-lp151.2.12.1
Patchnames:
openSUSE-2020-293


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs10 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs12 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Released
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs10 Released
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs8 Released
SUSE Openstack Cloud 7 nodejs6 Released
SUSE Openstack Cloud 8 nodejs6 Released
SUSE Openstack Cloud 9 nodejs6 Released
SUSE Storage 4 nodejs4 Unsupported
SUSE Storage 4 nodejs6 Unsupported
SUSE Studio Onsite 1.3 nodejs Unsupported