Upstream information

CVE-2019-1543 at MITRE

Description

ChaCha20-Poly1305 is an AEAD cipher, and requires a unique nonce input for every encryption operation. RFC 7539 specifies that the nonce value (IV) should be 96 bits (12 bytes). OpenSSL allows a variable nonce length and front pads the nonce with 0 bytes if it is less than 12 bytes. However it also incorrectly allows a nonce to be set of up to 16 bytes. In this case only the last 12 bytes are significant and any additional leading bytes are ignored. It is a requirement of using this cipher that nonce values are unique. Messages encrypted using a reused nonce value are susceptible to serious confidentiality and integrity attacks. If an application changes the default nonce length to be longer than 12 bytes and then makes a change to the leading bytes of the nonce expecting the new value to be a new unique nonce then such an application could inadvertently encrypt messages with a reused nonce. Additionally the ignored bytes in a long nonce are not covered by the integrity guarantee of this cipher. Any application that relies on the integrity of these ignored leading bytes of a long nonce may be further affected. Any OpenSSL internal use of this cipher, including in SSL/TLS, is safe because no such use sets such a long nonce value. However user applications that use this cipher directly and set a non-default nonce length to be longer than 12 bytes may be vulnerable. OpenSSL versions 1.1.1 and 1.1.0 are affected by this issue. Due to the limited scope of affected deployments this has been assessed as low severity and therefore we are not creating new releases at this time. Fixed in OpenSSL 1.1.1c (Affected 1.1.1-1.1.1b). Fixed in OpenSSL 1.1.0k (Affected 1.1.0-1.1.0j).

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.4 3.7
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact None None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1128189 [RESOLVED / FIXED], 1141801 [RESOLVED / FIXED], 1154162 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • libopenssl1_1 >= 1.1.1-2.9.1
  • libopenssl1_1-32bit >= 1.1.1-2.9.1
  • openssl-1_1 >= 1.1.1-2.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-787
SUSE Linux Enterprise Module for Basesystem 15
  • libopenssl-1_1-devel >= 1.1.0i-4.21.1
  • libopenssl1_1 >= 1.1.0i-4.21.1
  • libopenssl1_1-32bit >= 1.1.0i-4.21.1
  • libopenssl1_1-hmac >= 1.1.0i-4.21.1
  • libopenssl1_1-hmac-32bit >= 1.1.0i-4.21.1
  • openssl-1_1 >= 1.1.0i-4.21.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-678
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libopenssl-1_1-devel >= 1.1.0i-12.9
  • libopenssl1_1 >= 1.1.0i-12.9
  • libopenssl1_1-32bit >= 1.1.0i-12.9
  • libopenssl1_1-hmac >= 1.1.0i-12.9
  • libopenssl1_1-hmac-32bit >= 1.1.0i-12.9
  • openssl-1_1 >= 1.1.0i-12.9
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libopenssl-1_1-devel
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libopenssl-1_1-devel-32bit >= 1.1.0i-4.21.1
  • openssl-1_1 >= 1.1.0i-4.21.1
  • openssl-1_1-doc >= 1.1.0i-4.21.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-678
SUSE Linux Enterprise Server 12 SP4
  • libopenssl1_1 >= 1.1.1-2.9.1
  • libopenssl1_1-32bit >= 1.1.1-2.9.1
  • openssl-1_1 >= 1.1.1-2.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-787
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libopenssl1_1 >= 1.1.1-2.9.1
  • libopenssl1_1-32bit >= 1.1.1-2.9.1
  • openssl-1_1 >= 1.1.1-2.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-787
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libopenssl-1_1-devel >= 1.1.1-2.9.1
  • libopenssl-1_1-devel-32bit >= 1.1.1-2.9.1
  • openssl-1_1 >= 1.1.1-2.9.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-787
openSUSE Leap 15.0
  • libopenssl-1_1-devel >= 1.1.0i-lp150.3.22.3
  • libopenssl1_1 >= 1.1.0i-lp150.3.22.3
  • libopenssl1_1-debuginfo >= 1.1.0i-lp150.3.22.3
  • libopenssl1_1-hmac >= 1.1.0i-lp150.3.22.3
  • openssl-1_1 >= 1.1.0i-lp150.3.22.3
  • openssl-1_1-debuginfo >= 1.1.0i-lp150.3.22.3
  • openssl-1_1-debugsource >= 1.1.0i-lp150.3.22.3
  • openssl-1_1-doc >= 1.1.0i-lp150.3.22.3
  • python3-virtualbox >= 6.0.10-lp150.4.36.1
  • python3-virtualbox-debuginfo >= 6.0.10-lp150.4.36.1
  • virtualbox >= 6.0.10-lp150.4.36.1
  • virtualbox-debuginfo >= 6.0.10-lp150.4.36.1
  • virtualbox-debugsource >= 6.0.10-lp150.4.36.1
  • virtualbox-devel >= 6.0.10-lp150.4.36.1
  • virtualbox-guest-desktop-icons >= 6.0.10-lp150.4.36.1
  • virtualbox-guest-kmp-default >= 6.0.10_k4.12.14_lp150.12.67-lp150.4.36.1
  • virtualbox-guest-kmp-default-debuginfo >= 6.0.10_k4.12.14_lp150.12.67-lp150.4.36.1
  • virtualbox-guest-source >= 6.0.10-lp150.4.36.1
  • virtualbox-guest-tools >= 6.0.10-lp150.4.36.1
  • virtualbox-guest-tools-debuginfo >= 6.0.10-lp150.4.36.1
  • virtualbox-guest-x11 >= 6.0.10-lp150.4.36.1
  • virtualbox-guest-x11-debuginfo >= 6.0.10-lp150.4.36.1
  • virtualbox-host-kmp-default >= 6.0.10_k4.12.14_lp150.12.67-lp150.4.36.1
  • virtualbox-host-kmp-default-debuginfo >= 6.0.10_k4.12.14_lp150.12.67-lp150.4.36.1
  • virtualbox-host-source >= 6.0.10-lp150.4.36.1
  • virtualbox-qt >= 6.0.10-lp150.4.36.1
  • virtualbox-qt-debuginfo >= 6.0.10-lp150.4.36.1
  • virtualbox-vnc >= 6.0.10-lp150.4.36.1
  • virtualbox-websrv >= 6.0.10-lp150.4.36.1
  • virtualbox-websrv-debuginfo >= 6.0.10-lp150.4.36.1
Patchnames:
openSUSE-2019-1147
openSUSE-2019-1814
openSUSE Leap 15.1
  • python3-virtualbox >= 6.0.10-lp151.2.6.1
  • python3-virtualbox-debuginfo >= 6.0.10-lp151.2.6.1
  • virtualbox >= 6.0.10-lp151.2.6.1
  • virtualbox-debuginfo >= 6.0.10-lp151.2.6.1
  • virtualbox-debugsource >= 6.0.10-lp151.2.6.1
  • virtualbox-devel >= 6.0.10-lp151.2.6.1
  • virtualbox-guest-desktop-icons >= 6.0.10-lp151.2.6.1
  • virtualbox-guest-kmp-default >= 6.0.10_k4.12.14_lp151.28.10-lp151.2.6.1
  • virtualbox-guest-kmp-default-debuginfo >= 6.0.10_k4.12.14_lp151.28.10-lp151.2.6.1
  • virtualbox-guest-source >= 6.0.10-lp151.2.6.1
  • virtualbox-guest-tools >= 6.0.10-lp151.2.6.1
  • virtualbox-guest-tools-debuginfo >= 6.0.10-lp151.2.6.1
  • virtualbox-guest-x11 >= 6.0.10-lp151.2.6.1
  • virtualbox-guest-x11-debuginfo >= 6.0.10-lp151.2.6.1
  • virtualbox-host-kmp-default >= 6.0.10_k4.12.14_lp151.28.10-lp151.2.6.1
  • virtualbox-host-kmp-default-debuginfo >= 6.0.10_k4.12.14_lp151.28.10-lp151.2.6.1
  • virtualbox-host-source >= 6.0.10-lp151.2.6.1
  • virtualbox-qt >= 6.0.10-lp151.2.6.1
  • virtualbox-qt-debuginfo >= 6.0.10-lp151.2.6.1
  • virtualbox-vnc >= 6.0.10-lp151.2.6.1
  • virtualbox-websrv >= 6.0.10-lp151.2.6.1
  • virtualbox-websrv-debuginfo >= 6.0.10-lp151.2.6.1
Patchnames:
openSUSE-2019-1814


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 openssl Not affected
CaaS Platform 3.0 openssl Not affected
OpenStack Cloud Magnum Orchestration 7.0 openssl Not affected
SUSE Linux Enterprise Desktop 12 SP3 openssl Not affected
SUSE Linux Enterprise Desktop 12 SP4 openssl Not affected
SUSE Linux Enterprise High Performance Computing 12 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA openssl Affected
SUSE Linux Enterprise SDK 11 SP4 openssl Not affected
SUSE Linux Enterprise SDK 12 SP3 openssl Not affected
SUSE Linux Enterprise SDK 12 SP4 openssl Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP4 openssl Not affected
SUSE Linux Enterprise Server 12 GA LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP3 openssl Not affected
SUSE Linux Enterprise Server 12 SP4 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl Not affected
SUSE Studio Onsite 1.3 openssl Not affected