Upstream information

CVE-2019-14859 at MITRE

Description

A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 6.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High None
Availability Impact None Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1154217 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
HPE-Helion-OpenStack-8-2019-3024
SUSE CaaS Platform 3.0
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-CAASP-3.0-2019-3024
SUSE Enterprise Storage 4
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-Storage-4-2019-3024
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • python-ecdsa >= 0.13.3-3.3.1
  • python3-ecdsa >= 0.13.3-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2891
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • python-ecdsa >= 0.13.3-3.3.1
  • python2-ecdsa >= 0.13.3-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2891
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • python-ecdsa >= 0.13.3-3.3.1
  • python2-ecdsa >= 0.13.3-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2891
SUSE Linux Enterprise Module for Public Cloud 12
  • python-ecdsa >= 0.13.3-5.10.1
  • python3-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2019-3024
SUSE Linux Enterprise Module for Public Cloud 15
  • python-ecdsa >= 0.13.3-3.3.1
  • python3-ecdsa >= 0.13.3-3.3.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-2019-2891
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • python-ecdsa >= 0.13.3-3.3.1
  • python2-ecdsa >= 0.13.3-3.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-2891
SUSE Manager Server 3.2
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-SUSE-Manager-Server-3.2-2019-3024
SUSE OpenStack Cloud 7
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-3024
SUSE OpenStack Cloud 8
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-3024
SUSE OpenStack Cloud 9
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-OpenStack-Cloud-9-2019-3024
SUSE OpenStack Cloud Crowbar 8
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-3024
SUSE OpenStack Cloud Crowbar 9
  • python-ecdsa >= 0.13.3-5.10.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2019-3024
openSUSE Leap 15.0
  • python-ecdsa >= 0.13.3-lp150.2.3.1
  • python2-ecdsa >= 0.13.3-lp150.2.3.1
  • python3-ecdsa >= 0.13.3-lp150.2.3.1
Patchnames:
openSUSE-2019-2472
openSUSE Leap 15.1
  • python-ecdsa >= 0.13.3-lp151.3.3.1
  • python2-ecdsa >= 0.13.3-lp151.3.3.1
  • python3-ecdsa >= 0.13.3-lp151.3.3.1
Patchnames:
openSUSE-2019-2474


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 python-ecdsa Affected
CaaS Platform 2.0 python-ecdsa Affected
CaaS Platform 3.0 python-ecdsa Released
HPE Helion OpenStack 8 python-ecdsa Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-ecdsa Released
SUSE Linux Enterprise Module for Public Cloud 12 python-ecdsa Released
SUSE Linux Enterprise Module for Public Cloud 15 python-ecdsa Released
SUSE Manager Server 3.2 python-ecdsa Released
SUSE Openstack Cloud 6 python-ecdsa Affected
SUSE Openstack Cloud 7 python-ecdsa Released
SUSE Openstack Cloud 8 python-ecdsa Released
SUSE Openstack Cloud 9 python-ecdsa Released
SUSE Storage 4 python-ecdsa Released