Upstream information

CVE-2019-14822 at MITRE

Description

A flaw was discovered in ibus that allows any unprivileged user to monitor and send method calls to the ibus bus of another user due to a misconfiguration in the DBus server setup. A local attacker may use this flaw to intercept all keystrokes of a victim user who is using the graphical interface, change the input method engine, or modify other input related configurations of the victim user.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.1 8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High High
Availability Impact None High
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1150011 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
HPE-Helion-OpenStack-8-2019-2389
SUSE Enterprise Storage 4
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-Storage-4-2019-2389
SUSE Enterprise Storage 5
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-Storage-5-2019-2389
SUSE Linux Enterprise Desktop 12 SP4
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-gtk3-32bit >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • libibus-1_0-5-32bit >= 1.5.13-15.11.2
  • python-ibus >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2389
SUSE Linux Enterprise High Performance Computing 12 SP5
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • ibus >= 1.5.19-8.3.1
  • ibus-devel >= 1.5.19-8.3.1
  • ibus-gtk >= 1.5.19-8.3.1
  • ibus-gtk3 >= 1.5.19-8.3.1
  • ibus-lang >= 1.5.19-8.3.1
  • libibus-1_0-5 >= 1.5.19-8.3.1
  • typelib-1_0-IBus-1_0 >= 1.5.19-8.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-2427
SUSE Linux Enterprise Module for Desktop Applications 15
  • ibus >= 1.5.17-5.3.1
  • ibus-devel >= 1.5.17-5.3.1
  • ibus-gtk >= 1.5.17-5.3.1
  • ibus-gtk3 >= 1.5.17-5.3.1
  • ibus-lang >= 1.5.17-5.3.1
  • libibus-1_0-5 >= 1.5.17-5.3.1
  • python-ibus >= 1.5.17-5.3.1
  • typelib-1_0-IBus-1_0 >= 1.5.17-5.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-2387
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ibus >= 1.5.19-8.3.1
  • ibus-gtk-32bit >= 1.5.19-8.3.1
  • ibus-gtk3-32bit >= 1.5.19-8.3.1
  • libibus-1_0-5-32bit >= 1.5.19-8.3.1
  • python-ibus >= 1.5.19-8.3.1
  • python3-ibus >= 1.5.17-5.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2387
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2427
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • python3-ibus >= 1.5.17-5.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2387
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2389
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • ibus >= 1.5.8-10.4.1
  • ibus-gtk >= 1.5.8-10.4.1
  • ibus-gtk3 >= 1.5.8-10.4.1
  • ibus-lang >= 1.5.8-10.4.1
  • libibus-1_0-5 >= 1.5.8-10.4.1
  • typelib-1_0-IBus-1_0 >= 1.5.8-10.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2388
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2389
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2389
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2389
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2389
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2389
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2389
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2389
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2389
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ibus >= 1.5.8-10.4.1
  • ibus-gtk >= 1.5.8-10.4.1
  • ibus-gtk3 >= 1.5.8-10.4.1
  • ibus-lang >= 1.5.8-10.4.1
  • libibus-1_0-5 >= 1.5.8-10.4.1
  • typelib-1_0-IBus-1_0 >= 1.5.8-10.4.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2388
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2389
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2389
SUSE Linux Enterprise Software Development Kit 12 SP4
  • ibus >= 1.5.13-15.11.2
  • ibus-devel >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2389
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ibus >= 1.5.13-15.11.2
  • ibus-devel >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-2389
SUSE Linux Enterprise Workstation Extension 12 SP4
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk3-32bit >= 1.5.13-15.11.2
  • libibus-1_0-5-32bit >= 1.5.13-15.11.2
  • python-ibus >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-WE-12-SP4-2019-2389
SUSE Linux Enterprise Workstation Extension 12 SP5
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk3-32bit >= 1.5.13-15.11.2
  • libibus-1_0-5-32bit >= 1.5.13-15.11.2
  • python-ibus >= 1.5.13-15.11.2
Patchnames:
SUSE-SLE-WE-12-SP5-2019-2389
SUSE OpenStack Cloud 7
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2389
SUSE OpenStack Cloud 8
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2389
SUSE OpenStack Cloud Crowbar 8
  • ibus >= 1.5.13-15.11.2
  • ibus-gtk >= 1.5.13-15.11.2
  • ibus-gtk3 >= 1.5.13-15.11.2
  • ibus-lang >= 1.5.13-15.11.2
  • libibus-1_0-5 >= 1.5.13-15.11.2
  • typelib-1_0-IBus-1_0 >= 1.5.13-15.11.2
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2389
openSUSE Leap 15.0
  • ibus >= 1.5.17-lp150.4.3.1
  • ibus-branding-openSUSE-KDE >= 1.5.17-lp150.4.3.1
  • ibus-debuginfo >= 1.5.17-lp150.4.3.1
  • ibus-debugsource >= 1.5.17-lp150.4.3.1
  • ibus-devel >= 1.5.17-lp150.4.3.1
  • ibus-gtk >= 1.5.17-lp150.4.3.1
  • ibus-gtk-32bit >= 1.5.17-lp150.4.3.1
  • ibus-gtk-32bit-debuginfo >= 1.5.17-lp150.4.3.1
  • ibus-gtk-debuginfo >= 1.5.17-lp150.4.3.1
  • ibus-gtk3 >= 1.5.17-lp150.4.3.1
  • ibus-gtk3-32bit >= 1.5.17-lp150.4.3.1
  • ibus-gtk3-32bit-debuginfo >= 1.5.17-lp150.4.3.1
  • ibus-gtk3-debuginfo >= 1.5.17-lp150.4.3.1
  • ibus-lang >= 1.5.17-lp150.4.3.1
  • libibus-1_0-5 >= 1.5.17-lp150.4.3.1
  • libibus-1_0-5-32bit >= 1.5.17-lp150.4.3.1
  • libibus-1_0-5-32bit-debuginfo >= 1.5.17-lp150.4.3.1
  • libibus-1_0-5-debuginfo >= 1.5.17-lp150.4.3.1
  • python-ibus >= 1.5.17-lp150.4.3.1
  • python3-ibus >= 1.5.17-lp150.4.3.1
  • typelib-1_0-IBus-1_0 >= 1.5.17-lp150.4.3.1
Patchnames:
openSUSE-2019-2174
openSUSE Leap 15.1
  • ibus >= 1.5.19-lp151.2.3.1
  • ibus-debuginfo >= 1.5.19-lp151.2.3.1
  • ibus-debugsource >= 1.5.19-lp151.2.3.1
  • ibus-devel >= 1.5.19-lp151.2.3.1
  • ibus-gtk >= 1.5.19-lp151.2.3.1
  • ibus-gtk-32bit >= 1.5.19-lp151.2.3.1
  • ibus-gtk-32bit-debuginfo >= 1.5.19-lp151.2.3.1
  • ibus-gtk-debuginfo >= 1.5.19-lp151.2.3.1
  • ibus-gtk3 >= 1.5.19-lp151.2.3.1
  • ibus-gtk3-32bit >= 1.5.19-lp151.2.3.1
  • ibus-gtk3-32bit-debuginfo >= 1.5.19-lp151.2.3.1
  • ibus-gtk3-debuginfo >= 1.5.19-lp151.2.3.1
  • ibus-lang >= 1.5.19-lp151.2.3.1
  • libibus-1_0-5 >= 1.5.19-lp151.2.3.1
  • libibus-1_0-5-32bit >= 1.5.19-lp151.2.3.1
  • libibus-1_0-5-32bit-debuginfo >= 1.5.19-lp151.2.3.1
  • libibus-1_0-5-debuginfo >= 1.5.19-lp151.2.3.1
  • python-ibus >= 1.5.19-lp151.2.3.1
  • typelib-1_0-IBus-1_0 >= 1.5.19-lp151.2.3.1
Patchnames:
openSUSE-2019-2199


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP4 ibus Released
SUSE Linux Enterprise High Performance Computing 12 ibus Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA ibus Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 ibus Released
SUSE Linux Enterprise SDK 12 SP4 ibus Released
SUSE Linux Enterprise Server 12 SP1 LTSS ibus Released
SUSE Linux Enterprise Server 12 SP2 ibus Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ibus Released
SUSE Linux Enterprise Server 12 SP3 LTSS ibus Released
SUSE Linux Enterprise Server 12 SP4 ibus Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ibus Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ibus Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ibus Released
SUSE Linux Enterprise Workstation Extension 12 SP4 ibus Released