Upstream information

CVE-2019-14287 at MITRE

Description

In Sudo before 1.8.28, an attacker with access to a Runas ALL sudoer account can bypass certain policy blacklists and session PAM modules, and can cause incorrect logging, by invoking sudo with a crafted user ID. For example, this allows bypass of !root configuration, and USER= logging, for a "sudo -u \#$((0xffffffff))" command.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  SUSE
Base Score 7
Vector AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.0
SUSE Bugzilla entries: 1153674 [RESOLVED / FIXED], 1154901 [IN_PROGRESS], 1156093 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2666
SUSE CaaS Platform 3.0
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-CAASP-3.0-2019-2666
SUSE Enterprise Storage 4
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-Storage-4-2019-2667
SUSE Enterprise Storage 5
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-Storage-5-2019-2666
SUSE Linux Enterprise Desktop 12 SP4
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2666
SUSE Linux Enterprise Module for Basesystem 15
  • sudo >= 1.8.22-4.6.1
  • sudo-devel >= 1.8.22-4.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2656
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • sudo >= 1.8.22-4.6.1
  • sudo-devel >= 1.8.22-4.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2656
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • sudo >= 1.8.22-4.6.1
  • sudo-test >= 1.8.22-4.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2656
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • sudo >= 1.8.22-4.6.1
  • sudo-test >= 1.8.22-4.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2656
SUSE Linux Enterprise Point of Sale 11 SP3
  • sudo >= 1.7.6p2-0.30.5.1
Patchnames:
sleposp3-sudo-14193
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2667
SUSE Linux Enterprise Server 11 SP4-LTSS
  • sudo >= 1.7.6p2-0.30.5.1
Patchnames:
slessp4-sudo-14193
SUSE Linux Enterprise Server 12 SP1-LTSS
  • sudo >= 1.8.10p3-2.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2668
SUSE Linux Enterprise Server 12 SP2-BCL
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2667
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2667
SUSE Linux Enterprise Server 12 SP2-LTSS
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2667
SUSE Linux Enterprise Server 12 SP3-BCL
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2666
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2666
SUSE Linux Enterprise Server 12 SP3-LTSS
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2666
SUSE Linux Enterprise Server 12 SP4
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2666
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • sudo >= 1.7.6p2-0.30.5.1
Patchnames:
slessp4-sudo-14193
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • sudo >= 1.8.10p3-2.28.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2668
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • sudo >= 1.8.10p3-2.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2668
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2667
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2667
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2667
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2667
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2666
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2666
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2666
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2666
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2666
SUSE Linux Enterprise Software Development Kit 12 SP4
  • sudo >= 1.8.20p2-3.14.1
  • sudo-devel >= 1.8.20p2-3.14.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2666
SUSE OpenStack Cloud 6
  • sudo >= 1.8.10p3-2.28.1
Patchnames:
SUSE-OpenStack-Cloud-6-2019-2668
SUSE OpenStack Cloud 7
  • sudo >= 1.8.10p3-10.23.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2667
SUSE OpenStack Cloud 8
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2666
SUSE OpenStack Cloud Crowbar 8
  • sudo >= 1.8.20p2-3.14.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2666
openSUSE Leap 15.0
  • sudo >= 1.8.22-lp150.8.1
  • sudo-debuginfo >= 1.8.22-lp150.8.1
  • sudo-debugsource >= 1.8.22-lp150.8.1
  • sudo-devel >= 1.8.22-lp150.8.1
  • sudo-test >= 1.8.22-lp150.8.1
Patchnames:
openSUSE-2019-2333
openSUSE Leap 15.1
  • sudo >= 1.8.22-lp151.5.3.1
  • sudo-debuginfo >= 1.8.22-lp151.5.3.1
  • sudo-debugsource >= 1.8.22-lp151.5.3.1
  • sudo-devel >= 1.8.22-lp151.5.3.1
  • sudo-test >= 1.8.22-lp151.5.3.1
Patchnames:
openSUSE-2019-2316


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 sudo Ignore
CaaS Platform 2.0 sudo Ignore
CaaS Platform 3.0 sudo Released
SUSE Linux Enterprise Desktop 12 SP4 sudo Released
SUSE Linux Enterprise High Performance Computing 12 sudo Released
SUSE Linux Enterprise Module for Basesystem 15 GA sudo Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 sudo Released
SUSE Linux Enterprise SDK 12 SP4 sudo Released
SUSE Linux Enterprise Server 11 SP4 LTSS sudo Released
SUSE Linux Enterprise Server 12 SP1 LTSS sudo Released
SUSE Linux Enterprise Server 12 SP2 LTSS sudo Released
SUSE Linux Enterprise Server 12 SP3 LTSS sudo Released
SUSE Linux Enterprise Server 12 SP4 sudo Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sudo Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 sudo Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sudo Released