Upstream information

CVE-2019-14234 at MITRE

Description

An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. Due to an error in shallow key transformation, key and index lookups for django.contrib.postgres.fields.JSONField, and key lookups for django.contrib.postgres.fields.HStoreField, were subject to SQL injection. This could, for example, be exploited via crafted use of "OR 1=1" in a key or index name to return all records, using a suitably crafted dictionary, with dictionary expansion, as the **kwargs passed to the QuerySet.filter() function.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1142883 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • python-Django >= 1.11.23-3.12.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2257
SUSE OpenStack Cloud 7
  • python-Django >= 1.8.19-3.15.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2180
SUSE OpenStack Cloud 8
  • python-Django >= 1.11.23-3.12.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2257
SUSE OpenStack Cloud 9
  • python-Django1 >= 1.11.23-3.9.1
Patchnames:
SUSE-OpenStack-Cloud-9-2019-2335
SUSE OpenStack Cloud Crowbar 8
  • python-Django >= 1.11.23-3.12.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2257
SUSE OpenStack Cloud Crowbar 9
  • python-Django1 >= 1.11.23-3.9.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2019-2335
openSUSE Leap 15.1
  • python-Django >= 2.2.4-lp151.2.3.1
  • python3-Django >= 2.2.4-lp151.2.3.1
Patchnames:
openSUSE-2019-1839


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 python-Django Released
SUSE Openstack Cloud 6 python-Django Not affected
SUSE Openstack Cloud 7 python-Django Released
SUSE Openstack Cloud 8 python-Django Released
SUSE Storage 4 python-Django Not affected
SUSE Storage 5 python-Django Not affected