Upstream information

CVE-2019-13627 at MITRE

Description

It was discovered that there was a ECDSA timing attack in the libgcrypt20 cryptographic library. Version affected: 1.8.4-5, 1.7.6-2+deb9u3, and 1.6.3-2+deb8u4. Versions fixed: 1.8.5-2 and 1.6.3-2+deb8u7.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1148987 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2510
SUSE CaaS Platform 3.0
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
Patchnames:
SUSE-CAASP-3.0-2019-2510
SUSE Enterprise Storage 4
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-Storage-4-2019-2510
SUSE Enterprise Storage 5
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-Storage-5-2019-2510
SUSE Linux Enterprise Desktop 12 SP4
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2510
SUSE Linux Enterprise Desktop 12 SP5
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP5-2019-2510
SUSE Linux Enterprise Module for Basesystem 15
  • libgcrypt >= 1.8.2-6.20.1
  • libgcrypt-devel >= 1.8.2-6.20.1
  • libgcrypt20 >= 1.8.2-6.20.1
  • libgcrypt20-32bit >= 1.8.2-6.20.1
  • libgcrypt20-hmac >= 1.8.2-6.20.1
  • libgcrypt20-hmac-32bit >= 1.8.2-6.20.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2349
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libgcrypt >= 1.8.2-6.20.1
  • libgcrypt-cavs >= 1.8.2-6.20.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2349
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2510
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2510
SUSE Linux Enterprise Server 12 SP2-BCL
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2510
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2510
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2510
SUSE Linux Enterprise Server 12 SP3-BCL
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2510
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2510
SUSE Linux Enterprise Server 12 SP3-LTSS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2510
SUSE Linux Enterprise Server 12 SP4
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2510
SUSE Linux Enterprise Server 12 SP5
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2510
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2510
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt-devel >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2510
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt-devel >= 1.6.1-16.68.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-2510
SUSE OpenStack Cloud 7
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2510
SUSE OpenStack Cloud 8
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2510
SUSE OpenStack Cloud Crowbar 8
  • libgcrypt >= 1.6.1-16.68.1
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2510
openSUSE Leap 15.0
  • libgcrypt >= 1.8.2-lp150.5.13.1
  • libgcrypt-cavs >= 1.8.2-lp150.5.13.1
  • libgcrypt-cavs-debuginfo >= 1.8.2-lp150.5.13.1
  • libgcrypt-debugsource >= 1.8.2-lp150.5.13.1
  • libgcrypt-devel >= 1.8.2-lp150.5.13.1
  • libgcrypt-devel-32bit >= 1.8.2-lp150.5.13.1
  • libgcrypt-devel-32bit-debuginfo >= 1.8.2-lp150.5.13.1
  • libgcrypt-devel-debuginfo >= 1.8.2-lp150.5.13.1
  • libgcrypt20 >= 1.8.2-lp150.5.13.1
  • libgcrypt20-32bit >= 1.8.2-lp150.5.13.1
  • libgcrypt20-32bit-debuginfo >= 1.8.2-lp150.5.13.1
  • libgcrypt20-debuginfo >= 1.8.2-lp150.5.13.1
  • libgcrypt20-hmac >= 1.8.2-lp150.5.13.1
  • libgcrypt20-hmac-32bit >= 1.8.2-lp150.5.13.1
Patchnames:
openSUSE-2019-2161


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 libgcrypt Affected
CaaS Platform 2.0 libgcrypt Affected
CaaS Platform 3.0 libgcrypt Released
SUSE Linux Enterprise Desktop 12 SP4 libgcrypt Released
SUSE Linux Enterprise High Performance Computing 12 libgcrypt Released
SUSE Linux Enterprise Module for Basesystem 15 GA libgcrypt Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 libgcrypt Affected
SUSE Linux Enterprise SDK 12 SP4 libgcrypt Released
SUSE Linux Enterprise Server 11 SP4 LTSS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libgcrypt Released
SUSE Linux Enterprise Server 12 SP2 LTSS libgcrypt Released
SUSE Linux Enterprise Server 12 SP3 LTSS libgcrypt Released
SUSE Linux Enterprise Server 12 SP4 libgcrypt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libgcrypt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libgcrypt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libgcrypt Released