Upstream information

CVE-2019-13173 at MITRE

Description

fstream before 1.0.12 is vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system, and a file that matches the hardlink, will overwrite the system's file with the contents of the extracted file. The fstream.DirWriter() function is vulnerable.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:N/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact High Low
Availability Impact None Low
SUSE Bugzilla entry: 1140290 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • nodejs4 >= 4.9.1-15.23.1
  • nodejs6 >= 6.17.0-11.27.1
Patchnames:
SUSE-Storage-4-2019-2078
SUSE-Storage-4-2019-2181
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs10 >= 10.16.0-1.9.1
  • nodejs10-devel >= 10.16.0-1.9.1
  • nodejs10-docs >= 10.16.0-1.9.1
  • nodejs4 >= 4.9.1-15.23.1
  • nodejs4-devel >= 4.9.1-15.23.1
  • nodejs4-docs >= 4.9.1-15.23.1
  • nodejs6 >= 6.17.0-11.27.1
  • nodejs6-devel >= 6.17.0-11.27.1
  • nodejs6-docs >= 6.17.0-11.27.1
  • npm10 >= 10.16.0-1.9.1
  • npm4 >= 4.9.1-15.23.1
  • npm6 >= 6.17.0-11.27.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2019-2078
SUSE-SLE-Module-Web-Scripting-12-2019-2099
SUSE-SLE-Module-Web-Scripting-12-2019-2181
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs10 >= 10.16.0-1.9.1
  • nodejs10-devel >= 10.16.0-1.9.1
  • nodejs10-docs >= 10.16.0-1.9.1
  • nodejs8 >= 8.15.1-3.17.1
  • nodejs8-devel >= 8.15.1-3.17.1
  • nodejs8-docs >= 8.15.1-3.17.1
  • npm10 >= 10.16.0-1.9.1
  • npm8 >= 8.15.1-3.17.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-2019-2055
SUSE-SLE-Module-Web-Scripting-15-2019-2081
SUSE Linux Enterprise Module for Web Scripting 15 SP1
  • nodejs10 >= 10.16.0-1.9.1
  • nodejs10-devel >= 10.16.0-1.9.1
  • nodejs10-docs >= 10.16.0-1.9.1
  • nodejs8 >= 8.15.1-3.17.1
  • nodejs8-devel >= 8.15.1-3.17.1
  • nodejs8-docs >= 8.15.1-3.17.1
  • npm10 >= 10.16.0-1.9.1
  • npm8 >= 8.15.1-3.17.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP1-2019-2055
SUSE-SLE-Module-Web-Scripting-15-SP1-2019-2081
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.17.0-11.27.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2181
SUSE OpenStack Cloud Crowbar 8
  • nodejs6 >= 6.17.0-11.27.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2181
SUSE OpenStack Cloud Crowbar 9
  • nodejs6 >= 6.17.0-11.27.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2019-2181
openSUSE Leap 15.0
  • nodejs8 >= 8.15.1-lp150.2.16.1
  • nodejs8-debuginfo >= 8.15.1-lp150.2.16.1
  • nodejs8-debugsource >= 8.15.1-lp150.2.16.1
  • nodejs8-devel >= 8.15.1-lp150.2.16.1
  • nodejs8-docs >= 8.15.1-lp150.2.16.1
  • npm8 >= 8.15.1-lp150.2.16.1
Patchnames:
openSUSE-2019-1907
openSUSE Leap 15.1
  • nodejs10 >= 10.16.0-lp151.2.3.1
  • nodejs10-debuginfo >= 10.16.0-lp151.2.3.1
  • nodejs10-debugsource >= 10.16.0-lp151.2.3.1
  • nodejs10-devel >= 10.16.0-lp151.2.3.1
  • nodejs10-docs >= 10.16.0-lp151.2.3.1
  • nodejs8 >= 8.15.1-lp151.2.3.1
  • nodejs8-debuginfo >= 8.15.1-lp151.2.3.1
  • nodejs8-debugsource >= 8.15.1-lp151.2.3.1
  • nodejs8-devel >= 8.15.1-lp151.2.3.1
  • nodejs8-docs >= 8.15.1-lp151.2.3.1
  • npm10 >= 10.16.0-lp151.2.3.1
  • npm8 >= 8.15.1-lp151.2.3.1
Patchnames:
openSUSE-2019-1846
openSUSE-2019-1907


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs10 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Released
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs10 Released
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs8 Released
SUSE Openstack Cloud 7 nodejs6 Released
SUSE Openstack Cloud 8 nodejs6 Released
SUSE Openstack Cloud 9 nodejs6 Released
SUSE Storage 4 nodejs4 Released
SUSE Storage 4 nodejs6 Released
SUSE Studio Onsite 1.3 nodejs Affected