Upstream information

CVE-2019-13012 at MITRE

Description

The keyfile settings backend in GNOME GLib (aka glib2.0) before 2.60.0 creates directories using g_file_make_directory_with_parents (kfsb->dir, NULL, NULL) and files using g_file_replace_contents (kfsb->file, contents, length, NULL, FALSE, G_FILE_CREATE_REPLACE_DESTINATION, NULL, NULL, NULL). Consequently, it does not properly restrict directory (and file) permissions. Instead, for directories, 0777 permissions are used; for files, default file permissions are used. This is similar to CVE-2019-12450.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 8.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None High
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entries: 1139959 [RESOLVED / FIXED], 1142126 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
HPE-Helion-OpenStack-8-2019-1830
SUSE CaaS Platform 3.0
  • gio-branding-upstream >= 2.48.2-12.15.1
  • glib2 >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
Patchnames:
SUSE-CAASP-3.0-2019-1830
SUSE Enterprise Storage 4
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-Storage-4-2019-1830
SUSE Enterprise Storage 5
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-Storage-5-2019-1830
SUSE Linux Enterprise Build System Kit 12 SP4
  • gio-branding-upstream >= 2.48.2-12.15.1
  • glib2 >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-BSK-12-SP4-2019-1830
SUSE Linux Enterprise Desktop 12 SP4
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libgio-fam >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1830
SUSE Linux Enterprise Module for Basesystem 15
  • glib2 >= 2.54.3-4.18.1
  • glib2-devel >= 2.54.3-4.18.1
  • glib2-lang >= 2.54.3-4.18.1
  • glib2-tools >= 2.54.3-4.18.1
  • libgio-2_0-0 >= 2.54.3-4.18.1
  • libgio-2_0-0-32bit >= 2.54.3-4.18.1
  • libglib-2_0-0 >= 2.54.3-4.18.1
  • libglib-2_0-0-32bit >= 2.54.3-4.18.1
  • libgmodule-2_0-0 >= 2.54.3-4.18.1
  • libgmodule-2_0-0-32bit >= 2.54.3-4.18.1
  • libgobject-2_0-0 >= 2.54.3-4.18.1
  • libgobject-2_0-0-32bit >= 2.54.3-4.18.1
  • libgthread-2_0-0 >= 2.54.3-4.18.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1833
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • glib2 >= 2.54.3-4.18.1
  • glib2-devel >= 2.54.3-4.18.1
  • glib2-lang >= 2.54.3-4.18.1
  • glib2-tools >= 2.54.3-4.18.1
  • libgio-2_0-0 >= 2.54.3-4.18.1
  • libgio-2_0-0-32bit >= 2.54.3-4.18.1
  • libglib-2_0-0 >= 2.54.3-4.18.1
  • libglib-2_0-0-32bit >= 2.54.3-4.18.1
  • libgmodule-2_0-0 >= 2.54.3-4.18.1
  • libgmodule-2_0-0-32bit >= 2.54.3-4.18.1
  • libgobject-2_0-0 >= 2.54.3-4.18.1
  • libgobject-2_0-0-32bit >= 2.54.3-4.18.1
  • libgthread-2_0-0 >= 2.54.3-4.18.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-1833
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • gio-branding-upstream >= 2.54.3-4.18.1
  • glib2 >= 2.54.3-4.18.1
  • glib2-devel-static >= 2.54.3-4.18.1
  • libgio-fam >= 2.54.3-4.18.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1833
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • gio-branding-upstream >= 2.54.3-4.18.1
  • glib2 >= 2.54.3-4.18.1
  • glib2-devel-32bit >= 2.54.3-4.18.1
  • glib2-devel-static >= 2.54.3-4.18.1
  • glib2-tools-32bit >= 2.54.3-4.18.1
  • libgio-fam >= 2.54.3-4.18.1
  • libgio-fam-32bit >= 2.54.3-4.18.1
  • libgthread-2_0-0-32bit >= 2.54.3-4.18.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1833
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • glib2 >= 2.54.3-4.18.1
  • glib2-devel-32bit >= 2.54.3-4.18.1
  • glib2-tools-32bit >= 2.54.3-4.18.1
  • libgthread-2_0-0-32bit >= 2.54.3-4.18.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-1833
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-1830
SUSE Linux Enterprise Server 12 SP1-LTSS
  • glib2 >= 2.38.2-7.12.1
  • glib2-lang >= 2.38.2-7.12.1
  • glib2-tools >= 2.38.2-7.12.1
  • libgio-2_0-0 >= 2.38.2-7.12.1
  • libgio-2_0-0-32bit >= 2.38.2-7.12.1
  • libglib-2_0-0 >= 2.38.2-7.12.1
  • libglib-2_0-0-32bit >= 2.38.2-7.12.1
  • libgmodule-2_0-0 >= 2.38.2-7.12.1
  • libgmodule-2_0-0-32bit >= 2.38.2-7.12.1
  • libgobject-2_0-0 >= 2.38.2-7.12.1
  • libgobject-2_0-0-32bit >= 2.38.2-7.12.1
  • libgthread-2_0-0 >= 2.38.2-7.12.1
  • libgthread-2_0-0-32bit >= 2.38.2-7.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-1824
SUSE Linux Enterprise Server 12 SP2-BCL
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-1830
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-1830
SUSE Linux Enterprise Server 12 SP2-LTSS
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-1830
SUSE Linux Enterprise Server 12 SP3-BCL
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-1830
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-1830
SUSE Linux Enterprise Server 12 SP3-LTSS
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1830
SUSE Linux Enterprise Server 12 SP4
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1830
SUSE Linux Enterprise Server 12-LTSS
  • glib2 >= 2.38.2-7.12.1
  • glib2-lang >= 2.38.2-7.12.1
  • glib2-tools >= 2.38.2-7.12.1
  • libgio-2_0-0 >= 2.38.2-7.12.1
  • libgio-2_0-0-32bit >= 2.38.2-7.12.1
  • libglib-2_0-0 >= 2.38.2-7.12.1
  • libglib-2_0-0-32bit >= 2.38.2-7.12.1
  • libgmodule-2_0-0 >= 2.38.2-7.12.1
  • libgmodule-2_0-0-32bit >= 2.38.2-7.12.1
  • libgobject-2_0-0 >= 2.38.2-7.12.1
  • libgobject-2_0-0-32bit >= 2.38.2-7.12.1
  • libgthread-2_0-0 >= 2.38.2-7.12.1
  • libgthread-2_0-0-32bit >= 2.38.2-7.12.1
Patchnames:
SUSE-SLE-SERVER-12-2019-1824
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • glib2 >= 2.38.2-7.12.1
  • glib2-lang >= 2.38.2-7.12.1
  • glib2-tools >= 2.38.2-7.12.1
  • libgio-2_0-0 >= 2.38.2-7.12.1
  • libgio-2_0-0-32bit >= 2.38.2-7.12.1
  • libglib-2_0-0 >= 2.38.2-7.12.1
  • libglib-2_0-0-32bit >= 2.38.2-7.12.1
  • libgmodule-2_0-0 >= 2.38.2-7.12.1
  • libgmodule-2_0-0-32bit >= 2.38.2-7.12.1
  • libgobject-2_0-0 >= 2.38.2-7.12.1
  • libgobject-2_0-0-32bit >= 2.38.2-7.12.1
  • libgthread-2_0-0 >= 2.38.2-7.12.1
  • libgthread-2_0-0-32bit >= 2.38.2-7.12.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1824
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • glib2 >= 2.38.2-7.12.1
  • glib2-lang >= 2.38.2-7.12.1
  • glib2-tools >= 2.38.2-7.12.1
  • libgio-2_0-0 >= 2.38.2-7.12.1
  • libgio-2_0-0-32bit >= 2.38.2-7.12.1
  • libglib-2_0-0 >= 2.38.2-7.12.1
  • libglib-2_0-0-32bit >= 2.38.2-7.12.1
  • libgmodule-2_0-0 >= 2.38.2-7.12.1
  • libgmodule-2_0-0-32bit >= 2.38.2-7.12.1
  • libgobject-2_0-0 >= 2.38.2-7.12.1
  • libgobject-2_0-0-32bit >= 2.38.2-7.12.1
  • libgthread-2_0-0 >= 2.38.2-7.12.1
  • libgthread-2_0-0-32bit >= 2.38.2-7.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-1824
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1830
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • glib2 >= 2.38.2-7.12.1
  • glib2-lang >= 2.38.2-7.12.1
  • glib2-tools >= 2.38.2-7.12.1
  • libgio-2_0-0 >= 2.38.2-7.12.1
  • libgio-2_0-0-32bit >= 2.38.2-7.12.1
  • libglib-2_0-0 >= 2.38.2-7.12.1
  • libglib-2_0-0-32bit >= 2.38.2-7.12.1
  • libgmodule-2_0-0 >= 2.38.2-7.12.1
  • libgmodule-2_0-0-32bit >= 2.38.2-7.12.1
  • libgobject-2_0-0 >= 2.38.2-7.12.1
  • libgobject-2_0-0-32bit >= 2.38.2-7.12.1
  • libgthread-2_0-0 >= 2.38.2-7.12.1
  • libgthread-2_0-0-32bit >= 2.38.2-7.12.1
Patchnames:
SUSE-SLE-SERVER-12-2019-1824
SUSE Linux Enterprise Software Development Kit 12 SP4
  • glib2 >= 2.48.2-12.15.1
  • glib2-devel >= 2.48.2-12.15.1
  • glib2-devel-static >= 2.48.2-12.15.1
  • libgio-fam >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1830
SUSE Linux Enterprise Workstation Extension 12 SP4
  • glib2 >= 2.48.2-12.15.1
  • libgio-fam >= 2.48.2-12.15.1
Patchnames:
SUSE-SLE-WE-12-SP4-2019-1830
SUSE OpenStack Cloud 7
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-1830
SUSE OpenStack Cloud 8
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-1830
SUSE OpenStack Cloud Crowbar 8
  • glib2 >= 2.48.2-12.15.1
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-1830
openSUSE Leap 15.0
  • gio-branding-upstream >= 2.54.3-lp150.3.13.1
  • glib2 >= 2.54.3-lp150.3.13.1
  • glib2-debugsource >= 2.54.3-lp150.3.13.1
  • glib2-devel >= 2.54.3-lp150.3.13.1
  • glib2-devel-32bit >= 2.54.3-lp150.3.13.1
  • glib2-devel-32bit-debuginfo >= 2.54.3-lp150.3.13.1
  • glib2-devel-debuginfo >= 2.54.3-lp150.3.13.1
  • glib2-devel-static >= 2.54.3-lp150.3.13.1
  • glib2-lang >= 2.54.3-lp150.3.13.1
  • glib2-tools >= 2.54.3-lp150.3.13.1
  • glib2-tools-32bit >= 2.54.3-lp150.3.13.1
  • glib2-tools-32bit-debuginfo >= 2.54.3-lp150.3.13.1
  • glib2-tools-debuginfo >= 2.54.3-lp150.3.13.1
  • libgio-2_0-0 >= 2.54.3-lp150.3.13.1
  • libgio-2_0-0-32bit >= 2.54.3-lp150.3.13.1
  • libgio-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.13.1
  • libgio-2_0-0-debuginfo >= 2.54.3-lp150.3.13.1
  • libgio-fam >= 2.54.3-lp150.3.13.1
  • libgio-fam-32bit >= 2.54.3-lp150.3.13.1
  • libgio-fam-32bit-debuginfo >= 2.54.3-lp150.3.13.1
  • libgio-fam-debuginfo >= 2.54.3-lp150.3.13.1
  • libglib-2_0-0 >= 2.54.3-lp150.3.13.1
  • libglib-2_0-0-32bit >= 2.54.3-lp150.3.13.1
  • libglib-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.13.1
  • libglib-2_0-0-debuginfo >= 2.54.3-lp150.3.13.1
  • libgmodule-2_0-0 >= 2.54.3-lp150.3.13.1
  • libgmodule-2_0-0-32bit >= 2.54.3-lp150.3.13.1
  • libgmodule-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.13.1
  • libgmodule-2_0-0-debuginfo >= 2.54.3-lp150.3.13.1
  • libgobject-2_0-0 >= 2.54.3-lp150.3.13.1
  • libgobject-2_0-0-32bit >= 2.54.3-lp150.3.13.1
  • libgobject-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.13.1
  • libgobject-2_0-0-debuginfo >= 2.54.3-lp150.3.13.1
  • libgthread-2_0-0 >= 2.54.3-lp150.3.13.1
  • libgthread-2_0-0-32bit >= 2.54.3-lp150.3.13.1
  • libgthread-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.13.1
  • libgthread-2_0-0-debuginfo >= 2.54.3-lp150.3.13.1
Patchnames:
openSUSE-2019-1749


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 glib2 Affected
CaaS Platform 2.0 glib2 Affected
CaaS Platform 3.0 glib2 Released
OpenStack Cloud Magnum Orchestration 7.0 glib2 Affected
SUSE Linux Enterprise BSK 12 SP3 glib2 Affected
SUSE Linux Enterprise BSK 12 SP4 glib2 Released
SUSE Linux Enterprise Desktop 12 SP3 glib2 Affected
SUSE Linux Enterprise Desktop 12 SP4 glib2 Released
SUSE Linux Enterprise High Performance Computing 12 glib2 Released
SUSE Linux Enterprise Module for Basesystem 15 GA glib2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 glib2 Released
SUSE Linux Enterprise SDK 12 SP3 glib2 Affected
SUSE Linux Enterprise SDK 12 SP4 glib2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS glib2 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS glib2 Not affected
SUSE Linux Enterprise Server 12 GA LTSS glib2 Released
SUSE Linux Enterprise Server 12 SP1 LTSS glib2 Released
SUSE Linux Enterprise Server 12 SP2 LTSS glib2 Released
SUSE Linux Enterprise Server 12 SP3 glib2 Affected
SUSE Linux Enterprise Server 12 SP4 glib2 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 glib2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glib2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 glib2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glib2 Released
SUSE Linux Enterprise Workstation Extension 12 SP3 glib2 Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 glib2 Released