Upstream information

CVE-2019-12838 at MITRE

Description

SchedMD Slurm 17.11.x, 18.08.0 through 18.08.7, and 19.05.0 allows SQL Injection.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 6.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entry: 1140709 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15
  • perl-Switch >= 2.17-3.2.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2019-2229
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • perl-Switch >= 2.17-3.2.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2019-2229
SUSE Linux Enterprise Module for High Performance Computing 15 SP1
  • libpmi0 >= 18.08.8-3.4.1
  • libslurm33 >= 18.08.8-3.4.1
  • perl-Switch >= 2.17-3.2.1
  • perl-slurm >= 18.08.8-3.4.1
  • slurm >= 18.08.8-3.4.1
  • slurm-auth-none >= 18.08.8-3.4.1
  • slurm-config >= 18.08.8-3.4.1
  • slurm-config-man >= 18.08.8-3.4.1
  • slurm-devel >= 18.08.8-3.4.1
  • slurm-doc >= 18.08.8-3.4.1
  • slurm-lua >= 18.08.8-3.4.1
  • slurm-munge >= 18.08.8-3.4.1
  • slurm-node >= 18.08.8-3.4.1
  • slurm-pam_slurm >= 18.08.8-3.4.1
  • slurm-plugins >= 18.08.8-3.4.1
  • slurm-slurmdbd >= 18.08.8-3.4.1
  • slurm-sql >= 18.08.8-3.4.1
  • slurm-sview >= 18.08.8-3.4.1
  • slurm-torque >= 18.08.8-3.4.1
Patchnames:
SUSE-SLE-Module-HPC-15-SP1-2019-2229
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libpmi0 >= 18.08.8-3.4.1
  • libslurm33 >= 18.08.8-3.4.1
  • perl-slurm >= 18.08.8-3.4.1
  • slurm >= 18.08.8-3.4.1
  • slurm-auth-none >= 18.08.8-3.4.1
  • slurm-config >= 18.08.8-3.4.1
  • slurm-config-man >= 18.08.8-3.4.1
  • slurm-devel >= 18.08.8-3.4.1
  • slurm-doc >= 18.08.8-3.4.1
  • slurm-lua >= 18.08.8-3.4.1
  • slurm-munge >= 18.08.8-3.4.1
  • slurm-node >= 18.08.8-3.4.1
  • slurm-openlava >= 18.08.8-3.4.1
  • slurm-pam_slurm >= 18.08.8-3.4.1
  • slurm-plugins >= 18.08.8-3.4.1
  • slurm-seff >= 18.08.8-3.4.1
  • slurm-sjstat >= 18.08.8-3.4.1
  • slurm-slurmdbd >= 18.08.8-3.4.1
  • slurm-sql >= 18.08.8-3.4.1
  • slurm-sview >= 18.08.8-3.4.1
  • slurm-torque >= 18.08.8-3.4.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2229
openSUSE Leap 15.1
  • libpmi0 >= 18.08.8-lp151.2.3.1
  • libpmi0-debuginfo >= 18.08.8-lp151.2.3.1
  • libslurm33 >= 18.08.8-lp151.2.3.1
  • libslurm33-debuginfo >= 18.08.8-lp151.2.3.1
  • perl-slurm >= 18.08.8-lp151.2.3.1
  • perl-slurm-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm >= 18.08.8-lp151.2.3.1
  • slurm-auth-none >= 18.08.8-lp151.2.3.1
  • slurm-auth-none-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-config >= 18.08.8-lp151.2.3.1
  • slurm-config-man >= 18.08.8-lp151.2.3.1
  • slurm-cray >= 18.08.8-lp151.2.3.1
  • slurm-cray-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-debugsource >= 18.08.8-lp151.2.3.1
  • slurm-devel >= 18.08.8-lp151.2.3.1
  • slurm-doc >= 18.08.8-lp151.2.3.1
  • slurm-hdf5 >= 18.08.8-lp151.2.3.1
  • slurm-hdf5-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-lua >= 18.08.8-lp151.2.3.1
  • slurm-lua-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-munge >= 18.08.8-lp151.2.3.1
  • slurm-munge-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-node >= 18.08.8-lp151.2.3.1
  • slurm-node-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-openlava >= 18.08.8-lp151.2.3.1
  • slurm-pam_slurm >= 18.08.8-lp151.2.3.1
  • slurm-pam_slurm-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-plugins >= 18.08.8-lp151.2.3.1
  • slurm-plugins-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-seff >= 18.08.8-lp151.2.3.1
  • slurm-sjstat >= 18.08.8-lp151.2.3.1
  • slurm-slurmdbd >= 18.08.8-lp151.2.3.1
  • slurm-slurmdbd-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-sql >= 18.08.8-lp151.2.3.1
  • slurm-sql-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-sview >= 18.08.8-lp151.2.3.1
  • slurm-sview-debuginfo >= 18.08.8-lp151.2.3.1
  • slurm-torque >= 18.08.8-lp151.2.3.1
  • slurm-torque-debuginfo >= 18.08.8-lp151.2.3.1
Patchnames:
openSUSE-2019-2052

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for High Performance Computing 12
  • libpmi0 >= 17.02.11-6.33.1
  • libpmi0-debuginfo >= 17.02.11-6.33.1
  • libslurm31 >= 17.02.11-6.33.1
  • libslurm31-debuginfo >= 17.02.11-6.33.1
  • perl-slurm >= 17.02.11-6.33.1
  • perl-slurm-debuginfo >= 17.02.11-6.33.1
  • slurm >= 17.02.11-6.33.1
  • slurm-auth-none >= 17.02.11-6.33.1
  • slurm-auth-none-debuginfo >= 17.02.11-6.33.1
  • slurm-config >= 17.02.11-6.33.1
  • slurm-debuginfo >= 17.02.11-6.33.1
  • slurm-debugsource >= 17.02.11-6.33.1
  • slurm-devel >= 17.02.11-6.33.1
  • slurm-doc >= 17.02.11-6.33.1
  • slurm-lua >= 17.02.11-6.33.1
  • slurm-lua-debuginfo >= 17.02.11-6.33.1
  • slurm-munge >= 17.02.11-6.33.1
  • slurm-munge-debuginfo >= 17.02.11-6.33.1
  • slurm-pam_slurm >= 17.02.11-6.33.1
  • slurm-pam_slurm-debuginfo >= 17.02.11-6.33.1
  • slurm-plugins >= 17.02.11-6.33.1
  • slurm-plugins-debuginfo >= 17.02.11-6.33.1
  • slurm-sched-wiki >= 17.02.11-6.33.1
  • slurm-slurmdb-direct >= 17.02.11-6.33.1
  • slurm-slurmdbd >= 17.02.11-6.33.1
  • slurm-slurmdbd-debuginfo >= 17.02.11-6.33.1
  • slurm-sql >= 17.02.11-6.33.1
  • slurm-sql-debuginfo >= 17.02.11-6.33.1
  • slurm-torque >= 17.02.11-6.33.1
  • slurm-torque-debuginfo >= 17.02.11-6.33.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for High Performance Computing 12 slurm In progress
SUSE Linux Enterprise Module for High Performance Computing 15 slurm In progress