Upstream information

CVE-2019-12450 at MITRE

Description

file_copy_fallback in gio/gfile.c in GNOME GLib 2.15.0 through 2.61.1 does not properly restrict file permissions while a copy operation is in progress. Instead, default permissions are used.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.1
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1137001 [RESOLVED / FIXED], 1139959 [RESOLVED / FIXED], 1142126 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/caasp-dex:2.16.0
Container caasp/v4/cilium-init:1.5.3
Container caasp/v4/cilium-operator:1.6.6
Container caasp/v4/cilium:1.6.6
Container caasp/v4/gangway:3.1.0
Container suse/sle15:15.0
Container suse/sle15:15.1
Image caasp-389-ds-image
Image caasp-busybox-image
Image caasp-caasp-dex-image
Image caasp-cert-exporter-image
Image caasp-cilium-etcd-operator-image
Image caasp-cilium-image
Image caasp-cilium-init-image
Image caasp-cilium-operator-image
Image caasp-cloud-provider-openstack-image
Image caasp-configmap-reload-image
Image caasp-coredns-image
Image caasp-curl-image
Image caasp-etcd-image
Image caasp-gangway-image
Image caasp-grafana-image
Image caasp-helm-tiller-image
Image caasp-kube-state-metrics-image
Image caasp-kubernetes-client-image
Image caasp-kured-image
Image caasp-metrics-server-image
Image caasp-prometheus-alertmanager-image
Image caasp-prometheus-node-exporter-image
Image caasp-prometheus-pushgateway-image
Image caasp-prometheus-server-image
Image caasp-rsyslog-image
Image caasp-test-update-image
Image caasp-velero-image
Image caasp-velero-plugin-for-aws-image
Image caasp-velero-plugin-for-gcp-image
Image caasp-velero-plugin-for-microsoft-azure-image
Image caasp-velero-restic-restore-helper-image
  • libglib-2_0-0 >= 2.54.3-4.15.1
Container caasp/v4/hyperkube:v1.17.4
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image caasp-hyperkube-image
  • libglib-2_0-0 >= 2.54.3-4.15.1
  • libgmodule-2_0-0 >= 2.54.3-4.15.1
Container caasp/v4/k8s-sidecar:0.1.75
Image caasp-k8s-sidecar-image
  • glib2-tools >= 2.54.3-4.15.1
  • libgio-2_0-0 >= 2.54.3-4.15.1
  • libglib-2_0-0 >= 2.54.3-4.15.1
  • libgmodule-2_0-0 >= 2.54.3-4.15.1
  • libgobject-2_0-0 >= 2.54.3-4.15.1
Openstack Cloud Magnum Orchestration 7
  • glib2 >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-1722
SUSE CaaS Platform 3.0
  • gio-branding-upstream >= 2.48.2-12.12.2
  • glib2 >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
Patchnames:
SUSE-CAASP-3.0-2019-1722
SUSE CaaS Platform ALL
  • gio-branding-upstream >= 2.48.2-12.12.2
  • glib2 >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
Patchnames:
SUSE-CAASP-ALL-2019-1722
SUSE Enterprise Storage 4
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-Storage-4-2019-1722
SUSE Linux Enterprise Build System Kit 12 SP3
  • gio-branding-upstream >= 2.48.2-12.12.2
  • glib2 >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-BSK-12-SP3-2019-1722
SUSE Linux Enterprise Build System Kit 12 SP4
  • gio-branding-upstream >= 2.48.2-12.12.2
  • glib2 >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-BSK-12-SP4-2019-1722
SUSE Linux Enterprise Desktop 12 SP3
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libgio-fam >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-1722
SUSE Linux Enterprise Desktop 12 SP4
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libgio-fam >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1722
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • glib2-lang >= 2.48.2-12.15.1
  • glib2-tools >= 2.48.2-12.15.1
  • libgio-2_0-0 >= 2.48.2-12.15.1
  • libgio-2_0-0-32bit >= 2.48.2-12.15.1
  • libglib-2_0-0 >= 2.48.2-12.15.1
  • libglib-2_0-0-32bit >= 2.48.2-12.15.1
  • libgmodule-2_0-0 >= 2.48.2-12.15.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.15.1
  • libgobject-2_0-0 >= 2.48.2-12.15.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.15.1
  • libgthread-2_0-0 >= 2.48.2-12.15.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.15.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • glib2 >= 2.54.3-4.15.1
  • glib2-devel >= 2.54.3-4.15.1
  • glib2-lang >= 2.54.3-4.15.1
  • glib2-tools >= 2.54.3-4.15.1
  • libgio-2_0-0 >= 2.54.3-4.15.1
  • libgio-2_0-0-32bit >= 2.54.3-4.15.1
  • libglib-2_0-0 >= 2.54.3-4.15.1
  • libglib-2_0-0-32bit >= 2.54.3-4.15.1
  • libgmodule-2_0-0 >= 2.54.3-4.15.1
  • libgmodule-2_0-0-32bit >= 2.54.3-4.15.1
  • libgobject-2_0-0 >= 2.54.3-4.15.1
  • libgobject-2_0-0-32bit >= 2.54.3-4.15.1
  • libgthread-2_0-0 >= 2.54.3-4.15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-1594
SUSE Linux Enterprise Module for Basesystem 15
  • glib2 >= 2.54.3-4.15.1
  • glib2-devel >= 2.54.3-4.15.1
  • glib2-lang >= 2.54.3-4.15.1
  • glib2-tools >= 2.54.3-4.15.1
  • libgio-2_0-0 >= 2.54.3-4.15.1
  • libgio-2_0-0-32bit >= 2.54.3-4.15.1
  • libglib-2_0-0 >= 2.54.3-4.15.1
  • libglib-2_0-0-32bit >= 2.54.3-4.15.1
  • libgmodule-2_0-0 >= 2.54.3-4.15.1
  • libgmodule-2_0-0-32bit >= 2.54.3-4.15.1
  • libgobject-2_0-0 >= 2.54.3-4.15.1
  • libgobject-2_0-0-32bit >= 2.54.3-4.15.1
  • libgthread-2_0-0 >= 2.54.3-4.15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1594
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • gio-branding-upstream >= 2.54.3-4.15.1
  • glib2 >= 2.54.3-4.15.1
  • glib2-devel-32bit >= 2.54.3-4.15.1
  • glib2-devel-static >= 2.54.3-4.15.1
  • glib2-tools-32bit >= 2.54.3-4.15.1
  • libgio-fam >= 2.54.3-4.15.1
  • libgio-fam-32bit >= 2.54.3-4.15.1
  • libgthread-2_0-0-32bit >= 2.54.3-4.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1594
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • gio-branding-upstream >= 2.54.3-4.15.1
  • glib2 >= 2.54.3-4.15.1
  • glib2-devel-static >= 2.54.3-4.15.1
  • libgio-fam >= 2.54.3-4.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1594
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • glib2 >= 2.54.3-4.15.1
  • glib2-devel-32bit >= 2.54.3-4.15.1
  • glib2-tools-32bit >= 2.54.3-4.15.1
  • libgthread-2_0-0-32bit >= 2.54.3-4.15.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-1594
SUSE Linux Enterprise Point of Sale 11 SP3
  • glib2 >= 2.22.5-0.8.39.1
  • glib2-doc >= 2.22.5-0.8.39.1
  • glib2-lang >= 2.22.5-0.8.39.1
  • libgio-2_0-0 >= 2.22.5-0.8.39.1
  • libglib-2_0-0 >= 2.22.5-0.8.39.1
  • libgmodule-2_0-0 >= 2.22.5-0.8.39.1
  • libgobject-2_0-0 >= 2.22.5-0.8.39.1
  • libgthread-2_0-0 >= 2.22.5-0.8.39.1
Patchnames:
sleposp3-glib2-14102
SUSE Linux Enterprise Server 11 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • glib2 >= 2.22.5-0.8.39.1
  • glib2-doc >= 2.22.5-0.8.39.1
  • glib2-lang >= 2.22.5-0.8.39.1
  • libgio-2_0-0 >= 2.22.5-0.8.39.1
  • libgio-2_0-0-32bit >= 2.22.5-0.8.39.1
  • libglib-2_0-0 >= 2.22.5-0.8.39.1
  • libglib-2_0-0-32bit >= 2.22.5-0.8.39.1
  • libgmodule-2_0-0 >= 2.22.5-0.8.39.1
  • libgmodule-2_0-0-32bit >= 2.22.5-0.8.39.1
  • libgobject-2_0-0 >= 2.22.5-0.8.39.1
  • libgobject-2_0-0-32bit >= 2.22.5-0.8.39.1
  • libgthread-2_0-0 >= 2.22.5-0.8.39.1
  • libgthread-2_0-0-32bit >= 2.22.5-0.8.39.1
Patchnames:
slessp4-glib2-14102
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • glib2 >= 2.38.2-7.9.2
  • glib2-lang >= 2.38.2-7.9.2
  • glib2-tools >= 2.38.2-7.9.2
  • libgio-2_0-0 >= 2.38.2-7.9.2
  • libgio-2_0-0-32bit >= 2.38.2-7.9.2
  • libglib-2_0-0 >= 2.38.2-7.9.2
  • libglib-2_0-0-32bit >= 2.38.2-7.9.2
  • libgmodule-2_0-0 >= 2.38.2-7.9.2
  • libgmodule-2_0-0-32bit >= 2.38.2-7.9.2
  • libgobject-2_0-0 >= 2.38.2-7.9.2
  • libgobject-2_0-0-32bit >= 2.38.2-7.9.2
  • libgthread-2_0-0 >= 2.38.2-7.9.2
  • libgthread-2_0-0-32bit >= 2.38.2-7.9.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-1596
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-1722
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-1722
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1722
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1722
SUSE Linux Enterprise Server 12-LTSS
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • glib2 >= 2.38.2-7.9.2
  • glib2-lang >= 2.38.2-7.9.2
  • glib2-tools >= 2.38.2-7.9.2
  • libgio-2_0-0 >= 2.38.2-7.9.2
  • libgio-2_0-0-32bit >= 2.38.2-7.9.2
  • libglib-2_0-0 >= 2.38.2-7.9.2
  • libglib-2_0-0-32bit >= 2.38.2-7.9.2
  • libgmodule-2_0-0 >= 2.38.2-7.9.2
  • libgmodule-2_0-0-32bit >= 2.38.2-7.9.2
  • libgobject-2_0-0 >= 2.38.2-7.9.2
  • libgobject-2_0-0-32bit >= 2.38.2-7.9.2
  • libgthread-2_0-0 >= 2.38.2-7.9.2
  • libgthread-2_0-0-32bit >= 2.38.2-7.9.2
Patchnames:
SUSE-SLE-SERVER-12-2019-1596
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-1722
SUSE Linux Enterprise Software Development Kit 12 SP3
  • glib2 >= 2.48.2-12.12.2
  • glib2-devel >= 2.48.2-12.12.2
  • glib2-devel-static >= 2.48.2-12.12.2
  • libgio-fam >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1722
SUSE Linux Enterprise Software Development Kit 12 SP4
  • glib2 >= 2.48.2-12.12.2
  • glib2-devel >= 2.48.2-12.12.2
  • glib2-devel-static >= 2.48.2-12.12.2
  • libgio-fam >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1722
SUSE Linux Enterprise Software Development Kit 12 SP5
  • glib2-devel >= 2.48.2-12.15.1
  • glib2-devel-static >= 2.48.2-12.15.1
  • libgio-fam >= 2.48.2-12.15.1
SUSE Linux Enterprise Workstation Extension 12 SP3
  • glib2 >= 2.48.2-12.12.2
  • libgio-fam >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-WE-12-SP3-2019-1722
SUSE Linux Enterprise Workstation Extension 12 SP4
  • glib2 >= 2.48.2-12.12.2
  • libgio-fam >= 2.48.2-12.12.2
Patchnames:
SUSE-SLE-WE-12-SP4-2019-1722
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libgio-fam >= 2.48.2-12.15.1
SUSE OpenStack Cloud 7
  • glib2 >= 2.48.2-12.12.2
  • glib2-lang >= 2.48.2-12.12.2
  • glib2-tools >= 2.48.2-12.12.2
  • libgio-2_0-0 >= 2.48.2-12.12.2
  • libgio-2_0-0-32bit >= 2.48.2-12.12.2
  • libglib-2_0-0 >= 2.48.2-12.12.2
  • libglib-2_0-0-32bit >= 2.48.2-12.12.2
  • libgmodule-2_0-0 >= 2.48.2-12.12.2
  • libgmodule-2_0-0-32bit >= 2.48.2-12.12.2
  • libgobject-2_0-0 >= 2.48.2-12.12.2
  • libgobject-2_0-0-32bit >= 2.48.2-12.12.2
  • libgthread-2_0-0 >= 2.48.2-12.12.2
  • libgthread-2_0-0-32bit >= 2.48.2-12.12.2
Patchnames:
SUSE-OpenStack-Cloud-7-2019-1722
openSUSE Leap 15.0
  • gio-branding-upstream >= 2.54.3-lp150.3.10.1
  • glib2 >= 2.54.3-lp150.3.10.1
  • glib2-debugsource >= 2.54.3-lp150.3.10.1
  • glib2-devel >= 2.54.3-lp150.3.10.1
  • glib2-devel-32bit >= 2.54.3-lp150.3.10.1
  • glib2-devel-32bit-debuginfo >= 2.54.3-lp150.3.10.1
  • glib2-devel-debuginfo >= 2.54.3-lp150.3.10.1
  • glib2-devel-static >= 2.54.3-lp150.3.10.1
  • glib2-lang >= 2.54.3-lp150.3.10.1
  • glib2-tools >= 2.54.3-lp150.3.10.1
  • glib2-tools-32bit >= 2.54.3-lp150.3.10.1
  • glib2-tools-32bit-debuginfo >= 2.54.3-lp150.3.10.1
  • glib2-tools-debuginfo >= 2.54.3-lp150.3.10.1
  • libgio-2_0-0 >= 2.54.3-lp150.3.10.1
  • libgio-2_0-0-32bit >= 2.54.3-lp150.3.10.1
  • libgio-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.10.1
  • libgio-2_0-0-debuginfo >= 2.54.3-lp150.3.10.1
  • libgio-fam >= 2.54.3-lp150.3.10.1
  • libgio-fam-32bit >= 2.54.3-lp150.3.10.1
  • libgio-fam-32bit-debuginfo >= 2.54.3-lp150.3.10.1
  • libgio-fam-debuginfo >= 2.54.3-lp150.3.10.1
  • libglib-2_0-0 >= 2.54.3-lp150.3.10.1
  • libglib-2_0-0-32bit >= 2.54.3-lp150.3.10.1
  • libglib-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.10.1
  • libglib-2_0-0-debuginfo >= 2.54.3-lp150.3.10.1
  • libgmodule-2_0-0 >= 2.54.3-lp150.3.10.1
  • libgmodule-2_0-0-32bit >= 2.54.3-lp150.3.10.1
  • libgmodule-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.10.1
  • libgmodule-2_0-0-debuginfo >= 2.54.3-lp150.3.10.1
  • libgobject-2_0-0 >= 2.54.3-lp150.3.10.1
  • libgobject-2_0-0-32bit >= 2.54.3-lp150.3.10.1
  • libgobject-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.10.1
  • libgobject-2_0-0-debuginfo >= 2.54.3-lp150.3.10.1
  • libgthread-2_0-0 >= 2.54.3-lp150.3.10.1
  • libgthread-2_0-0-32bit >= 2.54.3-lp150.3.10.1
  • libgthread-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.10.1
  • libgthread-2_0-0-debuginfo >= 2.54.3-lp150.3.10.1
Patchnames:
openSUSE-2019-1650


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration glib2 Released
SLES for SAP Applications glib2 Affected
SUSE CaaS Platform 3.0 glib2 Released
SUSE Container as a Service Platform 1.0 glib2 Released
SUSE Container as a Service Platform 2.0 glib2 Released
SUSE Linux Enterprise 15 Module for Basesystem glib2 Released
SUSE Linux Enterprise 15-SP1 Module for Basesystem glib2 Released
SUSE Linux Enterprise Desktop 12 SP3 glib2 Released
SUSE Linux Enterprise Desktop 12 SP4 glib2 Released
SUSE Linux Enterprise High Performance Computing 12 SP4 glib2 Released
SUSE Linux Enterprise Server 11 SP1 glib2 Released
SUSE Linux Enterprise Server 11 SP3 glib2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS glib2 Affected
SUSE Linux Enterprise Server 11 SP4 LTSS glib2 Released
SUSE Linux Enterprise Server 12 LTSS glib2 Released
SUSE Linux Enterprise Server 12 SP1 LTSS glib2 Released
SUSE Linux Enterprise Server 12 SP2 LTSS glib2 Released
SUSE Linux Enterprise Server 12 SP3 glib2 Released
SUSE Linux Enterprise Server 12 SP4 glib2 Released
SUSE Linux Enterprise Server for SAP Applications 12 glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glib2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glib2 Released
SUSE Linux Enterprise Software Bootstrap Kit 12 glib2 Released
SUSE Linux Enterprise Software Development Kit 12 SP3 glib2 Released
SUSE Linux Enterprise Software Development Kit 12 SP4 glib2 Released
SUSE Linux Enterprise Workstation Extension 12 glib2 Released