Upstream information

CVE-2019-11460 at MITRE

Description

An issue was discovered in GNOME gnome-desktop 3.26, 3.28, and 3.30 prior to 3.30.2.2, and 3.32 prior to 3.32.1.1. A compromised thumbnailer may escape the bubblewrap sandbox used to confine thumbnailers by using the TIOCSTI ioctl to push characters into the input buffer of the thumbnailer's controlling terminal, allowing an attacker to escape the sandbox if the thumbnailer has a controlling terminal. This is due to improper filtering of the TIOCSTI ioctl on 64-bit systems, similar to CVE-2019-10063.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9 4.8
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
Access Vector Network Local
Access Complexity High Low
Privileges Required None Low
User Interaction None Required
Scope Changed Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1133043 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • flatpak >= 0.10.4-4.10.1
  • flatpak-devel >= 0.10.4-4.10.1
  • libflatpak0 >= 0.10.4-4.10.1
  • typelib-1_0-Flatpak-1_0 >= 0.10.4-4.10.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-2185
openSUSE Leap 15.0
  • flatpak >= 0.10.4-lp150.8.1
  • flatpak-debuginfo >= 0.10.4-lp150.8.1
  • flatpak-debugsource >= 0.10.4-lp150.8.1
  • flatpak-devel >= 0.10.4-lp150.8.1
  • libflatpak0 >= 0.10.4-lp150.8.1
  • libflatpak0-debuginfo >= 0.10.4-lp150.8.1
  • typelib-1_0-Flatpak-1_0 >= 0.10.4-lp150.8.1
Patchnames:
openSUSE-2019-2038


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 gnome-desktop Not affected
SUSE Linux Enterprise Desktop 12 SP4 gnome-desktop Not affected
SUSE Linux Enterprise High Performance Computing 12 gnome-desktop Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 GA gnome-desktop Affected
SUSE Linux Enterprise SDK 12 SP3 gnome-desktop Not affected
SUSE Linux Enterprise SDK 12 SP4 gnome-desktop Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS gnome-desktop Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS gnome-desktop Not affected
SUSE Linux Enterprise Server 12 GA LTSS gnome-desktop Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS gnome-desktop Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS gnome-desktop Not affected
SUSE Linux Enterprise Server 12 SP3 gnome-desktop Not affected
SUSE Linux Enterprise Server 12 SP4 gnome-desktop Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 gnome-desktop Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA gnome-desktop Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gnome-desktop Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gnome-desktop Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gnome-desktop Not affected