Upstream information

CVE-2019-11324 at MITRE

Description

The urllib3 library before 1.24.2 for Python mishandles certain cases where the desired set of CA certificates is different from the OS store of CA certificates, which results in SSL connections succeeding in situations where a verification failure is the correct outcome. This is related to use of the ssl_context, ca_certs, or ca_certs_dir argument.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 4
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact High None
Availability Impact None None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entry: 1132900 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • python-urllib3 >= 1.22-5.6.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2300
SUSE CaaS Platform 3.0
  • python-urllib3 >= 1.22-3.14.1
Patchnames:
SUSE-CAASP-3.0-2019-2370
SUSE Enterprise Storage 4
  • python-urllib3 >= 1.22-3.14.1
Patchnames:
SUSE-Storage-4-2019-2370
SUSE Enterprise Storage 5
  • python-urllib3 >= 1.22-3.14.1
Patchnames:
SUSE-Storage-5-2019-2370
SUSE Linux Enterprise Module for Basesystem 15
  • python-urllib3 >= 1.22-6.4.1
  • python2-urllib3 >= 1.22-6.4.1
  • python3-urllib3 >= 1.22-6.4.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2331
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • python-urllib3 >= 1.24-9.4.1
  • python3-urllib3 >= 1.24-9.4.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2332
SUSE Linux Enterprise Module for Public Cloud 12
  • python-urllib3 >= 1.22-3.14.1
  • python3-urllib3 >= 1.22-3.14.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2019-2370
SUSE Linux Enterprise Module for Python2 packages 15 SP1
  • python-urllib3 >= 1.24-9.4.1
  • python2-urllib3 >= 1.24-9.4.1
Patchnames:
SUSE-SLE-Module-Python2-15-SP1-2019-2332
SUSE Manager Server 3.2
  • python-urllib3 >= 1.22-3.14.1
Patchnames:
SUSE-SUSE-Manager-Server-3.2-2019-2370
SUSE OpenStack Cloud 8
  • python-urllib3 >= 1.22-5.6.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2300
SUSE OpenStack Cloud 9
  • ardana-ansible >= 9.0+git.1566374020.301191f-3.7.2
  • ardana-barbican >= 9.0+git.1566251498.be02ca4-3.7.2
  • ardana-cinder >= 9.0+git.1565678764.c3a9b9f-3.7.2
  • ardana-cluster >= 9.0+git.1559333871.40508f7-3.7.2
  • ardana-cobbler >= 9.0+git.1566336494.93967dd-3.7.2
  • ardana-db >= 9.0+git.1564409964.b7e4fc3-3.7.2
  • ardana-designate >= 9.0+git.1565680593.df7a432-3.7.2
  • ardana-extensions-nsx >= 9.0+git.1566213657.69862ab-8.1
  • ardana-glance >= 9.0+git.1566375806.f0b2333-3.7.2
  • ardana-heat >= 9.0+git.1565721273.f44b8d7-3.7.2
  • ardana-horizon >= 9.0+git.1565891518.2a545a1-3.7.2
  • ardana-input-model >= 9.0+git.1562848565.91e75b2-3.7.2
  • ardana-installer-ui >= 9.0+git.1566255088.3443670-3.7.2
  • ardana-ironic >= 9.0+git.1565721987.ddc59c8-3.7.2
  • ardana-keystone >= 9.0+git.1565891593.cad6d1a-3.7.2
  • ardana-logging >= 9.0+git.1565761582.2dc823a-3.7.2
  • ardana-magnum >= 9.0+git.1565762005.016032a-3.7.2
  • ardana-monasca >= 9.0+git.1566332665.ad894c0-3.7.2
  • ardana-mq >= 9.0+git.1565115025.148d092-3.7.2
  • ardana-neutron >= 9.0+git.1566251310.3a1e8f9-3.7.2
  • ardana-nova >= 9.0+git.1566332515.e232568-3.7.2
  • ardana-octavia >= 9.0+git.1566206502.6c87b41-3.7.2
  • ardana-opsconsole >= 9.0+git.1566251377.b1caeaa-3.7.2
  • ardana-opsconsole-ui >= 9.0+git.1555530925.206f1a8-4.7.2
  • ardana-osconfig >= 9.0+git.1565764394.545b573-3.7.2
  • ardana-service >= 9.0+git.1564706915.edd44c4-3.7.2
  • ardana-ses >= 9.0+git.1565962617.523149b-3.7.2
  • ardana-swift >= 9.0+git.1565891872.73fc3c7-3.7.2
  • ardana-swiftlm-drive-provision >= 9.0+git.1541434883.e0ebe69-8.1
  • ardana-swiftlm-log-tailer >= 9.0+git.1541434883.e0ebe69-8.1
  • ardana-swiftlm-uptime-mon >= 9.0+git.1541434883.e0ebe69-8.1
  • ardana-tempest >= 9.0+git.1566471752.a3c5c9c-3.7.2
  • openstack-ceilometer >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-agent-central >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-agent-compute >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-agent-ipmi >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-agent-notification >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-polling >= 11.0.2~dev14-3.7.2
  • openstack-cinder >= 13.0.7~dev3-3.7.2
  • openstack-cinder-api >= 13.0.7~dev3-3.7.2
  • openstack-cinder-backup >= 13.0.7~dev3-3.7.2
  • openstack-cinder-scheduler >= 13.0.7~dev3-3.7.2
  • openstack-cinder-volume >= 13.0.7~dev3-3.7.2
  • openstack-designate >= 7.0.1~dev21-3.7.2
  • openstack-designate-agent >= 7.0.1~dev21-3.7.2
  • openstack-designate-api >= 7.0.1~dev21-3.7.2
  • openstack-designate-central >= 7.0.1~dev21-3.7.2
  • openstack-designate-producer >= 7.0.1~dev21-3.7.2
  • openstack-designate-sink >= 7.0.1~dev21-3.7.2
  • openstack-designate-worker >= 7.0.1~dev21-3.7.2
  • openstack-heat >= 11.0.3~dev19-3.7.2
  • openstack-heat-api >= 11.0.3~dev19-3.7.2
  • openstack-heat-api-cfn >= 11.0.3~dev19-3.7.2
  • openstack-heat-engine >= 11.0.3~dev19-3.7.2
  • openstack-heat-plugin-heat_docker >= 11.0.3~dev19-3.7.2
  • openstack-horizon-plugin-neutron-fwaas-ui >= 1.5.1~dev6-8.1
  • openstack-horizon-plugin-neutron-lbaas-ui >= 5.0.1~dev7-8.1
  • openstack-horizon-plugin-neutron-vpnaas-ui >= 1.4.1~dev7-8.1
  • openstack-ironic >= 11.1.4~dev9-3.7.2
  • openstack-ironic-api >= 11.1.4~dev9-3.7.2
  • openstack-ironic-conductor >= 11.1.4~dev9-3.7.2
  • openstack-ironic-python-agent >= 3.3.3~dev4-3.7.2
  • openstack-keystone >= 14.1.1~dev8-3.7.2
  • openstack-magnum >= 7.1.1~dev28-3.7.2
  • openstack-magnum-api >= 7.1.1~dev28-3.7.2
  • openstack-magnum-conductor >= 7.1.1~dev28-3.7.2
  • openstack-manila >= 7.3.1~dev3-4.7.2
  • openstack-manila-api >= 7.3.1~dev3-4.7.2
  • openstack-manila-data >= 7.3.1~dev3-4.7.2
  • openstack-manila-scheduler >= 7.3.1~dev3-4.7.2
  • openstack-manila-share >= 7.3.1~dev3-4.7.2
  • openstack-monasca-notification >= 1.14.2~dev1-6.7.2
  • openstack-monasca-persister >= 1.12.1~dev9-9.1
  • openstack-monasca-persister-java >= 1.12.1~dev9-9.1
  • openstack-neutron >= 13.0.5~dev22-3.7.2
  • openstack-neutron-dhcp-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-gbp >= 5.0.1~dev459-3.7.2
  • openstack-neutron-ha-tool >= 13.0.5~dev22-3.7.2
  • openstack-neutron-l3-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-lbaas >= 13.0.1~dev14-3.7.2
  • openstack-neutron-lbaas-agent >= 13.0.1~dev14-3.7.2
  • openstack-neutron-linuxbridge-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-macvtap-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-metadata-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-metering-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-openvswitch-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-server >= 13.0.5~dev22-3.7.2
  • openstack-nova >= 18.2.2~dev9-3.7.2
  • openstack-nova-api >= 18.2.2~dev9-3.7.2
  • openstack-nova-cells >= 18.2.2~dev9-3.7.2
  • openstack-nova-compute >= 18.2.2~dev9-3.7.2
  • openstack-nova-conductor >= 18.2.2~dev9-3.7.2
  • openstack-nova-console >= 18.2.2~dev9-3.7.2
  • openstack-nova-novncproxy >= 18.2.2~dev9-3.7.2
  • openstack-nova-placement-api >= 18.2.2~dev9-3.7.2
  • openstack-nova-scheduler >= 18.2.2~dev9-3.7.2
  • openstack-nova-serialproxy >= 18.2.2~dev9-3.7.2
  • openstack-nova-vncproxy >= 18.2.2~dev9-3.7.2
  • openstack-octavia >= 3.1.2~dev8-3.7.2
  • openstack-octavia-amphora-agent >= 3.1.2~dev8-3.7.2
  • openstack-octavia-api >= 3.1.2~dev8-3.7.2
  • openstack-octavia-health-manager >= 3.1.2~dev8-3.7.2
  • openstack-octavia-housekeeping >= 3.1.2~dev8-3.7.2
  • openstack-octavia-worker >= 3.1.2~dev8-3.7.2
  • openstack-tempest >= 19.0.0-12.1
  • openstack-tempest-test >= 19.0.0-12.1
  • python-ardana-configurationprocessor >= 9.0+git.1566405927.c5c03d4-3.8.2
  • python-ceilometer >= 11.0.2~dev14-3.7.2
  • python-cinder >= 13.0.7~dev3-3.7.2
  • python-cinder-tempest-plugin >= 0.1.0-8.1
  • python-designate >= 7.0.1~dev21-3.7.2
  • python-heat >= 11.0.3~dev19-3.7.2
  • python-horizon-plugin-neutron-fwaas-ui >= 1.5.1~dev6-8.1
  • python-horizon-plugin-neutron-lbaas-ui >= 5.0.1~dev7-8.1
  • python-horizon-plugin-neutron-vpnaas-ui >= 1.4.1~dev7-8.1
  • python-ironic >= 11.1.4~dev9-3.7.2
  • python-ironicclient >= 2.5.3-4.7.2
  • python-ironicclient-doc >= 2.5.3-4.7.2
  • python-keystone >= 14.1.1~dev8-3.7.2
  • python-keystonemiddleware >= 5.2.0-8.1
  • python-magnum >= 7.1.1~dev28-3.7.2
  • python-manila >= 7.3.1~dev3-4.7.2
  • python-monasca-notification >= 1.14.2~dev1-6.7.2
  • python-monasca-persister >= 1.12.1~dev9-9.1
  • python-monasca-tempest-plugin >= 0.3.0-8.1
  • python-neutron >= 13.0.5~dev22-3.7.2
  • python-neutron-gbp >= 5.0.1~dev459-3.7.2
  • python-neutron-lbaas >= 13.0.1~dev14-3.7.2
  • python-nova >= 18.2.2~dev9-3.7.2
  • python-octavia >= 3.1.2~dev8-3.7.2
  • python-openstackclient >= 3.16.2-8.1
  • python-openstacksdk >= 0.17.3-8.1
  • python-proliantutils >= 2.8.4-8.1
  • python-python-engineio >= 2.0.2-9.1
  • python-swiftlm >= 9.0+git.1541434883.e0ebe69-8.1
  • python-tempest >= 19.0.0-12.1
  • python-urllib3 >= 1.23-3.6.1
  • python-vmware-nsx >= 13.0.1~dev146-9.1
  • python-vmware-nsxlib >= 13.0.1~dev24-8.1
  • venv-openstack-barbican >= 7.0.1~dev18-3.7.2
  • venv-openstack-barbican-x86_64 >= 7.0.1~dev18-3.7.2
  • venv-openstack-cinder >= 13.0.7~dev3-3.7.2
  • venv-openstack-cinder-x86_64 >= 13.0.7~dev3-3.7.2
  • venv-openstack-designate >= 7.0.1~dev21-3.7.2
  • venv-openstack-designate-x86_64 >= 7.0.1~dev21-3.7.2
  • venv-openstack-glance >= 17.0.1~dev16-3.7.2
  • venv-openstack-glance-x86_64 >= 17.0.1~dev16-3.7.2
  • venv-openstack-heat >= 11.0.3~dev19-3.7.2
  • venv-openstack-heat-x86_64 >= 11.0.3~dev19-3.7.2
  • venv-openstack-horizon >= 14.0.4~dev4-4.7.2
  • venv-openstack-horizon-x86_64 >= 14.0.4~dev4-4.7.2
  • venv-openstack-ironic >= 11.1.4~dev9-4.7.2
  • venv-openstack-ironic-x86_64 >= 11.1.4~dev9-4.7.2
  • venv-openstack-keystone >= 14.1.1~dev8-3.7.2
  • venv-openstack-keystone-x86_64 >= 14.1.1~dev8-3.7.2
  • venv-openstack-magnum >= 7.1.1~dev28-4.7.2
  • venv-openstack-magnum-x86_64 >= 7.1.1~dev28-4.7.2
  • venv-openstack-manila >= 7.3.1~dev3-3.7.2
  • venv-openstack-manila-x86_64 >= 7.3.1~dev3-3.7.2
  • venv-openstack-monasca >= 2.7.1~dev10-3.7.2
  • venv-openstack-monasca-ceilometer >= 1.8.2~dev3-3.7.2
  • venv-openstack-monasca-ceilometer-x86_64 >= 1.8.2~dev3-3.7.2
  • venv-openstack-monasca-x86_64 >= 2.7.1~dev10-3.7.2
  • venv-openstack-neutron >= 13.0.5~dev22-6.7.2
  • venv-openstack-neutron-x86_64 >= 13.0.5~dev22-6.7.2
  • venv-openstack-nova >= 18.2.2~dev9-3.7.2
  • venv-openstack-nova-x86_64 >= 18.2.2~dev9-3.7.2
  • venv-openstack-octavia >= 3.1.2~dev8-4.7.2
  • venv-openstack-octavia-x86_64 >= 3.1.2~dev8-4.7.2
  • venv-openstack-sahara >= 9.0.2~dev9-3.7.2
  • venv-openstack-sahara-x86_64 >= 9.0.2~dev9-3.7.2
  • venv-openstack-swift >= 2.19.2~dev1-2.4.2
  • venv-openstack-swift-x86_64 >= 2.19.2~dev1-2.4.2
Patchnames:
SUSE-OpenStack-Cloud-9-2019-2267
SUSE-OpenStack-Cloud-9-2019-2391
SUSE OpenStack Cloud Crowbar 8
  • python-urllib3 >= 1.22-5.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2300
SUSE OpenStack Cloud Crowbar 9
  • crowbar-core >= 6.0+git.1566321308.1de18b9a4-3.7.2
  • crowbar-core-branding-upstream >= 6.0+git.1566321308.1de18b9a4-3.7.2
  • crowbar-ha >= 6.0+git.1566406179.7549de2-3.7.2
  • crowbar-openstack >= 6.0+git.1566404979.41279a88e-3.7.2
  • crowbar-ui >= 1.3.0+git.1563181545.65360af5-8.1
  • openstack-ceilometer >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-agent-central >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-agent-compute >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-agent-ipmi >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-agent-notification >= 11.0.2~dev14-3.7.2
  • openstack-ceilometer-polling >= 11.0.2~dev14-3.7.2
  • openstack-cinder >= 13.0.7~dev3-3.7.2
  • openstack-cinder-api >= 13.0.7~dev3-3.7.2
  • openstack-cinder-backup >= 13.0.7~dev3-3.7.2
  • openstack-cinder-scheduler >= 13.0.7~dev3-3.7.2
  • openstack-cinder-volume >= 13.0.7~dev3-3.7.2
  • openstack-designate >= 7.0.1~dev21-3.7.2
  • openstack-designate-agent >= 7.0.1~dev21-3.7.2
  • openstack-designate-api >= 7.0.1~dev21-3.7.2
  • openstack-designate-central >= 7.0.1~dev21-3.7.2
  • openstack-designate-producer >= 7.0.1~dev21-3.7.2
  • openstack-designate-sink >= 7.0.1~dev21-3.7.2
  • openstack-designate-worker >= 7.0.1~dev21-3.7.2
  • openstack-heat >= 11.0.3~dev19-3.7.2
  • openstack-heat-api >= 11.0.3~dev19-3.7.2
  • openstack-heat-api-cfn >= 11.0.3~dev19-3.7.2
  • openstack-heat-engine >= 11.0.3~dev19-3.7.2
  • openstack-heat-plugin-heat_docker >= 11.0.3~dev19-3.7.2
  • openstack-horizon-plugin-neutron-fwaas-ui >= 1.5.1~dev6-8.1
  • openstack-horizon-plugin-neutron-lbaas-ui >= 5.0.1~dev7-8.1
  • openstack-horizon-plugin-neutron-vpnaas-ui >= 1.4.1~dev7-8.1
  • openstack-ironic >= 11.1.4~dev9-3.7.2
  • openstack-ironic-api >= 11.1.4~dev9-3.7.2
  • openstack-ironic-conductor >= 11.1.4~dev9-3.7.2
  • openstack-ironic-python-agent >= 3.3.3~dev4-3.7.2
  • openstack-keystone >= 14.1.1~dev8-3.7.2
  • openstack-magnum >= 7.1.1~dev28-3.7.2
  • openstack-magnum-api >= 7.1.1~dev28-3.7.2
  • openstack-magnum-conductor >= 7.1.1~dev28-3.7.2
  • openstack-manila >= 7.3.1~dev3-4.7.2
  • openstack-manila-api >= 7.3.1~dev3-4.7.2
  • openstack-manila-data >= 7.3.1~dev3-4.7.2
  • openstack-manila-scheduler >= 7.3.1~dev3-4.7.2
  • openstack-manila-share >= 7.3.1~dev3-4.7.2
  • openstack-monasca-notification >= 1.14.2~dev1-6.7.2
  • openstack-monasca-persister >= 1.12.1~dev9-9.1
  • openstack-monasca-persister-java >= 1.12.1~dev9-9.1
  • openstack-neutron >= 13.0.5~dev22-3.7.2
  • openstack-neutron-dhcp-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-gbp >= 5.0.1~dev459-3.7.2
  • openstack-neutron-ha-tool >= 13.0.5~dev22-3.7.2
  • openstack-neutron-l3-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-lbaas >= 13.0.1~dev14-3.7.2
  • openstack-neutron-lbaas-agent >= 13.0.1~dev14-3.7.2
  • openstack-neutron-linuxbridge-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-macvtap-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-metadata-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-metering-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-openvswitch-agent >= 13.0.5~dev22-3.7.2
  • openstack-neutron-server >= 13.0.5~dev22-3.7.2
  • openstack-nova >= 18.2.2~dev9-3.7.2
  • openstack-nova-api >= 18.2.2~dev9-3.7.2
  • openstack-nova-cells >= 18.2.2~dev9-3.7.2
  • openstack-nova-compute >= 18.2.2~dev9-3.7.2
  • openstack-nova-conductor >= 18.2.2~dev9-3.7.2
  • openstack-nova-console >= 18.2.2~dev9-3.7.2
  • openstack-nova-novncproxy >= 18.2.2~dev9-3.7.2
  • openstack-nova-placement-api >= 18.2.2~dev9-3.7.2
  • openstack-nova-scheduler >= 18.2.2~dev9-3.7.2
  • openstack-nova-serialproxy >= 18.2.2~dev9-3.7.2
  • openstack-nova-vncproxy >= 18.2.2~dev9-3.7.2
  • openstack-octavia >= 3.1.2~dev8-3.7.2
  • openstack-octavia-amphora-agent >= 3.1.2~dev8-3.7.2
  • openstack-octavia-api >= 3.1.2~dev8-3.7.2
  • openstack-octavia-health-manager >= 3.1.2~dev8-3.7.2
  • openstack-octavia-housekeeping >= 3.1.2~dev8-3.7.2
  • openstack-octavia-worker >= 3.1.2~dev8-3.7.2
  • openstack-tempest >= 19.0.0-12.1
  • openstack-tempest-test >= 19.0.0-12.1
  • python-ceilometer >= 11.0.2~dev14-3.7.2
  • python-cinder >= 13.0.7~dev3-3.7.2
  • python-cinder-tempest-plugin >= 0.1.0-8.1
  • python-designate >= 7.0.1~dev21-3.7.2
  • python-heat >= 11.0.3~dev19-3.7.2
  • python-horizon-plugin-neutron-fwaas-ui >= 1.5.1~dev6-8.1
  • python-horizon-plugin-neutron-lbaas-ui >= 5.0.1~dev7-8.1
  • python-horizon-plugin-neutron-vpnaas-ui >= 1.4.1~dev7-8.1
  • python-ironic >= 11.1.4~dev9-3.7.2
  • python-ironicclient >= 2.5.3-4.7.2
  • python-ironicclient-doc >= 2.5.3-4.7.2
  • python-keystone >= 14.1.1~dev8-3.7.2
  • python-keystonemiddleware >= 5.2.0-8.1
  • python-magnum >= 7.1.1~dev28-3.7.2
  • python-manila >= 7.3.1~dev3-4.7.2
  • python-monasca-notification >= 1.14.2~dev1-6.7.2
  • python-monasca-persister >= 1.12.1~dev9-9.1
  • python-monasca-tempest-plugin >= 0.3.0-8.1
  • python-neutron >= 13.0.5~dev22-3.7.2
  • python-neutron-gbp >= 5.0.1~dev459-3.7.2
  • python-neutron-lbaas >= 13.0.1~dev14-3.7.2
  • python-nova >= 18.2.2~dev9-3.7.2
  • python-octavia >= 3.1.2~dev8-3.7.2
  • python-openstackclient >= 3.16.2-8.1
  • python-openstacksdk >= 0.17.3-8.1
  • python-proliantutils >= 2.8.4-8.1
  • python-tempest >= 19.0.0-12.1
  • python-urllib3 >= 1.23-3.6.1
  • python-vmware-nsx >= 13.0.1~dev146-9.1
  • python-vmware-nsxlib >= 13.0.1~dev24-8.1
  • yast2-crowbar >= 3.4.2-8.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2019-2267
SUSE-OpenStack-Cloud-Crowbar-9-2019-2391
openSUSE Leap 15.0
  • python-urllib3 >= 1.22-lp150.5.3.1
  • python2-urllib3 >= 1.22-lp150.5.3.1
  • python3-urllib3 >= 1.22-lp150.5.3.1
Patchnames:
openSUSE-2019-2131
openSUSE Leap 15.1
  • python-urllib3 >= 1.24-lp151.2.3.1
  • python-urllib3-test >= 1.24-lp151.2.3.1
  • python2-urllib3 >= 1.24-lp151.2.3.1
  • python2-urllib3-test >= 1.24-lp151.2.3.1
  • python3-urllib3 >= 1.24-lp151.2.3.1
  • python3-urllib3-test >= 1.24-lp151.2.3.1
Patchnames:
openSUSE-2019-2133


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 python-urllib3 Affected
CaaS Platform 2.0 python-urllib3 Affected
CaaS Platform 3.0 python-urllib3 Released
HPE Helion OpenStack 8 python-urllib3 Released
OpenStack Cloud Magnum Orchestration 7.0 python-urllib3 Affected
SUSE Linux Enterprise Module for Basesystem 15 GA python-urllib3 Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-urllib3 Released
SUSE Linux Enterprise Module for Public Cloud 12 python-urllib3 Released
SUSE Linux Enterprise Module for Python2 15 SP1 python-urllib3 Released
SUSE Manager Server 3.1 python-urllib3 Affected
SUSE Manager Server 3.2 python-urllib3 Released
SUSE Openstack Cloud 7 python-urllib3 Affected
SUSE Openstack Cloud 8 python-urllib3 Released
SUSE Openstack Cloud 9 python-urllib3 Released
SUSE Storage 4 python-urllib3 Released
SUSE Storage 5 python-urllib3 Released