Upstream information

CVE-2019-10877 at MITRE

Description

In Teeworlds 0.7.2, there is an integer overflow in CMap::Load() in engine/shared/map.cpp that can lead to a buffer overflow, because multiplication of width and height is mishandled.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1131731 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.1
  • teeworlds >= 0.7.3.1-lp151.2.3.1
  • teeworlds-debuginfo >= 0.7.3.1-lp151.2.3.1
  • teeworlds-debugsource >= 0.7.3.1-lp151.2.3.1
Patchnames:
openSUSE-2019-1793