Upstream information

CVE-2019-0199 at MITRE

Description

The HTTP/2 implementation in Apache Tomcat 9.0.0.M1 to 9.0.14 and 8.5.0 to 8.5.37 accepted streams with excessive numbers of SETTINGS frames and also permitted clients to keep streams open without reading/writing request/response data. By keeping streams open for requests that utilised the Servlet API's blocking I/O, clients were able to cause server-side threads to block eventually leading to thread exhaustion and a DoS.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entries: 1131055 [NEW], 1139924 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • tomcat >= 9.0.21-3.27.1
  • tomcat-docs-webapp >= 9.0.21-3.27.1
  • tomcat-embed >= 9.0.21-3.27.1
  • tomcat-javadoc >= 9.0.21-3.27.1
  • tomcat-jsvc >= 9.0.21-3.27.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1693
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1825
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • tomcat >= 9.0.21-4.5.5
  • tomcat-docs-webapp >= 9.0.21-4.5.5
  • tomcat-embed >= 9.0.21-4.5.5
  • tomcat-javadoc >= 9.0.21-4.5.5
  • tomcat-jsvc >= 9.0.21-4.5.5
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1895
SUSE Linux Enterprise Module for Web Scripting 15
  • tomcat >= 9.0.21-3.27.1
  • tomcat-admin-webapps >= 9.0.21-3.27.1
  • tomcat-el-3_0-api >= 9.0.21-3.27.1
  • tomcat-jsp-2_3-api >= 9.0.21-3.27.1
  • tomcat-lib >= 9.0.21-3.27.1
  • tomcat-servlet-4_0-api >= 9.0.21-3.27.1
  • tomcat-webapps >= 9.0.21-3.27.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-2019-1693
SUSE-SLE-Module-Web-Scripting-15-2019-1825
SUSE Linux Enterprise Module for Web Scripting 15 SP1
  • tomcat >= 9.0.21-4.5.5
  • tomcat-admin-webapps >= 9.0.21-4.5.5
  • tomcat-el-3_0-api >= 9.0.21-4.5.5
  • tomcat-jsp-2_3-api >= 9.0.21-4.5.5
  • tomcat-lib >= 9.0.21-4.5.5
  • tomcat-servlet-4_0-api >= 9.0.21-4.5.5
  • tomcat-webapps >= 9.0.21-4.5.5
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP1-2019-1895
SUSE Linux Enterprise Server 12 SP4
  • tomcat >= 9.0.21-3.13.2
  • tomcat-admin-webapps >= 9.0.21-3.13.2
  • tomcat-docs-webapp >= 9.0.21-3.13.2
  • tomcat-el-3_0-api >= 9.0.21-3.13.2
  • tomcat-javadoc >= 9.0.21-3.13.2
  • tomcat-jsp-2_3-api >= 9.0.21-3.13.2
  • tomcat-lib >= 9.0.21-3.13.2
  • tomcat-servlet-4_0-api >= 9.0.21-3.13.2
  • tomcat-webapps >= 9.0.21-3.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1866
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • tomcat >= 9.0.21-3.13.2
  • tomcat-admin-webapps >= 9.0.21-3.13.2
  • tomcat-docs-webapp >= 9.0.21-3.13.2
  • tomcat-el-3_0-api >= 9.0.21-3.13.2
  • tomcat-javadoc >= 9.0.21-3.13.2
  • tomcat-jsp-2_3-api >= 9.0.21-3.13.2
  • tomcat-lib >= 9.0.21-3.13.2
  • tomcat-servlet-4_0-api >= 9.0.21-3.13.2
  • tomcat-webapps >= 9.0.21-3.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1866
openSUSE Leap 15.0
  • tomcat >= 9.0.21-lp150.2.22.1
  • tomcat-admin-webapps >= 9.0.21-lp150.2.22.1
  • tomcat-docs-webapp >= 9.0.21-lp150.2.22.1
  • tomcat-el-3_0-api >= 9.0.21-lp150.2.22.1
  • tomcat-embed >= 9.0.21-lp150.2.22.1
  • tomcat-javadoc >= 9.0.21-lp150.2.22.1
  • tomcat-jsp-2_3-api >= 9.0.21-lp150.2.22.1
  • tomcat-jsvc >= 9.0.21-lp150.2.22.1
  • tomcat-lib >= 9.0.21-lp150.2.22.1
  • tomcat-servlet-4_0-api >= 9.0.21-lp150.2.22.1
  • tomcat-webapps >= 9.0.21-lp150.2.22.1
Patchnames:
openSUSE-2019-1673
openSUSE-2019-1723
openSUSE Leap 15.1
  • tomcat >= 9.0.21-lp151.3.3.1
  • tomcat-admin-webapps >= 9.0.21-lp151.3.3.1
  • tomcat-docs-webapp >= 9.0.21-lp151.3.3.1
  • tomcat-el-3_0-api >= 9.0.21-lp151.3.3.1
  • tomcat-embed >= 9.0.21-lp151.3.3.1
  • tomcat-javadoc >= 9.0.21-lp151.3.3.1
  • tomcat-jsp-2_3-api >= 9.0.21-lp151.3.3.1
  • tomcat-jsvc >= 9.0.21-lp151.3.3.1
  • tomcat-lib >= 9.0.21-lp151.3.3.1
  • tomcat-servlet-4_0-api >= 9.0.21-lp151.3.3.1
  • tomcat-webapps >= 9.0.21-lp151.3.3.1
Patchnames:
openSUSE-2019-1808


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 tomcat Released
SUSE Linux Enterprise Module for Web and Scripting 15 tomcat Released
SUSE Linux Enterprise Server 12 GA LTSS tomcat Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP3 tomcat Affected
SUSE Linux Enterprise Server 12 SP4 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 GA tomcat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 tomcat Released