Upstream information

CVE-2018-9336 at MITRE

Description

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 5.5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
SUSE Bugzilla entries: 1090647 [IN_PROGRESS], 1090839 [REOPENED]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Basesystem 15
  • openvpn >= 2.4.3-5.3.19
  • openvpn-auth-pam-plugin >= 2.4.3-5.3.19
  • openvpn-auth-pam-plugin-debuginfo >= 2.4.3-5.3.19
  • openvpn-debuginfo >= 2.4.3-5.3.19
  • openvpn-debugsource >= 2.4.3-5.3.19
  • openvpn-devel >= 2.4.3-5.3.19


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 openvpn Unsupported
SUSE Linux Enterprise Desktop 12 SP3 openvpn Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA openvpn In progress
SUSE Linux Enterprise Security Module 11.3 GA openvpn-openssl1 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS openvpn Not affected
SUSE Linux Enterprise Server 11 SP4 openvpn Not affected
SUSE Linux Enterprise Server 12 GA LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP2 openvpn Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP3 openvpn Not affected