Upstream information

CVE-2018-9055 at MITRE

Description

JasPer 2.0.14 allows denial of service via a reachable assertion in the function jpc_firstone in libjasper/jpc/jpc_math.c.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 3.3
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entries: 1087020 [NEW], 1088278 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • jasper >= 1.900.14-195.8.1
  • libjasper1 >= 1.900.14-195.8.1
  • libjasper1-32bit >= 1.900.14-195.8.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-982
SUSE Linux Enterprise Module for Basesystem 15
  • libjasper4 >= 2.0.14-1.19
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libjasper4
SUSE Linux Enterprise Module for Desktop Applications 15
  • libjasper-devel >= 2.0.14-1.19
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libjasper-devel
SUSE Linux Enterprise Server 12 SP3
  • jasper >= 1.900.14-195.8.1
  • libjasper1 >= 1.900.14-195.8.1
  • libjasper1-32bit >= 1.900.14-195.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-982
SUSE Linux Enterprise Software Development Kit 12 SP3
  • jasper >= 1.900.14-195.8.1
  • libjasper-devel >= 1.900.14-195.8.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-982
openSUSE Leap 15.0
  • libjasper4 >= 2.0.14-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libjasper4
openSUSE Leap 42.3
  • jasper >= 1.900.14-182.1
  • jasper-debuginfo >= 1.900.14-182.1
  • jasper-debugsource >= 1.900.14-182.1
  • libjasper-devel >= 1.900.14-182.1
  • libjasper1 >= 1.900.14-182.1
  • libjasper1-32bit >= 1.900.14-182.1
  • libjasper1-debuginfo >= 1.900.14-182.1
  • libjasper1-debuginfo-32bit >= 1.900.14-182.1
Patchnames:
openSUSE-2018-531


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 jasper Unsupported
SUSE Linux Enterprise Desktop 12 SP3 jasper Released
SUSE Linux Enterprise SDK 11 SP4 jasper Affected
SUSE Linux Enterprise SDK 12 SP2 jasper Unsupported
SUSE Linux Enterprise SDK 12 SP3 jasper Released
SUSE Linux Enterprise Server 11 SP3 LTSS jasper Affected
SUSE Linux Enterprise Server 11 SP4 jasper Affected
SUSE Linux Enterprise Server 12 GA LTSS jasper Affected
SUSE Linux Enterprise Server 12 SP1 LTSS jasper Affected
SUSE Linux Enterprise Server 12 SP2 jasper Unsupported
SUSE Linux Enterprise Server 12 SP3 jasper Released