Upstream information

CVE-2018-7999 at MITRE

Description

In libgraphite2 in graphite2 1.3.11, a NULL pointer dereference vulnerability was found in Segment.cpp during a dumbRendering operation, which may allow attackers to cause a denial of service or possibly have unspecified other impact via a crafted .ttf file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 5.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
SUSE Bugzilla entry: 1084850 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • graphite2 >= 1.3.1-10.3.1
  • libgraphite2-3 >= 1.3.1-10.3.1
  • libgraphite2-3-32bit >= 1.3.1-10.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-573
SUSE Linux Enterprise Desktop 12 SP3
  • graphite2 >= 1.3.1-10.3.1
  • libgraphite2-3 >= 1.3.1-10.3.1
  • libgraphite2-3-32bit >= 1.3.1-10.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-573
SUSE Linux Enterprise Module for Basesystem 15
  • graphite2-devel >= 1.3.11-2.12
  • libgraphite2-3 >= 1.3.11-2.12
  • libgraphite2-3-32bit >= 1.3.11-2.12
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA graphite2-devel
SUSE Linux Enterprise Server 12 SP2
  • graphite2 >= 1.3.1-10.3.1
  • libgraphite2-3 >= 1.3.1-10.3.1
  • libgraphite2-3-32bit >= 1.3.1-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-573
SUSE Linux Enterprise Server 12 SP3
  • graphite2 >= 1.3.1-10.3.1
  • libgraphite2-3 >= 1.3.1-10.3.1
  • libgraphite2-3-32bit >= 1.3.1-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-573
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • graphite2 >= 1.3.1-10.3.1
  • libgraphite2-3 >= 1.3.1-10.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-573
SUSE Linux Enterprise Software Development Kit 12 SP2
  • graphite2 >= 1.3.1-10.3.1
  • graphite2-devel >= 1.3.1-10.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-573
SUSE Linux Enterprise Software Development Kit 12 SP3
  • graphite2 >= 1.3.1-10.3.1
  • graphite2-devel >= 1.3.1-10.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-573
openSUSE Leap 15.0
  • libgraphite2-3 >= 1.3.11-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libgraphite2-3
openSUSE Leap 42.3
  • graphite2 >= 1.3.1-7.3.1
  • graphite2-debuginfo >= 1.3.1-7.3.1
  • graphite2-debugsource >= 1.3.1-7.3.1
  • graphite2-devel >= 1.3.1-7.3.1
  • libgraphite2-3 >= 1.3.1-7.3.1
  • libgraphite2-3-32bit >= 1.3.1-7.3.1
  • libgraphite2-3-debuginfo >= 1.3.1-7.3.1
  • libgraphite2-3-debuginfo-32bit >= 1.3.1-7.3.1
Patchnames:
openSUSE-2018-337


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 graphite2 Released
SUSE Linux Enterprise Desktop 12 SP3 graphite2 Released
SUSE Linux Enterprise SDK 12 SP2 graphite2 Released
SUSE Linux Enterprise SDK 12 SP3 graphite2 Released
SUSE Linux Enterprise Server 12 GA LTSS graphite2 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS graphite2 Affected
SUSE Linux Enterprise Server 12 SP2 graphite2 Released
SUSE Linux Enterprise Server 12 SP3 graphite2 Released