Upstream information

CVE-2018-7187 at MITRE

Description

The "go get" implementation in Go 1.9.4, when the -insecure command-line option is used, does not validate the import path (get/vcs.go only checks for "://" anywhere in the string), which allows remote attackers to execute arbitrary OS commands via a crafted web site.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1080006 [RESOLVED / FIXED], 1081495 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12
  • go >= 1.9.7-19.1
  • go-doc >= 1.9.7-19.1
  • go-race >= 1.9.7-19.1
  • go1.9 >= 1.9.7-13.2
  • go1.9-doc >= 1.9.7-13.2
  • go1.9-race >= 1.9.7-13.2
Patchnames:
openSUSE-2018-672
openSUSE Leap 15.0
  • go >= 1.9.7-lp150.2.4.1
  • go-doc >= 1.9.7-lp150.2.4.1
  • go-race >= 1.9.7-lp150.2.4.1
  • go1.9 >= 1.9.7-lp150.2.4.2
  • go1.9-doc >= 1.9.7-lp150.2.4.2
  • go1.9-race >= 1.9.7-lp150.2.4.2
Patchnames:
openSUSE-2018-672
openSUSE Leap 42.3
  • go >= 1.9.7-37.2
  • go-doc >= 1.9.7-37.2
  • go-race >= 1.9.7-37.2
  • go1.9 >= 1.9.7-10.1
  • go1.9-doc >= 1.9.7-10.1
  • go1.9-race >= 1.9.7-10.1
Patchnames:
openSUSE-2018-672