Upstream information

CVE-2018-7185 at MITRE

Description

The protocol engine in ntp 4.2.6 before 4.2.8p11 allows a remote attackers to cause a denial of service (disruption) by continually sending a packet with a zero-origin timestamp and source IP address of the "other side" of an interleaved association causing the victim ntpd to reset its association.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 3.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entries: 1082210 [RESOLVED / FIXED], 1083420 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • ntp >= 4.2.8p11-64.5.1
Patchnames:
SUSE-CAASP-ALL-2018-1188
SUSE-CAASP-ALL-2018-648
SUSE Enterprise Storage 4
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-Storage-4-2018-1188
SUSE Linux Enterprise Desktop 12 SP3
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1188
SUSE-SLE-DESKTOP-12-SP3-2018-648
SUSE Linux Enterprise Module for Legacy Software 15
  • ntp >= 4.2.8p11-2.12
Patchnames:
SUSE Linux Enterprise Module for Legacy Software 15 GA ntp
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1188
SUSE Linux Enterprise Server 11 SP4
  • ntp >= 4.2.8p11-64.4.1
  • ntp-doc >= 4.2.8p11-64.4.1
Patchnames:
slessp4-ntp-13534
SUSE Linux Enterprise Server 12 SP1-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1188
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1188
SUSE Linux Enterprise Server 12 SP3
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1188
SUSE-SLE-SERVER-12-SP3-2018-648
SUSE Linux Enterprise Server 12-LTSS
  • ntp >= 4.2.8p11-46.26.2
  • ntp-doc >= 4.2.8p11-46.26.2
Patchnames:
SUSE-SLE-SERVER-12-2018-1000
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • ntp >= 4.2.8p11-64.4.1
  • ntp-doc >= 4.2.8p11-64.4.1
Patchnames:
slessp4-ntp-13534
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-1188
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1188
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1188
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1188
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1188
SUSE-SLE-SERVER-12-SP3-2018-648
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • ntp >= 4.2.8p11-46.26.2
  • ntp-doc >= 4.2.8p11-46.26.2
Patchnames:
SUSE-SLE-SERVER-12-2018-1000
SUSE OpenStack Cloud 7
  • ntp >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1188
openSUSE Leap 42.3
  • ntp >= 4.2.8p11-31.3.1
  • ntp-debuginfo >= 4.2.8p11-31.3.1
  • ntp-debugsource >= 4.2.8p11-31.3.1
  • ntp-doc >= 4.2.8p11-31.3.1
Patchnames:
openSUSE-2018-376

List of packages in QA

Product(s) Package(s)
SUSE CaaS Platform ALL
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
SUSE Enterprise Storage 4
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Desktop 12 SP3
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12 SP1-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12 SP2-BCL
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12 SP3
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE OpenStack Cloud 7
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 ntp In progress
CaaS Platform 3.0 ntp In progress
SUSE Linux Enterprise Desktop 12 SP2 ntp Affected
SUSE Linux Enterprise Desktop 12 SP3 ntp In progress
SUSE Linux Enterprise Server 11 SP3 LTSS ntp Affected
SUSE Linux Enterprise Server 11 SP4 ntp Released
SUSE Linux Enterprise Server 12 GA LTSS ntp Released
SUSE Linux Enterprise Server 12 SP1 LTSS ntp In progress
SUSE Linux Enterprise Server 12 SP2 ntp Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ntp In progress
SUSE Linux Enterprise Server 12 SP3 ntp In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ntp In progress