Upstream information

CVE-2018-7183 at MITRE

Description

Buffer overflow in the decodearr function in ntpq in ntp 4.2.8p6 through 4.2.8p10 allows remote attackers to execute arbitrary code by leveraging an ntpq query and sending a response with a crafted array.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entries: 1082210 [IN_PROGRESS], 1083417 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • ntp >= 4.2.8p11-64.3.2
Patchnames:
SUSE-CAASP-ALL-2018-648
SUSE Linux Enterprise Desktop 12 SP3
  • ntp >= 4.2.8p11-64.3.2
  • ntp-doc >= 4.2.8p11-64.3.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-648
SUSE Linux Enterprise Server 11 SP4
  • ntp >= 4.2.8p11-64.4.1
  • ntp-doc >= 4.2.8p11-64.4.1
Patchnames:
slessp4-ntp-13534
SUSE Linux Enterprise Server 12 SP3
  • ntp >= 4.2.8p11-64.3.2
  • ntp-doc >= 4.2.8p11-64.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-648
SUSE Linux Enterprise Server 12-LTSS
  • ntp >= 4.2.8p11-46.26.2
  • ntp-doc >= 4.2.8p11-46.26.2
Patchnames:
SUSE-SLE-SERVER-12-2018-1000
openSUSE Leap 42.3
  • ntp >= 4.2.8p11-31.3.1
  • ntp-debuginfo >= 4.2.8p11-31.3.1
  • ntp-debugsource >= 4.2.8p11-31.3.1
  • ntp-doc >= 4.2.8p11-31.3.1
Patchnames:
openSUSE-2018-376

List of packages in QA

Product(s) Package(s)
SUSE CaaS Platform ALL
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
SUSE Enterprise Storage 4
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Desktop 12 SP3
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12 SP1-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12 SP3
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise for SAP 12 SP1
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE Linux Enterprise for SAP 12 SP2
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1
SUSE OpenStack Cloud 7
  • ntp >= 4.2.8p11-64.5.1
  • ntp-debuginfo >= 4.2.8p11-64.5.1
  • ntp-debugsource >= 4.2.8p11-64.5.1
  • ntp-doc >= 4.2.8p11-64.5.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 ntp In progress
SUSE Linux Enterprise Desktop 12 SP2 ntp Unsupported
SUSE Linux Enterprise Desktop 12 SP3 ntp In progress
SUSE Linux Enterprise Server 11 SP3 LTSS ntp Affected
SUSE Linux Enterprise Server 11 SP4 ntp Released
SUSE Linux Enterprise Server 12 GA LTSS ntp Released
SUSE Linux Enterprise Server 12 SP1 LTSS ntp In progress
SUSE Linux Enterprise Server 12 SP2 ntp Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS ntp In progress
SUSE Linux Enterprise Server 12 SP3 ntp In progress