Upstream information

CVE-2018-7167 at MITRE

Description

Calling Buffer.fill() or Buffer.alloc() with some parameters can lead to a hang which could result in a Denial of Service. In order to address this vulnerability, the implementations of Buffer.alloc() and Buffer.fill() were updated so that they zero fill instead of hanging in these cases. All versions of Node.js 6.x (LTS "Boron"), 8.x (LTS "Carbon"), and 9.x are vulnerable. All versions of Node.js 10.x (Current) are NOT vulnerable.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1097375 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • nodejs6 >= 6.14.3-11.15.1
Patchnames:
SUSE-Storage-4-2018-1287
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs6 >= 6.14.3-11.15.1
  • nodejs6-devel >= 6.14.3-11.15.1
  • nodejs6-docs >= 6.14.3-11.15.1
  • npm6 >= 6.14.3-11.15.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2018-1287
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.3-3.5.1
  • nodejs8-devel >= 8.11.3-3.5.1
  • nodejs8-docs >= 8.11.3-3.5.1
  • npm8 >= 8.11.3-3.5.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-2018-1291
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.14.3-11.15.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1287
SUSE OpenStack Cloud Crowbar 8
  • nodejs6 >= 6.14.3-11.15.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2018-1287
openSUSE Leap 15.0
  • nodejs8 >= 8.11.3-lp150.2.3.1
  • nodejs8-debuginfo >= 8.11.3-lp150.2.3.1
  • nodejs8-debugsource >= 8.11.3-lp150.2.3.1
  • nodejs8-devel >= 8.11.3-lp150.2.3.1
  • nodejs8-docs >= 8.11.3-lp150.2.3.1
  • npm8 >= 8.11.3-lp150.2.3.1
Patchnames:
openSUSE-2018-724
openSUSE Leap 42.3
  • nodejs6 >= 6.14.3-12.1
  • nodejs6-debuginfo >= 6.14.3-12.1
  • nodejs6-debugsource >= 6.14.3-12.1
  • nodejs6-devel >= 6.14.3-12.1
  • nodejs6-docs >= 6.14.3-12.1
  • npm6 >= 6.14.3-12.1
Patchnames:
openSUSE-2018-723


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Released
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs8 Released
SUSE Openstack Cloud 7 nodejs6 Released
SUSE Openstack Cloud 8 nodejs6 Released
SUSE Storage 4 nodejs4 Not affected
SUSE Storage 4 nodejs6 Released