Upstream information

CVE-2018-7161 at MITRE

Description

All versions of Node.js 8.x, 9.x, and 10.x are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node server providing an http2 server to crash. This can be accomplished by interacting with the http2 server in a manner that triggers a cleanup bug where objects are used in native code after they are no longer available. This has been addressed by updating the http2 implementation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.2
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1097404 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.3-3.5.1
  • nodejs8-devel >= 8.11.3-3.5.1
  • nodejs8-docs >= 8.11.3-3.5.1
  • npm8 >= 8.11.3-3.5.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-2018-1291
openSUSE Leap 15.0
  • nodejs8 >= 8.11.3-lp150.2.3.1
  • nodejs8-debuginfo >= 8.11.3-lp150.2.3.1
  • nodejs8-debugsource >= 8.11.3-lp150.2.3.1
  • nodejs8-devel >= 8.11.3-lp150.2.3.1
  • nodejs8-docs >= 8.11.3-lp150.2.3.1
  • npm8 >= 8.11.3-lp150.2.3.1
Patchnames:
openSUSE-2018-724


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs8 Released
SUSE Openstack Cloud 7 nodejs6 Not affected
SUSE Openstack Cloud 8 nodejs6 Not affected
SUSE Storage 4 nodejs4 Not affected
SUSE Storage 4 nodejs6 Not affected