Upstream information

CVE-2018-7033 at MITRE

Description

SchedMD Slurm before 17.02.10 and 17.11.x before 17.11.5 allows SQL Injection attacks against SlurmDBD.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 4.4
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High None
SUSE Bugzilla entry: 1085240 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for High Performance Computing 12
  • libpmi0 >= 17.02.10-6.16.1
  • libslurm31 >= 17.02.10-6.16.1
  • perl-slurm >= 17.02.10-6.16.1
  • slurm >= 17.02.10-6.16.1
  • slurm-auth-none >= 17.02.10-6.16.1
  • slurm-devel >= 17.02.10-6.16.1
  • slurm-doc >= 17.02.10-6.16.1
  • slurm-lua >= 17.02.10-6.16.1
  • slurm-munge >= 17.02.10-6.16.1
  • slurm-pam_slurm >= 17.02.10-6.16.1
  • slurm-plugins >= 17.02.10-6.16.1
  • slurm-sched-wiki >= 17.02.10-6.16.1
  • slurm-slurmdb-direct >= 17.02.10-6.16.1
  • slurm-slurmdbd >= 17.02.10-6.16.1
  • slurm-sql >= 17.02.10-6.16.1
  • slurm-torque >= 17.02.10-6.16.1
Patchnames:
SUSE-SLE-Module-HPC-12-2018-664
SUSE Linux Enterprise Module for High Performance Computing 15
  • libpmi0 >= 17.11.5-4.28
  • libslurm32 >= 17.11.5-4.28
  • perl-slurm >= 17.11.5-4.28
  • slurm >= 17.11.5-4.28
  • slurm-auth-none >= 17.11.5-4.28
  • slurm-config >= 17.11.5-4.28
  • slurm-devel >= 17.11.5-4.28
  • slurm-doc >= 17.11.5-4.28
  • slurm-lua >= 17.11.5-4.28
  • slurm-munge >= 17.11.5-4.28
  • slurm-node >= 17.11.5-4.28
  • slurm-pam_slurm >= 17.11.5-4.28
  • slurm-plugins >= 17.11.5-4.28
  • slurm-slurmdbd >= 17.11.5-4.28
  • slurm-sql >= 17.11.5-4.28
  • slurm-torque >= 17.11.5-4.28
Patchnames:
SUSE Linux Enterprise Module for High Performance Computing 15 GA libpmi0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for High Performance Computing 12 slurm Released