Upstream information

CVE-2018-6798 at MITRE

Description

An issue was discovered in Perl 5.22 through 5.26. Matching a crafted locale dependent regular expression can cause a heap-based buffer over-read and potentially information disclosure.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1082233 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • perl >= 5.18.2-12.11.1
  • perl-base >= 5.18.2-12.11.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-730
SUSE CaaS Platform ALL
  • perl >= 5.18.2-12.11.1
  • perl-base >= 5.18.2-12.11.1
Patchnames:
SUSE-CAASP-ALL-2018-730
SUSE Linux Enterprise Desktop 12 SP3
  • perl >= 5.18.2-12.11.1
  • perl-32bit >= 5.18.2-12.11.1
  • perl-base >= 5.18.2-12.11.1
  • perl-doc >= 5.18.2-12.11.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-730
SUSE Linux Enterprise Server 11 SP4
  • perl >= 5.10.0-64.81.10.1
  • perl-32bit >= 5.10.0-64.81.10.1
  • perl-Module-Build >= 0.2808.01-0.81.10.1
  • perl-Test-Simple >= 0.72-0.81.10.1
  • perl-base >= 5.10.0-64.81.10.1
  • perl-doc >= 5.10.0-64.81.10.1
  • perl-x86 >= 5.10.0-64.81.10.1
Patchnames:
slessp4-perl-13564
SUSE Linux Enterprise Server 12 SP3
  • perl >= 5.18.2-12.11.1
  • perl-32bit >= 5.18.2-12.11.1
  • perl-base >= 5.18.2-12.11.1
  • perl-doc >= 5.18.2-12.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-730
SUSE Linux Enterprise Software Development Kit 11 SP4
  • perl >= 5.10.0-64.81.10.1
  • perl-base-32bit >= 5.10.0-64.81.10.1
Patchnames:
sdksp4-perl-13564
openSUSE Leap 42.3
  • perl >= 5.18.2-12.1
  • perl-32bit >= 5.18.2-12.1
  • perl-base >= 5.18.2-12.1
  • perl-base-32bit >= 5.18.2-12.1
  • perl-base-debuginfo >= 5.18.2-12.1
  • perl-base-debuginfo-32bit >= 5.18.2-12.1
  • perl-debuginfo >= 5.18.2-12.1
  • perl-debuginfo-32bit >= 5.18.2-12.1
  • perl-debugsource >= 5.18.2-12.1
  • perl-doc >= 5.18.2-12.1
Patchnames:
openSUSE-2018-400


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 perl Released
OpenStack Cloud Magnum Orchestration 7.0 perl Released
SUSE Linux Enterprise Desktop 12 SP2 perl In progress
SUSE Linux Enterprise Desktop 12 SP3 perl Released
SUSE Linux Enterprise SDK 11 SP4 perl Released
SUSE Linux Enterprise Server 11 SP3 LTSS perl Affected
SUSE Linux Enterprise Server 11 SP4 perl Released
SUSE Linux Enterprise Server 12 GA LTSS perl Affected
SUSE Linux Enterprise Server 12 SP1 LTSS perl Affected
SUSE Linux Enterprise Server 12 SP2 perl In progress
SUSE Linux Enterprise Server 12 SP3 perl Released