Upstream information

CVE-2018-6797 at MITRE

Description

An issue was discovered in Perl 5.18 through 5.26. A crafted regular expression can cause a heap-based buffer overflow, with control over the bytes written.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 4
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High None
SUSE Bugzilla entries: 1082234 [RESOLVED / FIXED], 1106717 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • perl >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-1328
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-730
SUSE CaaS Platform 3.0
  • perl >= 5.18.2-12.17.1
  • perl-base >= 5.18.2-12.17.1
Patchnames:
SUSE-CAASP-3.0-2018-1695
SUSE CaaS Platform ALL
  • perl >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
Patchnames:
SUSE-CAASP-ALL-2018-1328
SUSE-CAASP-ALL-2018-730
SUSE Enterprise Storage 4
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-Storage-4-2018-1328
SUSE Linux Enterprise Desktop 12 SP3
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1328
SUSE-SLE-DESKTOP-12-SP3-2018-730
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1328
SUSE Linux Enterprise Server 12 SP1-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1328
SUSE Linux Enterprise Server 12 SP2-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1328
SUSE Linux Enterprise Server 12 SP3
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1328
SUSE-SLE-SERVER-12-SP3-2018-730
SUSE Linux Enterprise Server 12-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1328
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-1328
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1328
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1328
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1328
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1328
SUSE-SLE-SERVER-12-SP3-2018-730
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1328
SUSE OpenStack Cloud 7
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1328
openSUSE Leap 42.3
  • perl >= 5.18.2-12.1
  • perl-32bit >= 5.18.2-12.1
  • perl-base >= 5.18.2-12.1
  • perl-base-32bit >= 5.18.2-12.1
  • perl-base-debuginfo >= 5.18.2-12.1
  • perl-base-debuginfo-32bit >= 5.18.2-12.1
  • perl-debuginfo >= 5.18.2-12.1
  • perl-debuginfo-32bit >= 5.18.2-12.1
  • perl-debugsource >= 5.18.2-12.1
  • perl-doc >= 5.18.2-12.1
Patchnames:
openSUSE-2018-400

List of packages in QA

Product(s) Package(s)
Openstack Cloud Magnum Orchestration 7
  • perl >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
SUSE CaaS Platform ALL
  • perl >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
SUSE Enterprise Storage 4
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Desktop 12 SP3
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server 12 SP1-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server 12 SP2-BCL
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server 12 SP2-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server 12 SP3
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server 12-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1
SUSE OpenStack Cloud 7
  • perl >= 5.18.2-12.14.1
  • perl-32bit >= 5.18.2-12.14.1
  • perl-base >= 5.18.2-12.14.1
  • perl-base-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo >= 5.18.2-12.14.1
  • perl-debuginfo-32bit >= 5.18.2-12.14.1
  • perl-debugsource >= 5.18.2-12.14.1
  • perl-doc >= 5.18.2-12.14.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 perl In progress
CaaS Platform 3.0 perl In progress
OpenStack Cloud Magnum Orchestration 7.0 perl In progress
SUSE Linux Enterprise Desktop 12 SP2 perl In progress
SUSE Linux Enterprise Desktop 12 SP3 perl In progress
SUSE Linux Enterprise SDK 11 SP4 perl Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS perl Not affected
SUSE Linux Enterprise Server 11 SP4 perl Not affected
SUSE Linux Enterprise Server 12 GA LTSS perl In progress
SUSE Linux Enterprise Server 12 SP1 LTSS perl In progress
SUSE Linux Enterprise Server 12 SP2 perl In progress
SUSE Linux Enterprise Server 12 SP2 LTSS perl In progress
SUSE Linux Enterprise Server 12 SP3 perl In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 perl In progress