Upstream information

CVE-2018-6543 at MITRE

Description

In GNU Binutils 2.30, there's an integer overflow in the function load_specific_debug_section() in objdump.c, which results in `malloc()` with 0 size. A crafted ELF file allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 5.3
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High Low
SUSE Bugzilla entry: 1079103 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • binutils >= 2.31-6.3.1
  • binutils-devel >= 2.31-6.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2265
SUSE Linux Enterprise Module for Development Tools 15
  • binutils >= 2.31-6.3.1
  • binutils-devel-32bit >= 2.31-6.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-2265

List of packages in QA

Product(s) Package(s)
Openstack Cloud Magnum Orchestration 7
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Enterprise Storage 4
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Desktop 12 SP3
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server 12 SP1-LTSS
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server 12 SP2-LTSS
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server 12 SP3
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server 12-LTSS
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1
  • binutils-devel >= 2.31-9.26.1
  • binutils-gold >= 2.31-9.26.1
  • binutils-gold-debuginfo >= 2.31-9.26.1
  • cross-ppc-binutils >= 2.31-9.26.1
  • cross-ppc-binutils-debuginfo >= 2.31-9.26.1
  • cross-ppc-binutils-debugsource >= 2.31-9.26.1
  • cross-spu-binutils >= 2.31-9.26.1
  • cross-spu-binutils-debuginfo >= 2.31-9.26.1
  • cross-spu-binutils-debugsource >= 2.31-9.26.1
SUSE OpenStack Cloud 7
  • binutils >= 2.31-9.26.1
  • binutils-debuginfo >= 2.31-9.26.1
  • binutils-debugsource >= 2.31-9.26.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
OpenStack Cloud Magnum Orchestration 7.0 binutils In progress
SUSE Linux Enterprise Desktop 12 SP2 binutils Not affected
SUSE Linux Enterprise Desktop 12 SP3 binutils In progress
SUSE Linux Enterprise Module for Basesystem 15 GA binutils In progress
SUSE Linux Enterprise Module for Development Tools 15 GA binutils In progress
SUSE Linux Enterprise SDK 11 SP4 binutils Not affected
SUSE Linux Enterprise SDK 12 SP2 binutils Not affected
SUSE Linux Enterprise SDK 12 SP3 binutils In progress
SUSE Linux Enterprise Server 11 SP4 binutils Not affected
SUSE Linux Enterprise Server 12 GA LTSS binutils In progress
SUSE Linux Enterprise Server 12 SP1 LTSS binutils In progress
SUSE Linux Enterprise Server 12 SP2 binutils Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS binutils In progress
SUSE Linux Enterprise Server 12 SP3 binutils In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 binutils In progress